-   Slackware (
-   -   Hypersensitive mouse (

Yalla-One 06-21-2007 09:56 AM

Hypersensitive mouse

I have a wireless logitech mouse that works well in Slackware, but is hypersensitive - ie. just one millimetre moving the mouse makes it travel "all over" the screen.

I've tried playing with the

Option "Resolution" "500"
settings in xorg.conf, but I can't really say it makes a difference.

I also tried playing with

xset m 1 30
for setting things there, but these options only seem to control the acceleration, and not the overall sensitivity of the mouse.

In other words, I'd like the mouse to travel a shorter pixel-distance on the screen for every millimetre I move it on my mousepad.

Anyone? Any insight greatly appreciated!

LightningCrash 06-21-2007 10:21 AM


xset m 2 4
try that out and see how it fares

if that's not enough, try


xset m 1/10 4
edit: some mice have a sensitivity that seems to only be able to change via dinking with the hardware somehow. happened to me once but i can't remember the details.

Yalla-One 06-21-2007 11:05 AM

This only controls the acceleration (ie how many pixels to travel before how much acceleration), and as such does not address the problem.

The challenge is that the mouse is too sensitive even before acceleration. When playing around to turn acceleration on, things go even more bananas.

I tried playing with the controlling files under
such as rate and resolution, by setting these values to 200 (rather than default 100). (echo -n 200 > resolution) - this makes it less bad, but still not good.

Are there further parameters possible to pass to the psmouse module (other than those controlled by the sysfs files described above) ?

Computer is a Lenovo thinkpad T60


LightningCrash 06-21-2007 11:31 AM

This might be of interest to you:

Seems like there's an app targeted specifically at Logitech beasties

simcox1 06-21-2007 11:46 AM

Does moving the wireless hub further away make any difference? Or pressing the reset?

H_TeXMeX_H 06-21-2007 01:19 PM

Which wireless logitech mouse do you have ?

These might be of use:

Yalla-One 06-22-2007 11:02 AM

Thanks for the pointers - they certainly seem to have the right approach.

I added this to lilo.conf to control the usbhid interface:

append = "usbhid.mousepoll=5"
However, this seems to turn the mouse into some sort of Frankenstein, with a life of its own.

The mouse and keyboard only says "Logitech Cordless Mouse / Logitech Cordless Keyboard" without further specification - it's rather old.

I suspect this might boil down to Linux being more strict on its hardware than Windows, but it bothers me that this detail of the system actually works better under Windows...

I also tried to play with other numbers - having mousepoll=2 (causing the resolution to be 500), was clearly way too much, but 5 (200, twice the default) seems to be the best compromise.

It's better, but still not 100%. Whenever my hands start being as jerky as the mouse currently is, I'm hopefully very very old and wise... ;-)

Thanks for the insight!


H_TeXMeX_H 06-22-2007 11:34 AM

You could always try the 'evdev' driver instead of 'mouse' driver if it is a USB mouse. See the Gentoo wiki.

Yalla-One 06-23-2007 02:53 AM

evdev crashes
Good call with evdev - thanks again!!

However, when moving to evdev as suggested, Xorg crashes and exits.

My xorg.conf contains:


Section "InputDevice"
    Identifier  "Mouse"
    Driver      "evdev"
    Option      "Name" "Logitech USB Receiver"
    Option      "CorePointer"
    # Option      "Emulate3Buttons"
    # Option      "Buttons" "7"
    # Option      "ZAxisMapping" "6 7"

and the "Name" part is based on cat /proc/bus/input/devices:


I: Bus=0003 Vendor=046d Product=c505 Version=0110
N: Name="Logitech USB Receiver"
P: Phys=usb-0000:00:1d.0-1/input1
S: Sysfs=/class/input/input5
U: Uniq=
H: Handlers=kbd mouse0 event5
B: EV=20007
B: KEY=ffffffff ffffffff ffffffff ffffffff ffffffff ffffffff ffffffff ffffffff 0
 0 1878 d800d100 1e0000 0 0 0
B: REL=103
B: LED=ff00

However - this gives the following error (and exit) when xorg starts:


(II) evdev brain: Rescanning devices (1).
(**) Option "CorePointer"
(**) Mouse-usb-0000:00:1d.0-1/input0: Core Pointer
(**) Option "CorePointer"
(**) Mouse-usb-0000:00:1d.0-1/input1: Core Pointer
(II) Mouse-usb-0000:00:1d.0-1/input1: Found 3 relative axes.
(II) Mouse-usb-0000:00:1d.0-1/input1: Configuring as pointer.
(**) Mouse-usb-0000:00:1d.0-1/input1: WHEELRelativeAxisButtons: 4 5.
(II) Mouse-usb-0000:00:1d.0-1/input1: Found 95 mouse buttons
(**) Mouse-usb-0000:00:1d.0-1/input1: Configuring 3 relative axes.
(II) Mouse-usb-0000:00:1d.0-1/input1: Configured 97 mouse buttons
(**) Option "CoreKeyboard"
(**) Keyboard0: Core Keyboard
(**) Option "Protocol" "standard"
(**) Keyboard0: Protocol: standard
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xorg"
(**) Keyboard0: XkbRules: "xorg"
(**) Option "XkbModel" "pc105"
(**) Keyboard0: XkbModel: "pc105"
(**) Option "XkbLayout" "no"
(**) Keyboard0: XkbLayout: "no"
(**) Option "CustomKeycodes" "off"
(**) Keyboard0: CustomKeycodes disabled
(WW) <default pointer>: No Device specified, looking for one...
(II) <default pointer>: Setting Device option to "/dev/input/mice"
(--) <default pointer>: Device: "/dev/input/mice"
(==) <default pointer>: Protocol: "Auto"
(**) Option "AlwaysCore"
(**) <default pointer>: always reports core events
(==) <default pointer>: Emulate3Buttons, Emulate3Timeout: 50
(**) <default pointer>: ZAxisMapping: buttons 4 and 5
(**) <default pointer>: Buttons: 9
(II) XINPUT: Adding extended input device "<default pointer>" (type: MOUSE)
(II) XINPUT: Adding extended input device "Keyboard0" (type: KEYBOARD)
(II) XINPUT: Adding extended input device "Mouse-usb-0000:00:1d.0-1/input1" (type: KEYBOARD)
(II) XINPUT: Adding extended input device "Mouse-usb-0000:00:1d.0-1/input0" (type: KEYBOARD)
(II) XINPUT: Adding extended input device "evdev brain" (type: evdev brain)
(II) Mouse-usb-0000:00:1d.0-1/input0: Init
(**) Mouse-usb-0000:00:1d.0-1/input1: 3 valuators.
(**) evdev_btn.c (166): Registering 97 buttons.
(II) Mouse-usb-0000:00:1d.0-1/input1: Init
(II) evdev brain: Rescanning devices (2).
(II) Mouse-usb-0000:00:1d.0-1/input0: On
(II) Mouse-usb-0000:00:1d.0-1/input1: On
(--) <default pointer>: PnP-detected protocol: "ExplorerPS/2"
(II) <default pointer>: ps2EnableDataReporting: succeeded

0: /usr/bin/X(xf86SigHandler+0x84) [0x80c5404]
1: [0xb7f81420]
2: /usr/bin/X(main+0x6b5) [0x8070455]
3: /lib/ [0xb7d8adf8]
4: /usr/bin/X(FontFileCompleteXLFD+0x1e1) [0x806f561]

Fatal server error:
Caught signal 11.  Server aborting

Is this an xorg bug, or yet another user error on my end?

Thanks much for all the insight so far - I really hope to be able to solve this one and heal the spastic mouse


regis_n_bits 06-23-2007 04:23 AM

Try adding the "Device" option to the InputDevice section. For your setup it would be:

Section "InputDevice"
    Identifier  "Mouse"
    Driver      "evdev"
    Option      "Device" "/dev/input/event5"
    Option      "Name" "Logitech USB Receiver"
    Option      "CorePointer"
    # Option      "Emulate3Buttons"
    # Option      "Buttons" "7"
    # Option      "ZAxisMapping" "6 7"

The value "event5" comes from your /proc/bus/input/devices.

I have also seen Xorg crash in a similar way when I tried using the evdev driver with using the Name option alone (different mouse in my case - Microsoft). Adding the "Device" option fixed it for me.

Yalla-One 06-23-2007 05:46 AM


Originally Posted by regis_n_bits
Try adding the "Device" option to the InputDevice section.

Thanks much - you're a star! By adding the device it works like a charm.

However, since moving to evdev I lost the scrollwheel.

By following the Gentoo wiki I ran the command:

xmodmap -e "pointer = 1 3 2 4 5 8 9 6 7 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32"
It sort of does the trick, as the scroll wheel works, but now the middle and right mousebutton are switched.

This seems to be an area of relatively poor documentation - any insight on how I get scroll and "paste" on middle button, and normal right-click on the right button?

Thanks again for your insight!

Yalla-One 06-23-2007 09:55 AM

There seems to be nothing like "random" experiments...

The following xmodmap statement did the trick:

pointer = 1 2 3 4 5 7 6 8 9 10 11 12

Thanks to all who contributed!

H_TeXMeX_H 06-23-2007 01:00 PM

Good. Post back if you have problems ...

All times are GMT -5. The time now is 05:52 AM.