-   Slackware (
-   -   Humble bundle Multi-lib issue (

D1ver 04-13-2011 07:36 AM

Humble bundle Multi-lib issue
I've bought the latest humble bundle and am having trouble installing a few of the games.

Upon running the installer i get the following error

error while loading shared libraries: cannot open shared object file: No such file or directory
I have a /usr/lib64/ but nothing in /usr/lib. I've ran through the multi-lib setup as per but it still doesn't seem to work.

Any help is appreciated..

ponce 04-13-2011 07:44 AM

if /usr/lib is empty, probably you haven't installed the compat32 libs

Alien Bob 04-13-2011 07:58 AM

It's something different.
I do not include the l/libglade package in my set of mass-converted packages.
What you'd have to do is grab the 32bit libglade package from a Slackware mirror, and use the command "convertpkg-compat32" to convert this package for use in a multilib environment. Once you have this package installed, the probability is higher that your game installer works.


TL_CLD 04-13-2011 09:27 AM

D1ver your game will work if you do what Alien Bob says. I did just that this morning, and voila my Shadowground game worked a charm.

lumak 04-13-2011 02:49 PM

Nice to know what I need when I get there.

I'm still playing Trine... damn ps3 controller took forever to get up and running.
-joystick package from Slackbuilds
-jscal to calibrate
-output calibration to the file to set a dead zone
-sent the calibration file back to jscal
-realized I couldn't shoot arrows or block with the shield regardless of pushing the right control stick
-found the config file and set it to be triggered by a button instead of joy-rx-any,joy-ry-any and I can still control the movement of those actions with the right stick.
-stopped using compiz since I was having speed issues :/

I forgot why I stopped playing games on Windows and Linux. I'd rather it just work with the intended platform and already have good configurations for the controller (yes the keyboard probably works fine. But I wanted a controller)

D1ver 04-13-2011 04:09 PM

Thank you AlienBob, I'll try that and mark thread as solved when I get home from work.

Alien Bob 04-13-2011 06:25 PM


Originally Posted by D1ver (Post 4323779)
Thank you AlienBob, I'll try that and mark thread as solved when I get home from work.

For slackware-current I already fixed it in by adding "l/libglade" to the script. I also updated the collection of "pre-converted" packages in ... the libglade package is already in there.

If you do not run Slackware-current yet, but for instance Slackware 13.1 or 13.0 you can still grab the compat32-tools package from the "current" directory because that works equally well on these older releases:


D1ver 04-14-2011 04:05 AM

Reran the multilib set up and now everything is working beautifully. Thanks! :)

samac 04-17-2011 03:14 PM

Just thought that I would make this thread go to the top again.

Not bad games at a price you can afford and you can donate to charity at the same time.

Shadowgrounds and Shadowgrounds-Survivor work perfectly on Slackware-13.1.


disturbed1 04-17-2011 04:23 PM

We've purchased all 3 HIB's. Great games.

Trine is an awesome game!!

D1ver 04-17-2011 05:02 PM


Originally Posted by disturbed1 (Post 4327350)
We've purchased all 3 HIB's. Great games.

Trine is an awesome game!!

Trine had me hooked. The environments are beautiful and the puzzles Are very entertaining. I found it very charming heh

lumak 04-17-2011 07:07 PM

In Trine, it was a bit too easy to ruin the intent of the out of reach green vials by jumping above a cube and using it as a floating platform. But interesting and fun.

All times are GMT -5. The time now is 08:11 PM.