-   Slackware (
-   -   huge problem with power management and screensaver (

Xavius 01-04-2005 08:07 AM

huge problem with power management and screensaver
I have a big problem with Slackware Current and Power Management. If it is disabled, of course, no problem.
But if I enable it, it "starts" at random.

Example: I set monitor "Standby after 20 min" but sometimes the monitor goes standby after few minutes, and when I'm "currently" using Linux (surfing, typing, etc.)
BUT if I don't use / touch pc for 20 min. sometimes it starts sometimes not.

The same for screensaver.... after the given time, sometimes it starts, sometimes not.

someone has experienced this problem before? what can I try? (right I can disable Power Management, but it's not really a "solution")
It's a really weird problem and I don't know how approach to it

thanks a lot!

slackie1000 01-04-2005 08:52 AM

hi there,

to be able to answer this questions, people here will ask more input:

1. APM or ACPI
2. kernel messages => dmesg | grep -i error
3. KDE ??
4. Laptop ?? if yes, type?




Xavius 01-04-2005 01:30 PM

1) how can I see if I'm using apm or acpi?
2) I'm not in front of my linux box right now. I will check and post.
3) I'm using KDE
4) No, it's not a laptop

slackie1000 01-04-2005 02:48 PM

hi there,

welcome Xavius! it was a coincidence that i replied both questions. :D

so, to check what you are running there is not a standard answer.
let's try that. please, post the ouput of:

ll /proc/acpi
this can also be BIOS dependent. some BIOS uses APM, that IMHO is worst than ACPI. But anyway we need to check what is up in your system.
about kde, i am sorry. i know sh*** about that. i just hope that kde has no applications that are using your power management. you can check that try another DE. Ex. wmaker, fluxbox,etc.
the ouput of dmesg is fundamental. it is important to see which modules are being loaded by the kernel.
i am not an expert. like *almost everybody* here i am a newbie. i just tried to help you to put better boundary conditions to your problem.
hope some guru join us here.



Xavius 01-05-2005 04:04 PM

what do you mean with "ll /proc/acpi" i don't have ll command

btw, I think I'm using apm beacuse when I do the shutdown, there is messagge that say "apm daemon etc etc"
how can I disable apm and try acpi? I think acpi is better too, and maybe this could solve my problem.... I hope :rolleyes:

thanks for your support!
happy new year!!!!!!!!!!!

slackie1000 01-06-2005 03:38 AM

hi there,

sorry! 'll' is an alias for 'ls -lrt'. my bad.
ok. take a look at your BIOS and be sure that the apm things support are disable.
second post the output of

ls /proc/acpi

after that find your '.config' - from the kernel - and post

grep -i ACPI .config
grep -i APM .config

and keep posting...

happy new year also...



All times are GMT -5. The time now is 06:22 AM.