-   Slackware (
-   -   hplip / HP Deskjet D4160 install help (

soylentgreen 05-25-2007 04:41 PM

hplip / HP Deskjet D4160 install help
i followed the how-to here

but i'm having problems.

i installed the D4160 using the hpjs foomatic D4100 driver, but when it asked for the URI, i entered:

because there was no drop down list, or anything that even looked like it was seeing the printer...

dmesg shows:

hub.c: USB hub found
hub.c: 2 ports detected
hub.c: new USB device 00:1f.2-1.1, assigned address 7
printer.c: usblp0: USB Bidirectional printer dev 7 if 0 alt 0 proto 2 vid 0x03F0 pid 0x7704
and lsusb shows:

Bus 001 Device 007: ID 03f0:7704 Hewlett-Packard
when sending a test page, it doesn't blink, or do anything...

(i had tried using just the ppd file and install it the 'old fashioned' way before i found out about the HPLIP engine, and it at least was blinking like it was taking a job, even though it wouldn't print.. but now its simply doing nothing.

anyone have any luck installing the D4160 or any D4100 on slackware? and if so, do you mind helping me? I had an HP Deskjet 1220C that worked just fine under CUPS/SAMBA and my wife went out and bought this **thing** and wanted me to install it. i'm ready to take it back because unless i can get it installed.

please assist?!

BCarey 05-25-2007 05:26 PM

First try the hplip package from slackware's /testing directory.


sn9ke_eyes 05-25-2007 05:29 PM

I have used an F380 and C6180 both on Slackware 11.

I think there's a config script like hpconfig or hplipconfig isn't there ? I don't have access to that system right now.

Are you using KDE ? Does the HP toolbox see your printer ?

H_TeXMeX_H 05-25-2007 07:24 PM

You can also try my instructions here:

(this worked for me ...) and, I think you can use the latest hplip, I just haven't updated the link.

soylentgreen 05-26-2007 04:19 PM

it was not being seen by the system as a valid printer (hp-toolbox) and it was not listed under usb printers in the kde kaddprinterwizard..


Originally Posted by BCarey
First try the hplip package from slackware's /testing directory.


well i went in and did a

make uninstall
then installed the one from /testing (didn't know it was there - thanks)

after rebooting, i got the thing to print locally, but now im having issues sharing it out.

the machine that its on is the headless server, but none of the clients can see it.. i have a winXP box and a xubuntu laptop.

whenever i go in to SAMBA/swat and try to share it out, it keeps reverting to available 'no' in the swat tool.

when i tried to print to it using cups from the ubuntu laptop, it queued up a 48126k job (48MB!!) which didn't print.

i have some time to play with it .. it came with a 14-day return policy.. i'm a little happier at least i got it to print, just need to get it shared out now.

i appreciate your advice so far, any other ideas? i can post my logs if they would help.


soylentgreen 05-26-2007 06:29 PM

maybe solved..
well i manually edited my smb.conf.


        comment = Deskjet D4160
        path = /var/spool/samba
        printable = Yes
        available = Yes
        use client driver = Yes
        printcap name = cups

and it seems to be shared now..

i think i have the 'known issue' where you have to turn the pig off after each job...

i hope something gets updated with that..

so i've got the 1.6.9 tgz install of it.. and it seems to be at least printing.

thanks for the advice.. i really appreciate it.

soylentgreen 05-27-2007 05:53 PM

what a pain in the a$$.

sure, it works...

and after every single print job you have to go in to the CUPS manager and START the printer, because it pauses itself.

this baby is going back.. from what i've heard a Deskjet 5440 or a 5940 might be in my future..

the D in D4160 apparently means Dont buy it if you run Linux.

H_TeXMeX_H 05-27-2007 06:31 PM

Try upgrading some stuff ... maybe samba or cups ... no need to return a printer for such a thing.

All times are GMT -5. The time now is 01:53 AM.