-   Slackware (
-   -   hp deskjet 1000 j110 ink level error (

waddles 03-02-2013 04:46 PM

hp deskjet 1000 j110 ink level error
I put in new black ink cartridge and have written less than 6 pages of text. When I run hp-levels (always worked before) I get: error: Channel write error. On a Slackware 13.37 platform. Won't print because of low ink level error. Any ideas? BTW no ink puddles in side.

frankbell 03-02-2013 08:47 PM

My hp-levels seems to working okay on --Current.

Can you log into the printer directly and check the ink levels? My HP (wired network) has a web interface accessible in the browser.

Perhaps hp-levels is just telling you what the printer is telling it. Could be a bum cartridge. It's rare with HP, I know, but I've had it happen with other makes.

waddles 03-03-2013 12:37 AM

Both the command line HP-levels and the "hp device manager" show low ink. Since it was printing until recently think the cartridge is less likely to be the problem.
I am not certain of what U mean by logging in to the printer? Is that the http://localhost/631 CUPS interface that U refer to?
I went there and went into the log file to find the error which told me little more than the error: Channel write error which I get from dmesg and the printer responding.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 0c45:60fc Microdia PC Camera with Mic (SN9C105)
Bus 001 Device 005: ID 03f0:8811 Hewlett-Packard
hp-info gives:
error: Unable to communicate with device (code=12): hp:/usb/Deskjet_1000_J110_Series?Serial=CN17R25NC405D2
error: Unable to open device hp:/usb/Deskjet_1000_J110_Series?Serial=CN17R25NC405D2.

hp-probe yields:
Num Connection Description Type
-------- ---------- ----------------------------------------------------------
0* usb Universal Serial Bus (USB)
1 net Network/Ethernet/Wireless (direct connection or JetDirect)
Enter number 0...1 for connection type (q=quit, enter=usb*) ? 0
Using connection type: usb
Device URI Model
------------------------------------------------------ ---------------------------
hp:/usb/Deskjet_1000_J110_series?serial=CN17R25NC405D2 HP Deskjet 1000 J110 series
Found 1 printer(s) on the 'usb' bus.
[Empty lines removed]

I am unable to print even the test page though.
The printer device manager is providing no help at all.
Does this help?

tronayne 03-03-2013 07:38 AM

This might be a good time to upgrade HPLIP to the current version (you're probably running an old version, the current is hplip-3.13.2). That should take care of a lot of glitches (but you may have a bum ink cartridge in any event or just take it out and clean off the contacts in the printer and on the cartridge with a Q-tip, maybe with a little lighter fluid, which is chloroethane, maybe try it dry first).

You can download the source and SlackBuild from get all the files then compile by executing

su -
sh hplip.SlackBuild
<wait a while>
<pay attention to where the Slackware package is, probably /tmp>
upgradepkg <path-to>/hplip*.t?z

HPLIP has improved a lot, worth your time to do this.

Hope this helps some.

frankbell 03-03-2013 08:16 PM

As for logging into the printer, mine has a static ip address in my network. I can access the printer directly in the browser by going to http://[printer_ip_address].

waddles 03-04-2013 04:29 AM

During my trials with this printer which lasted for nearly a year (will never buy another HP product), I finally had to degrade to the HPIJS because the 3.11.3a of HPLIP which was supposed to be compatible was NOT. I had tried the download and compile approach before. Leave it to say I won't go there again as the results did not improve.
Like I said tho it was working fine then went kaput! My concern if for fumble fingers of late that I may have triggered something inadvertently. Managed to convert from 2 to 4 layer workspace yesterday that way.
Re: cleaning ports, yea been there too.
Printer is usb connected to platform.

All times are GMT -5. The time now is 10:50 PM.