Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 11-27-2008, 11:23 AM   #16
Senior Member
Registered: Sep 2004
Location: Nashville
Distribution: Manjaro, RHEL, CentOS
Posts: 2,098

Rep: Reputation: 102Reputation: 102

didn't see this suggested or maybe it was and I glanced over it but you can initiate the following.
shutdown -hP now
this will try to power down the server as long as your acpi supports it. But yes when your system says it is halted it can be manually powered down.
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 11-27-2008, 11:35 AM   #17
Senior Member
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 231Reputation: 231Reputation: 231
I thought Slackware was set up so that pressing (not holding) the power button will shut everything down. Additionally can't you always 'sudo init 0' ??
Running init 0 as root will call rc.0 effectively shutting down the machine but the powerdown problem will be the same as if running poweroff or shutdown -h now had been ran. The problem is usually with a kernel setting which may be fixed by passing a boot time parameter.

Last edited by bgeddy; 11-27-2008 at 11:37 AM.
Old 11-27-2008, 12:21 PM   #18
Senior Member
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 544Reputation: 544Reputation: 544Reputation: 544Reputation: 544Reputation: 544
It stayed like before, on System halted.
If the computer BIOS and power supply do not support APM or ACPI then you will not be able to enjoy automatic power down. I have a box with a 1997 Asus TXP4 motherboard (Socket 7) that supports APM but not ACPI. The power supply does not support either therefore I cannot power down the box automatically. When the screen displays 'system halted' I then manually press the power button.

If you believe the power supply and BIOS support power management, and the box was built before the year 2000, then as previously suggested consider disabling acpi (acpi=off) and use APM. If I recall correctly, however, the stock Slackware huge kernel does not have APM built in. You'll have to recompile the kernel to obtain APM features.

If you are interested in using APM then perhaps the following might help:

Configuring the APM Daemon
1 members found this post helpful.
Old 11-27-2008, 02:10 PM   #19
Registered: Jul 2007
Distribution: Slackware 14
Posts: 237
Blog Entries: 8

Rep: Reputation: 59
Am I missing why I can't just use
Old 11-27-2008, 02:22 PM   #20
Registered: Jan 2005
Location: Istanbul, Turkey
Distribution: Slackware64 14.2, Slackwarearm-current
Posts: 962

Rep: Reputation: 110Reputation: 110
Originally Posted by Woodsman View Post
If the computer BIOS and power supply do not support APM or ACPI then you will not be able to enjoy automatic power down.
I have a PIII Dell Optiplex GX110 from 1997, though not with me right now, but it should at least support APM. I remember using Slackware >=10 and some other distros on it and automatic shutdown was working.
Old 11-27-2008, 02:29 PM   #21
Senior Member
Registered: May 2008
Posts: 4,408
Blog Entries: 7

Rep: Reputation: 1859Reputation: 1859Reputation: 1859Reputation: 1859Reputation: 1859Reputation: 1859Reputation: 1859Reputation: 1859Reputation: 1859Reputation: 1859Reputation: 1859
My Dell XPS P3-800 works just fine under slackware. When I switch off, I just logout, press the power button on the front panel and it runs shutdown for me. When I tried OpenBSD on this same hardware, I was getting the same problem as you describe with slackware. I get the feeling these early APM systems were a bit hit and miss.
Old 11-27-2008, 02:49 PM   #22
Amigo developer
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,855

Rep: Reputation: 547Reputation: 547Reputation: 547Reputation: 547Reputation: 547Reputation: 547
Try to find out if your BIOS supports acpi or apm:
dmesg |grep acpi
dmesg |grep apm

I too, would most likely try using apm on an older machine. In that case you'd need to make sure the apm kernel module is loaded before shutting doen with 'poweroff'. I use a home-made shutdown GUI that mdoprobes the apm module before shutting down, if ti isn't already loaded.
You may alos need to adjust your BIOS settings. Some BIOS'es can use either apm or acpi, so you may be able to choose which way to go.
Old 11-27-2008, 04:32 PM   #23
Registered: Nov 2005
Location: Diessen, The Netherlands
Distribution: Slackware 14.2
Posts: 661

Rep: Reputation: 38
I've been struggling with this matter on one machine (P4, 2005) for quite some time now and haven't solved it so far.
As far as I know, you cannot get APM to work on a SMP-kernel (correct me if I'm wrong). Building my own kernel didn't work either, so I'm curious, has anyone gotten this to be solved by using the non-smp-kernel?

Just tried that, no such luck...

Last edited by adriv; 11-27-2008 at 05:05 PM.



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Howto shutdown power Management mickeyboa Fedora 1 04-24-2006 11:56 PM
howto map localhost correctly? computerdaves Fedora 10 02-08-2005 03:54 PM
script to shutdown system - howto matthewchin Linux - General 5 07-11-2004 11:11 PM
Graceful shutdown.. howto? rohan208 Linux - General 5 05-16-2004 02:39 PM
howto mirror a man page correctly bronko Linux - Newbie 2 03-15-2004 10:05 AM > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:14 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration