LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 12-02-2018, 10:51 PM   #1
Lockywolf
Member
 
Registered: Jul 2007
Posts: 143

Rep: Reputation: 31
How to turn off cpu frequency scaling completely for Intel cpus?


Hello, everyone.

I want to compile ATLAS from SBo. No matter how I try (cpufreq-set, powersave governor, etc), ATLAS detects cpu scaling and doesn't compile.

I have an intel cpu:

Code:
root@delllaptop:/opt/anaconda3# cat /proc/cpuinfo 
processor	: 0
vendor_id	: GenuineIntel
cpu family	: 6
model		: 42
model name	: Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz
stepping	: 7
microcode	: 0x15
cpu MHz		: 2453.262
cache size	: 3072 KB
physical id	: 0
siblings	: 4
core id		: 0
cpu cores	: 2
apicid		: 0
initial apicid	: 0
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx lahf_lm epb pti tpr_shadow vnmi flexpriority ept vpid xsaveopt dtherm arat pln pts
bugs		: cpu_meltdown spectre_v1 spectre_v2 spec_store_bypass
bogomips	: 4988.52
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
power management:

processor	: 1
vendor_id	: GenuineIntel
cpu family	: 6
model		: 42
model name	: Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz
stepping	: 7
microcode	: 0x15
cpu MHz		: 2402.434
cache size	: 3072 KB
physical id	: 0
siblings	: 4
core id		: 1
cpu cores	: 2
apicid		: 2
initial apicid	: 2
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx lahf_lm epb pti tpr_shadow vnmi flexpriority ept vpid xsaveopt dtherm arat pln pts
bugs		: cpu_meltdown spectre_v1 spectre_v2 spec_store_bypass
bogomips	: 4988.52
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
power management:

processor	: 2
vendor_id	: GenuineIntel
cpu family	: 6
model		: 42
model name	: Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz
stepping	: 7
microcode	: 0x15
cpu MHz		: 2468.559
cache size	: 3072 KB
physical id	: 0
siblings	: 4
core id		: 0
cpu cores	: 2
apicid		: 1
initial apicid	: 1
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx lahf_lm epb pti tpr_shadow vnmi flexpriority ept vpid xsaveopt dtherm arat pln pts
bugs		: cpu_meltdown spectre_v1 spectre_v2 spec_store_bypass
bogomips	: 4988.52
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
power management:

processor	: 3
vendor_id	: GenuineIntel
cpu family	: 6
model		: 42
model name	: Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz
stepping	: 7
microcode	: 0x15
cpu MHz		: 2477.798
cache size	: 3072 KB
physical id	: 0
siblings	: 4
core id		: 1
cpu cores	: 2
apicid		: 3
initial apicid	: 3
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx lahf_lm epb pti tpr_shadow vnmi flexpriority ept vpid xsaveopt dtherm arat pln pts
bugs		: cpu_meltdown spectre_v1 spectre_v2 spec_store_bypass
bogomips	: 4988.52
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
power management:
Any suggestions on how to compile ATLAS?

Would rebooting with 'init=/bin/sh' help?

Hardware frequency scaling is turned off in BIOS, or it is turned off as much as possible, although I guess that some resigual scaling, to avoid a burndown cannot be turned off through the stock BIOS interface.
 
Old 12-03-2018, 02:07 AM   #2
Keruskerfuerst
Senior Member
 
Registered: Oct 2005
Location: Horgau, Germany
Distribution: Kubuntu 18.04, Manjaro, Win 10
Posts: 2,159

Rep: Reputation: 158Reputation: 158
Can you show the compile error ?

And: the cpu frequency scaling should not be turned off at all.

Last edited by Keruskerfuerst; 12-03-2018 at 02:54 AM.
 
Old 12-03-2018, 12:37 PM   #3
fskmh
Member
 
Registered: Jun 2002
Location: South Africa
Distribution: Custom slackware64-current
Posts: 270

Rep: Reputation: 66
I switched to OpenBLAS quite a few years ago but back when I did use ATLAS I had this in my build script:

Code:
../configure -Si cputhrchk 0
I don't know if that option is still supported but try it and see.
 
Old 12-03-2018, 01:21 PM   #4
phenixia2003
Member
 
Registered: May 2006
Location: France
Distribution: Slackware
Posts: 839

Rep: Reputation: 709Reputation: 709Reputation: 709Reputation: 709Reputation: 709Reputation: 709Reputation: 709
Hello,

Quote:
Originally Posted by Lockywolf View Post
Hello, everyone.

I want to compile ATLAS from SBo. No matter how I try (cpufreq-set, powersave governor, etc), ATLAS detects cpu scaling and doesn't compile.

I have an intel cpu:

Code:
root@delllaptop:/opt/anaconda3# cat /proc/cpuinfo 
model name	: Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz
Any suggestions on how to compile ATLAS?

Would rebooting with 'init=/bin/sh' help?

Hardware frequency scaling is turned off in BIOS, or it is turned off as much as possible, although I guess that some resigual scaling, to avoid a burndown cannot be turned off through the stock BIOS interface.
The scaling driver for your CPU must be intel_pstate. It can be disabled by passing intel_pstate=disable to the kernel.


--
SeB
 
Old 12-03-2018, 02:49 PM   #5
philanc
Member
 
Registered: Jan 2011
Posts: 181

Rep: Reputation: 147Reputation: 147
Quote:
Originally Posted by Lockywolf View Post
I want to compile ATLAS from SBo. No matter how I try (cpufreq-set, powersave governor, etc), ATLAS detects cpu scaling and doesn't compile.
Have you tried running
Code:
/etc/rc.d/rc.cpufreq performance
as root,
before building ATLAS?

(as suggested in README.SLACKWARE, in file atlas.tar.gz on SBo -- see section INSTALLATION DETAILS, item 1)

Last edited by philanc; 12-03-2018 at 02:50 PM.
 
Old 12-03-2018, 05:37 PM   #6
wigums
Member
 
Registered: Oct 2013
Location: Detroit
Distribution: slackware and raspbian
Posts: 55

Rep: Reputation: Disabled
Quote:
chmod -x /etc/rc.d/rc.cpufreq && /etc/rc.d/rc.cpufreq stop
(you dont have chmod it just for a build. you can stop it then restart it when your done)

https://www.slackwiki.com/CPU_Frequency_Scaling

Last edited by wigums; 12-04-2018 at 05:02 AM.
 
  


Reply

Tags
compiling, cpu frequncy scaling


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Set Clock Frequency on a Frequency Scaling Disabled Kernel mobin.seven Linux - Kernel 3 02-18-2017 11:33 PM
[SOLVED] Kernel config CPU Frequency Scaling / module and Intel "Turbo boost" behaviour zeebra Linux - Kernel 3 09-29-2013 05:39 PM
cpu frequency scaling with Pentium(R) Dual-Core CPU E5200 @ 2.50GHz tramni1980 Slackware 5 08-16-2009 09:29 AM
cpu frequency scaling....anyone? alaios Linux - General 3 06-07-2005 11:51 AM
CPU frequency scaling on Pentium M Khang Linux - Laptop and Netbook 2 03-23-2005 07:16 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration