LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-01-2004, 06:37 AM   #1
Smaugur [SWE]
LQ Newbie
 
Registered: Mar 2004
Location: STOCKTOWN/SWEDEN
Distribution: Slackware
Posts: 5

Rep: Reputation: 0
How to stop the BEEP sound?


Example: When I press backspace in the shell in front of the prompt I hear this annoying beep! sound and I want to turn it of.

But I also want to be able to listen to MP3s if i want to.

So how do I do this?



I have a laptop Compaq Armada 7800 with a pentium II processor and 96 mb ram with Slackware 9.0
 
Old 04-01-2004, 08:19 AM   #2
OdieQ
Member
 
Registered: Jan 2004
Location: Stockholm, Sweden
Distribution: Debian, Slackware
Posts: 71

Rep: Reputation: 15
Bash bell

On some soundcards, you can set the volume of the bell independantly, with the "speaker" setting in the mixer.

You can also disable the audible bell altogether by putting "set bell-style none" in your ~/.inputrc. If you still want to notified of bell events, set the bell style to "visible" instead. This will blink the screen instead of beeping (I am not saying this is any less irritating, though...).

Cheers,
Odie
 
Old 04-01-2004, 12:48 PM   #3
IRIGHTI
Member
 
Registered: Oct 2003
Distribution: Slackware64 13.1 x86_64, Ubuntu 10.04 x86_64
Posts: 121

Rep: Reputation: 15
i'm pretty sure it is a kernel config option that you just take out. Don't quote me on on that though. I think I took it out, when i recompiled because i don't have it anymore.
 
Old 04-01-2004, 05:34 PM   #4
Toth
Member
 
Registered: Aug 2003
Posts: 83

Rep: Reputation: 15
Quote:
Originally posted by IRIGHTI
i'm pretty sure it is a kernel config option that you just take out. Don't quote me on on that though. I think I took it out, when i recompiled because i don't have it anymore.
Only in 2.6.x IIRC.
 
Old 04-10-2004, 02:16 PM   #5
guest
Member
 
Registered: May 2003
Distribution: CentOS 5 64 bit
Posts: 255

Rep: Reputation: 30
THANKS GOD

THANK U!!!

I really hate this beeep beeeppppp beeeepppp, it make me mad!!
And if i work some hours on vmware with linux and its beep and beep i realy want take my notebook and plonk it on the wall....

THANKS!!
 
Old 03-20-2009, 01:31 AM   #6
Crummy
LQ Newbie
 
Registered: Mar 2009
Posts: 3

Rep: Reputation: 0
Quote:
Originally Posted by OdieQ View Post

You can also disable the audible bell altogether by putting "set bell-style none" in your ~/.inputrc.
How do I do that? I'm completely new to linux and have Fedora 10
 
Old 03-20-2009, 06:00 AM   #7
Yalla-One
Member
 
Registered: Oct 2004
Location: Norway
Distribution: Slackware, CentOS
Posts: 640

Rep: Reputation: 36
Quote:
Originally Posted by Crummy View Post
How do I do that? I'm completely new to linux and have Fedora 10
If you want to set it for only your own user, you type
Code:
echo "set bell-style none" >$HOME/.inputrc
If you have multiple users, you can open /etc/inputrc in your favourite editor and search for the lines that say:
Code:
# Configure the system bell.  Options are none, visible, and audible.
#set bell-style none
Just remove the # in front of set bell-style none, and you have taken it away system-wide.

PS. Since this is a Slackware forum I posted the Slackware response, but this is pretty standard across distributions, so while I haven't been on a RedHat derivative for a while I assume it's still somewhat valid.
 
Old 03-20-2009, 07:02 AM   #8
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
lsmod
rmmod pcspkr (if exists)

add to blacklist if loaded on boot

Last edited by Alien_Hominid; 03-20-2009 at 07:03 AM.
 
Old 03-21-2009, 10:18 PM   #9
Crummy
LQ Newbie
 
Registered: Mar 2009
Posts: 3

Rep: Reputation: 0
Where would I type in the code at? I'm sorry but I'm really new lol.

I did disable it though finally through the sound manager thing but I never had that happen on windows and never had a sound control that control that kind of beep so it took me a while to figure that out.

Last edited by Crummy; 03-21-2009 at 10:20 PM.
 
Old 03-22-2009, 08:44 AM   #10
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,044

Rep: Reputation: 150Reputation: 150
Quote:
Originally Posted by Crummy View Post
Where would I type in the code at? I'm sorry but I'm really new lol.

I did disable it though finally through the sound manager thing but I never had that happen on windows and never had a sound control that control that kind of beep so it took me a while to figure that out.
There are two kinds of beeps, one from your sound card, which can be disabled using the mixer; the other from the speaker port on your mother board, which is controlled via the IO ports 0x42 and 0x43. For the latter one, you can blacklist the pcspkr module. However, it's blacklisted by default in Slackware (see "/etc/modprobe.d/blacklist").
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
about internet sharing and beep sound fisayo SUSE / openSUSE 3 09-26-2005 04:13 PM
how to remove the beep sound libertine Linux - Software 1 07-23-2005 11:36 PM
no sound and strange beep gagaman Linux - Newbie 2 07-19-2004 04:33 PM
Consident BEEP Sound problem kjp_72 Linux - Newbie 3 05-24-2004 06:00 PM
Default Beep and the No Sound chem1 Linux - Hardware 2 04-28-2003 08:59 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 02:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration