LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-09-2009, 02:18 PM   #1
danielldaniell
Member
 
Registered: Apr 2009
Location: Hungary
Distribution: Slackware, OpenBSD
Posts: 50

Rep: Reputation: 16
how to stop automatically bringing up a network interface at boot


Hi!

So far when I boot Slackware(-current) it brings up all my network devices.
Can I configure it somehow to not bring up any network interface at boot, so I can manually enable them (be it wireless or wired)?
 
Old 07-09-2009, 03:06 PM   #2
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 9,255

Rep: Reputation: 4074Reputation: 4074Reputation: 4074Reputation: 4074Reputation: 4074Reputation: 4074Reputation: 4074Reputation: 4074Reputation: 4074Reputation: 4074Reputation: 4074
This is controlled by /etc/rc.d/rc.inet1.conf.
 
Old 07-09-2009, 03:31 PM   #3
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 231Reputation: 231Reputation: 231
Have a look at Alien Bob's wiki page for setting up your network.
 
Old 07-09-2009, 04:25 PM   #4
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,391

Rep: Reputation: Disabled
chmod -x /etc/rc.d/rc.inet1

But then you would either need to chmod +x to start it manually, or use wicd for example.
 
Old 07-09-2009, 08:46 PM   #5
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 231Reputation: 231Reputation: 231
Quote:
chmod -x /etc/rc.d/rc.inet1
The problem with this is that /etc/rc.d/rc.inet1 also brings up the loopback interface with 127.0.0.1. I don't think it's a good idea to not have this in place. If you must keep all interfaces down I think you'd be better editing /etc/rc.d/rc.inet1.conf to remove both DHCP and static IP assignments which will keep the interfaces down.
 
Old 07-09-2009, 09:10 PM   #6
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,391

Rep: Reputation: Disabled
Yes you are right. I typed in haste.
 
Old 07-09-2009, 09:46 PM   #7
BrZ
Member
 
Registered: Apr 2009
Distribution: Slackware
Posts: 542

Rep: Reputation: 120Reputation: 120
Can he just turn it off on rc.local, like adding /etc/rc.d/rc.inet1 eth0_stop? Same for dhcpd and IP? I think he'll need loopback (127.0.0.1) locally, but it's not mandatory. My newbiness keeps bugging me with direct messing with rc.inet1, as for most time I just edited rc.inet1.conf...
 
Old 07-09-2009, 09:51 PM   #8
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Gentoo (all servers at work are openSUSE)
Posts: 6,938

Rep: Reputation: 128Reputation: 128
Quote:
Originally Posted by danielldaniell View Post
Hi!

So far when I boot Slackware(-current) it brings up all my network devices.
Can I configure it somehow to not bring up any network interface at boot, so I can manually enable them (be it wireless or wired)?
If that is your goal, perhaps wicd is what you'd prefer to use.

Be sure to read README.SLACKWARE so you set it up properly.

Once wicd is running, you can tell it to automatically connect,
or not to do so.
 
Old 07-10-2009, 06:06 AM   #9
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 231Reputation: 231Reputation: 231
Quote:
Can he just turn it off on rc.local, like adding /etc/rc.d/rc.inet1 eth0_stop?
Yes he could add "/etc/rc.d/rc.inet1 stop" to send them all down but it just seems a little strange sending them up - waiting for DHCP (if that's how the interfaces are set up) and then sending them down again ! Maybe, as Bruce Hill says, wicd is the way to go. There are lots of ways to control this - Slackware never forces you into one way of doing things !!
 
Old 07-10-2009, 09:37 PM   #10
stureedy
Member
 
Registered: Jul 2009
Location: Lexington, Kentucky, USA
Distribution: Slackware
Posts: 43
Blog Entries: 4

Rep: Reputation: 2
Perhaps I'm missing something, but can't one just edit /etc/rc.d/rc.inet1.conf and set IPADDR, NETMASK and USE_DHCP to "" for each network interface?

I believe that will activate loopback and nothing else. Then one could use WICD or the like to manage the interfaces.

My $0.02
 
Old 07-10-2009, 09:39 PM   #11
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Gentoo (all servers at work are openSUSE)
Posts: 6,938

Rep: Reputation: 128Reputation: 128
Welcome to LQ!

You are exactly correct.
 
Old 07-13-2009, 02:43 AM   #12
danielldaniell
Member
 
Registered: Apr 2009
Location: Hungary
Distribution: Slackware, OpenBSD
Posts: 50

Original Poster
Rep: Reputation: 16
no luck for me

Quote:
Originally Posted by stureedy View Post
Perhaps I'm missing something, but can't one just edit /etc/rc.d/rc.inet1.conf and set IPADDR, NETMASK and USE_DHCP to "" for each network interface?

I believe that will activate loopback and nothing else. Then one could use WICD or the like to manage the interfaces.

My $0.02
Unfortunatelly, this is not working for me. I've added both my eth0 and wlan0 device (with IFNAME) and left everything empty, but during boot, both of my devices are coming up.
 
Old 07-13-2009, 03:02 AM   #13
Nille_kungen
Member
 
Registered: Jul 2005
Posts: 515

Rep: Reputation: 181Reputation: 181
What doesn't work?
What happens and what did you want to happen?
Edit /etc/rc.d/rc.inet1.conf is the right way because you still need the loopback device.
 
Old 07-13-2009, 11:27 AM   #14
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 231Reputation: 231Reputation: 231
Quote:
Unfortunatelly, this is not working for me. I've added both my eth0 and wlan0 device (with IFNAME) and left everything empty, but during boot, both of my devices are coming up.
This is the standard way of doing things. The interface will not be brought up unless /etc/rc.d/rc.inet1.conf has USE_DHCP[x]="yes" or IPADDR[x]="An.ip.address.set" where [x] is interface number "An.ip.address.set" is an IP address, obviously.

Note that you do not need IFNAME set for eth0 - just setup the IPADDR[0] stanza as the [0] implies eth0.

Perhaps you mean the devices themselves being detected - this is not what's usually termed "coming up". This is a setting on the device when it is put into an active state via /sbin/ifconfig (or other means). This is indicated when you run /sbin/ifconfig -a by an "UP" flag against the device.

Please - if you haven't already - check out Alien Bob's page on this subject and all will be revealed.
 
Old 07-13-2009, 02:45 PM   #15
danielldaniell
Member
 
Registered: Apr 2009
Location: Hungary
Distribution: Slackware, OpenBSD
Posts: 50

Original Poster
Rep: Reputation: 16
more detailed description of problem

/etc/rc.d/rc.inet1.conf:
[...]
IFNAME[4]="wlan0"
IPADDR[4]=""
NETMASK[4]=""
USE_DHCP[4]=""
DHCP_HOSTNAME[4]=""
[...]

Despite of this, on every boot, the wlan0 device will come up, which means:
$ ifconfig wlan0
wlan0 Link encap:Ethernet
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)


How can I stop this behavior, and keep the wlan interface down?
(I'm not using wicd)
 
  


Reply

Tags
boot, network


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to run a script after bringing up a particular network interface (ppp0) polemon Linux - Networking 2 04-01-2007 09:32 PM
system locks up when bringing down bonded network interface BrianK Linux - Hardware 1 02-20-2007 11:09 PM
Bringing up interface ppp0: gets Boot stuck cleo Linux - Hardware 0 06-04-2005 01:37 PM
boot freeze a bringing up interface ppp0 vrdhananjay Linux - Software 2 10-16-2004 09:09 AM
error on boot up: Bringing up loopback interface glorygirl Linux - Networking 2 01-18-2004 11:11 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 05:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration