LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 12-21-2010, 04:20 PM   #1
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,044

Rep: Reputation: 150Reputation: 150
How to remove the "flush" flag when mounting removable disks?


Hi all. Is it possible to remove the "flush" flag when mounting removable disks in KDE4 without recompiling KDE4? Can it be done in some config file(s)? Thanks!
 
Old 12-24-2010, 09:00 AM   #2
sys64738
Member
 
Registered: May 2008
Location: NRW/Germany
Posts: 105

Rep: Reputation: 30
Hi
I think your questions is:
How do I mount a file system without synchronous IOs or asynchronous IOs and which file is use to configure it?

The answer:
Code:
mount -o sync /dev/sdb /media/blahblah
for the "flush way"

Code:
mount -o async /dev/sdb /media/blahblah
for the "no flush way"

The file is "/etc/fstab".

Ask if you need further help.
 
Old 12-27-2010, 12:19 PM   #3
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,044

Original Poster
Rep: Reputation: 150Reputation: 150
Hi,

It was "flush". Not "sync".

mount(8)

Mount options for fat

flush If set, the filesystem will try to flush to disk
more early than normal. Not set by default.

Regards
 
Old 12-28-2010, 06:17 PM   #4
sys64738
Member
 
Registered: May 2008
Location: NRW/Germany
Posts: 105

Rep: Reputation: 30
Hi
that option "flush" is new to me.
As far as I figured out it is not only a KDE4 "problem" in Slackware.
I am using Ubuntu (lucid & gnome) and I got this in /proc/mounts:
Code:
/dev/sdb1 /media/333D-C5F7 vfat rw,nosuid,nodev,relatime,uid=1000,gid=1000,fmask=0022,dmask=0077,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,flush,errors=remount-ro 0 0
when I mount an usb-stick.
As far as I figured out it is done to have the written data in a more consistent way.

The only way to stop the flush option in my environment was to umount the device and do a mount command. I know not very convenient but the only thing I found.

Hope that will help you.
 
Old 12-28-2010, 08:30 PM   #5
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,044

Original Poster
Rep: Reputation: 150Reputation: 150
That needs root privilege.
 
Old 12-29-2010, 06:07 PM   #6
sys64738
Member
 
Registered: May 2008
Location: NRW/Germany
Posts: 105

Rep: Reputation: 30
Well if that is a problem (please take no offense) you have to use "/etc/fstab" and the option user or users.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Qt "cannot call constructor for""a function-style cast remove the redundant ::QBrush" Peterius Linux - Software 4 11-24-2010 04:57 PM
mysql "flush logs" or "flush tables with read lock", ... hangs deadeyes Linux - Server 4 01-19-2010 03:24 AM
How can I get KDE4 to automount all vfat usb-sticks with the "flush" mount option? ssenuta Mandriva 1 01-15-2010 12:14 AM
bash - how to remove lines from "FILE_A" which presents in "FILE_B" ? Vilmerok Programming 4 03-13-2009 04:27 AM
Missing menu for "Removable Disks and Media Preferences" in Gnome: Fedora9 awmian Linux - Newbie 1 09-08-2008 12:34 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 05:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration