LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   How to Optimize Fonts in Slackware (https://www.linuxquestions.org/questions/slackware-14/how-to-optimize-fonts-in-slackware-640468/)

dugan 01-04-2010 08:42 AM

Quote:

Originally Posted by Thursapr (Post 3813482)
Upgraded to new versions. It is weird that everything works fine, except Firefox (3.5.6), the fonts like the patches never been applied.

Is anyone having the same problem? I had a rebuilt Firefox 3.5.2 from before I upgraded to the new font packages. After I upgraded the font packages, Firefox's font rendering behavior continued as expected.

rmjohnso 01-04-2010 03:30 PM

I'm using Slackware64-current, so I think Pat's build of Firefox is dynamically linked against cairo instead of the static linking under 32-bit. Everything looks good to me in firefox-3.5.6 now that I've got cairo-1.8.8 patched.

rmjohnso 01-04-2010 06:37 PM

Why is Chrome not showing fonts in a manner similar to Firefox? It defaults to using Arial and Times New Roman, and I've switched it to match what I have in Firefox, but I didn't really see any change.

Daedra 01-05-2010 12:16 AM

just guessing but like you said above, chrome might be statically linked against cairo. That could be the problem.

rmjohnso 01-05-2010 12:42 PM

After doing a little googling, it looks like Chrome uses skia (http://code.google.com/p/skia/) and not cairo.

dugan 01-25-2010 03:18 AM

Thursapr, what rmjohnso wrote is correct. You need to rebuild Firefox from source. Use the Slackware64 SlackBuild.

Thursapr 01-26-2010 10:08 AM

Quote:

Originally Posted by dugan (Post 3839507)
Thursapr, what rmjohnso wrote is correct. You need to rebuild Firefox from source. Use the Slackware64 SlackBuild.

I did these exactly. But after upgrading the 4 packages, not before.

Anyone rebuild FF after upgrading 4 package not encountered my problem?

dugan 01-26-2010 12:32 PM

Quote:

Originally Posted by Thursapr (Post 3841097)
Anyone rebuild FF after upgrading 4 package not encountered my problem?

Yes. In the "Optimizing" page I have screenshots to prove it.

GrapefruiTgirl 01-26-2010 12:47 PM

@ dugan,

I just wanted to write that I had never before visited your web page about these fonts and things, so I went and had a look just now. It's nice! Really well written and covers a lot of angles dealing with fonts and monitors and X. Cool, nice work.

I have long ago got my subpixel rendering sorted out, but never yet bothered going into great depth regarding my Slackware fonts (AFAICT they are pretty good anyhow); but it's on my list though of things to do eventually, and I'll be using this thread, and your web page, as a guide/template when I get to it.

Thanks,
Sasha

dugan 05-24-2010 05:59 PM

The four patched SlackBuilds have been updated for 13.1.

You can find them in the "Optimizing Slackware Linux's Fonts" page in my sig.

Hangdog42 05-25-2010 07:10 AM

Thanks dugan, your page has been a real help in making my desktop MUCH getter.

tomtomjkw 06-01-2010 02:13 AM

Calibri problem
 
Hi

I have a problem with Calibri font:

http://yfrog.com/jycalibrip

When font size ranges from 8 to 14, rendering of language specific fonts seems to be broken. 15 and over - font is ok.
Webcore-fonts installed from Dugan's slackbuild, fontconfig and others compiled Cleartype-style.
Any ideas?

dugan 06-12-2010 11:34 PM

I just noticed that the current Fontconfig patch no longer enables the "lcddefault" filter, which is the whole point of the Ubuntu patches in the first place.

You need to add the following lines to your local.conf:
Code:

       
<match target="font">
    <edit name="lcdfilter" mode="assign">
        <const>lcddefault</const>
    </edit>
</match>

Also, after upgrading from 13.1 from 13.0, you need to rebuild all 4 packages in order. I know this wasn't obvious because I'd neglected to change the build numbers, but I've taken care of that now.

SpelledJ 06-13-2010 10:08 AM

I rebuilt your packages for 13.1 on a fresh installation a couple of weeks ago, Dugan, and my fonts didn't seem as clear as they did a couple of months ago on -current. Thanks for the tweak - that made a big difference. One thing you might want to mention is that your addition needs to go between the <fontconfig> . . . </fontconfig> tags, not at the end of the file.

Something else I noticed is that I'm missing some entries in /etc/fonts/conf.avail now. Compared to your post #125, I don't have any 10-hinting-*.conf entries, and I don't have 11-lcd-filter-lcddefault.conf. Your conf.d from post #125 was last edited in 08/09 for Slackware 13.0. Is it still consistent with 13.1?

My /etc/fonts/conf.avail:
Code:

-rw-r--r-- 1 root root  220 2010-06-01 17:54 10-autohint.conf
-rw-r--r-- 1 root root  226 2010-06-01 17:54 10-no-sub-pixel.conf
-rw-r--r-- 1 root root  225 2010-06-01 17:54 10-sub-pixel-bgr.conf
-rw-r--r-- 1 root root  225 2010-06-01 17:54 10-sub-pixel-rgb.conf
-rw-r--r-- 1 root root  226 2010-06-01 17:54 10-sub-pixel-vbgr.conf
-rw-r--r-- 1 root root  226 2010-06-01 17:54 10-sub-pixel-vrgb.conf
-rw-r--r-- 1 root root  217 2010-06-01 17:54 10-unhinted.conf
-rw-r--r-- 1 root root  912 2010-06-01 17:54 20-fix-globaladvance.conf
-rw-r--r-- 1 root root 1157 2010-06-01 17:54 20-unhint-small-vera.conf
-rw-r--r-- 1 root root 2941 2010-06-01 17:54 25-unhint-nonlatin.conf
-rw-r--r-- 1 root root 3939 2010-06-01 17:54 30-metric-aliases.conf
-rw-r--r-- 1 root root 1164 2010-06-01 17:54 30-urw-aliases.conf
-rw-r--r-- 1 root root 2103 2010-06-01 17:54 40-nonlatin.conf
-rw-r--r-- 1 root root 1837 2010-06-01 17:54 45-latin.conf
-rw-r--r-- 1 root root  545 2010-06-01 17:54 49-sansserif.conf
-rw-r--r-- 1 root root  245 2010-06-01 17:54 50-user.conf
-rw-r--r-- 1 root root  318 2010-06-13 09:33 51-local.conf
-rw-r--r-- 1 root root 1701 2010-06-01 17:54 60-latin.conf
-rw-r--r-- 1 root root 9880 2010-06-01 17:54 65-fonts-persian.conf
-rw-r--r-- 1 root root  289 2010-06-01 17:54 65-khmer.conf
-rw-r--r-- 1 root root 7706 2010-06-01 17:54 65-nonlatin.conf
-rw-r--r-- 1 root root  672 2010-06-01 17:54 69-unifont.conf
-rw-r--r-- 1 root root  263 2010-06-01 17:54 70-no-bitmaps.conf
-rw-r--r-- 1 root root  263 2010-06-01 17:54 70-yes-bitmaps.conf
-rw-r--r-- 1 root root  388 2010-06-01 17:54 80-delicious.conf
-rw-r--r-- 1 root root 1691 2010-06-01 17:54 90-synthetic.conf

My *dc packages in /var/log/packages, note timestamps for build order:

Code:

-rw-r--r-- 1 root root 3861 2010-06-01 17:57 freetype-2.3.12-x86_64-1_dc
-rw-r--r-- 1 root root 8827 2010-06-01 17:58 fontconfig-2.8.0-x86_64-1_dc
-rw-r--r-- 1 root root 1068 2010-06-01 18:01 libXft-2.1.14-x86_64-1_dc
-rw-r--r-- 1 root root 4197 2010-06-01 18:02 cairo-1.8.8-x86_64-3_dc

Thanks as usual for keeping up with all the nice font upgrades!

dugan 06-13-2010 01:12 PM

SpelledJ: Those files are no longer there. I've edited post #125 accordingly.

To tweak further, try putting <edit name="antialias" mode="assign"><bool>true</bool></edit> or <edit name="antialias" mode="assign"><bool>false</bool></edit> between the <match> tags.

Also, I tried Chrome, and I noticed that the fonts in the rendering area look different than the fonts in its menus, with the menu fonts being fuzzier and the website fonts being sharper. This leads me to believe that the settings in Chrome's rendering area are actually hardcoded, and cannot be changed. I do know that this is the case with another program: the Gargoyle Interactive Fiction Interpreter.


All times are GMT -5. The time now is 05:19 AM.