LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-21-2011, 11:59 AM   #1
eraosso
Member
 
Registered: May 2006
Location: Brazil
Distribution: Slackware 13.37
Posts: 35

Rep: Reputation: 15
How to mount NAS wireless device and access files


Hi all,
I have a Western Digital My Book World Edition II 2TB http://www.wdc.com/en/products/products.aspx?id=290 set up on my Windows install.
Question is: how do I access the files from my Slackware box? I have Slack 13.37 64bit installed on a Samsung laptop.

Thanks,
eraosso
 
Old 05-21-2011, 01:15 PM   #2
droyden
Member
 
Registered: Feb 2007
Location: UK
Posts: 150

Rep: Reputation: 19
Share the drive under windows and mount it with samba / cifs?
 
Old 05-21-2011, 04:20 PM   #3
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 545Reputation: 545Reputation: 545Reputation: 545Reputation: 545Reputation: 545
Based upon a quick perusal of the user manual:

Looks like the device is Linux based and supports CIFS/SMBS and NFS.

Find the IP address of the NAS device. The NAS device will obtain an IP address from your router if you are using DHCP or will use a static IP address if you configured the device that way.

Verify you can find the NAS device using the ping command. For example:

ping xxx.xxx.xxx.xxx

Where xxx.xxx.xxx.xxx is the IP address of the device. For example, 192.168.1.100 or something similar.

If the CIFS/SMBS service is enabled on the device then try the following:

smbclient -L xxx.xxx.xxx.xxx

You might be asked to provide a password.

If the smbclient command is successful, you should see a listing of all share points provided by the device.

If the NFS service is enabled on the device then try using the showmount command to discover which NFS mount points are provided by the device. Try the following:

/usr/sbin/showmount --exports xxx.xxx.xxx.xxx

Depending upon the results, use the mount command thereafter to connect to the desired share points.

I hope this helps.
 
1 members found this post helpful.
Old 05-22-2011, 02:39 AM   #4
droyden
Member
 
Registered: Feb 2007
Location: UK
Posts: 150

Rep: Reputation: 19
From the OP it sounds like it is directly attached rather than on the network
 
Old 05-22-2011, 10:47 AM   #5
eraosso
Member
 
Registered: May 2006
Location: Brazil
Distribution: Slackware 13.37
Posts: 35

Original Poster
Rep: Reputation: 15
Hi,
with the smbclient command, I get:

Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.0.34]

Sharename Type Comment
--------- ---- -------
Public Disk Public Share
Download Disk Download Share
Configuration Disk System Configuration
IPC$ IPC IPC Service (My Book World Edition Network Storage)
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.0.34]

Server Comment
--------- -------
MYBOOKWORLD My Book World Edition Network Storage

Workgroup Master
--------- -------
WORKGROUP


but then I'm having issues with the mount command.
Forgive me for my persistent "newbiness" but I'm having issues with the mount command:

mount -L 192.168.6.200/Public /media/hd returns mount: no such partition found

I have edited the samba.conf file and the only change I've made to the example file was that I uncommented the line for hosts allow and changed the domain to 192.168.6

Thanks again!
eraosso
 
Old 05-22-2011, 10:49 AM   #6
SqdnGuns
Senior Member
 
Registered: Aug 2005
Distribution: Slackware64 Current
Posts: 1,023

Rep: Reputation: 118Reputation: 118
This is what I have done for my Seagate Black Armor NAS.

Code:
mkdir /mnt/nas

mount -t cifs //192.168.1.50/"shared folder name here" /mnt/nas -o username="domain or workgroup name here"/"username here",password=*********
 
1 members found this post helpful.
Old 05-22-2011, 11:38 AM   #7
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 545Reputation: 545Reputation: 545Reputation: 545Reputation: 545Reputation: 545
Rather than use 'mount -L' use 'mount -t' as suggested by SqdnGuns.

I notice the device IP address is 192.168.6.200. Is your 'nix box is on the same 192.168.6.x subnet? If not then your router needs to bridge the two different subnets or you will experience problems trying to connect to the device.

The NAS device host name is MYBOOKWORLD.

You might want to check how the NAS device's IP address is assigned. If dynamically through DHCP then any time the router is rebooted the IP address could change unless the router is configured to reassign the same address or the NAS device is configured to use a static address. The point is once you get the mount command to work manually you likely will want to permanently add the mount in /etc/fstab.

Just a little helper to improve readability in the forums, when copying and pasting text from the command line output, be sure to enclose the text in code tags. Then when the text is posted in the forum the text will retain the same output formatting. Something like this:

Code:
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.0.34]

        Sharename       Type      Comment
        ---------       ----      -------
        Public          Disk      Public Share
        Download        Disk      Download Share
        Configuration   Disk      System Configuration
        IPC$            IPC       IPC Service (My Book World Edition Network Storage)
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.0.34]

        Server               Comment
        ---------            -------
        MYBOOKWORLD          My Book World Edition Network Storage

        Workgroup            Master
        ---------            -------
        WORKGROUP
 
1 members found this post helpful.
Old 05-23-2011, 06:25 PM   #8
eraosso
Member
 
Registered: May 2006
Location: Brazil
Distribution: Slackware 13.37
Posts: 35

Original Poster
Rep: Reputation: 15
Thanks guys!
I have issued the command
Code:
mount -t cifs //192.168.6.200/Public /mnt/nas/
and it did mount correctly with root pwd.

I will do some more research and work on username and password options.

Woodsman, I have configure the router to assign a fixed IP to the NAS device and all devices are within the 192.168.6 subnet.

Thanks a lot!
 
Old 05-23-2011, 09:27 PM   #9
SqdnGuns
Senior Member
 
Registered: Aug 2005
Distribution: Slackware64 Current
Posts: 1,023

Rep: Reputation: 118Reputation: 118
Glad to hear it worked out for you.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't access NAS device from nookatee Linux - Newbie 6 01-03-2011 01:31 PM
Booting stops after: Unable to access resume device, mount: could not mount ... lespaul047 Linux - Newbie 2 04-06-2009 05:50 PM
Equal Access to files on a NAS form Debian and Windows? bruceam Linux - Newbie 8 02-27-2009 05:35 PM
Buffalo NAS - how do we get files on NAS syncing with Windows Sync? bykerbob Linux - Newbie 0 10-21-2008 08:59 PM
Need to mount a XFS NAS device psalms1 Red Hat 3 09-16-2007 05:36 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration