-   Slackware (
-   -   how to make Slack 13.37 LSB 3.2 compliant (

waddles 09-29-2012 03:34 PM

how to make Slack 13.37 LSB 3.2 compliant
I need to make my 13.37 Slackware LSB 3.2 compliant so that I can download Epson drivers for a printer (workforce435) I intend to buy.
I found 1 site which solved this problem but he was running Debian.
Consequently I am unsure if what he did is sufficient and/or complete for Slack 13.37.
Can someone tell me what needs to be done to this version of Slackware to make it LSB 3.2 compliant? and what is already compliant?
Also how to do it or a web reference would be helpful, my searching has only turned up 2 incomplete and moderately useful references.

Didier Spaier 09-29-2012 03:53 PM

Well, the official website for viewing or downloading LSB 3.2 is here.

I had a quick look at the core functional area. I think you would save a lot of time searching for the exact model/type on this forum instead of trying to find out if Slackware is "enough LSB 3.2 compliant" (does anybody knows what "enough" would mean in that case?).

That said, if you suffer of insomnia, reading the 717 pages of the core functional area for the Generic architecture specification is worth trying as a cure ;)

wildwizard 09-29-2012 03:56 PM

Though your wasting your time on that front, it will be far easier to mould the script to fit Slackware.

Didier Spaier 09-29-2012 04:17 PM

Reading this:

22 Software Installation
22.1 Introduction
Applications shall either be packaged in the RPM packaging format as defined
in this specification, or supply an installer which is LSB conforming (for
example, calls LSB commands and utilities).
Note: Supplying an RPM format package is encouraged because it makes systems
easier to manage. This specification does not require the implementation to use
RPM as the package manager; it only specifies the format of the package file.
Slackware is not compliant to LSB 3.2, as its package format do not comply to the package file format specified in LSB 3.2 (see from page 652).

This is confirmed by the fact that lsb-release utility (page 590) is not included in Slackware 13.37.

And if I may risk a prediction this will not change as long as Patrick J. Volkerding will be our BDFL.

allend 09-29-2012 09:39 PM

There should be no problem with getting that printer to work with Slackware.
Please note the (How to install) link from the same page.

waddles 09-30-2012 02:38 AM

Allend: I briefly scanned your offerings but they led me to the same conclusion I have been suffering under. That is that I need to make the OS LSB compatible before I download Epson's drivers for the device. They also mentioned that in the Epson driver download page unless these tired eyes and befuddled brain have misled me.
Please please correct me if I am wrong as at this point I could believe dancing in the street with holly sprigs in my ears would cure my printer problems.

I just need a simple ink-jet printer to handle printing. I will follow the advice of Didier and put out a call for a printer here.
After my HP fiasco I can just imagine downloading a bunch of rpm-s, converting to tars, all probably in the wrong tree, only to find some salient point was missed and I once again spent $75-$100 for a boat anchor.

I think what I am looking for is a sequenced list of what needs to be put where to become LSB 3.2.

WildWizard: expand please on what you ment by moulding a script to Slack? I think you may be on to a viable solution from what U said.

I see that VueScan claims 6o seconds to print or something like that. From my background it seems that a script/program to move the cartridge carrier, select the color, nozzle etc. could be built by any distro to drive a similar set of manufacturers features but I think that is what Linux Foundation is attempting but IMHO with too much clutter.
My sincere thanks to all.

Didier Spaier 09-30-2012 05:00 AM

This could help. It would be even better, after following the instructions from 1. through 4., to make yourself a Slackware package, see "man makepkg".

FYI there is an How To Extract an RPM Package Without Installing It.

waddles 09-30-2012 03:22 PM

how to make Slack 13.37 LSB 3.2 compliant
Didier Spaier I think that is EXACTLY what I was looking for!
I had researched the heck out of the various manufacturers and from my experiences with Epson, Canon, and HP the former was the least trying so the WF435 (which is also called BX305plus, I'm told) was my favorite since HP had done it to themselves. I don't know how U found it but it is similar to a site I had seen and was unsuccessful in trying to re-locate.
BTW I had seen the rpm2cpio <file> | cpio -idmv (had to use web to get the man page for idmv, Slacks doesn't have explanation for them). Have U seen:
rpm2cpio <file> | lzma -d | cpio -idmv which is similar to:
rpm2cpio <file> | xz -d | cpio -idmv which was a response in the reference U gave. Thanx very much.
Per the rpm2cpio does anyone know why there is no rpm2tar with Slack anymore?

Didier Spaier 09-30-2012 04:27 PM

Want something even simpler? type "rpm2txz <rpm package>", then install the package with the "installpkg" command. Type "rpm2txz" with no argument for command's usage. This should make a good Slackware package as it has been written by Patrick Volkerding ;)

waddles 10-02-2012 01:26 PM

how to make Slack 13.37 LSB 3.2 compliant
Thanks again, Didier.
I hadn't tried to use rpm2tar/tgz/txz in a long while but tried the other day to find it in my Slack 13.37 and there was only the rpm2cpio which stunned me. I will have to download it from somewhere. Probably Sourceforge or Slackbuild has it.
I am concluding this post stream since UR 2 references solved my problem.

Didier Spaier 10-02-2012 02:01 PM

If you can't find rpm2txz on you Slackware 13.37, that should be because you didn't make a full install or removed it. It comes from the package rpm2tgz which is included in Slackware 13.37 in the /a series of packages and should be installed in /usr/bin.

So for some reason your Slackware 13.37 installation is not complete.

All times are GMT -5. The time now is 08:34 AM.