LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 10-25-2016, 06:23 PM   #1
mfoley
Senior Member
 
Registered: Oct 2008
Location: Columbus, Ohio USA
Distribution: Slackware
Posts: 1,624

Rep: Reputation: 128Reputation: 128
How to make Firefox my default browser in KDE


I am running KDE on Slackware. I've set Firefox as my default browser in the Firefox options, but when I have a link pop up, for example a notice that a new version of VirtualBox is available along with a link; when I click that link it opens in Konqueror. I want it to open in Firefox.
 
Old 10-25-2016, 06:40 PM   #2
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 15,076
Blog Entries: 25

Rep: Reputation: 4263Reputation: 4263Reputation: 4263Reputation: 4263Reputation: 4263Reputation: 4263Reputation: 4263Reputation: 4263Reputation: 4263Reputation: 4263Reputation: 4263
Is this link popping up within Firefox or directly on the desktop (I suspect the latter)?

As a shot in the dark, I recommend looking in KDE System Settings-->Default Applications and System Settings-->File Associations.
 
Old 10-25-2016, 07:20 PM   #3
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib" & Xfce.
Posts: 4,773
Blog Entries: 1

Rep: Reputation: 2150Reputation: 2150Reputation: 2150Reputation: 2150Reputation: 2150Reputation: 2150Reputation: 2150Reputation: 2150Reputation: 2150Reputation: 2150Reputation: 2150
It would be, in KDE-4.x.x, System Settings -> Default Applications.
 
Old 10-25-2016, 11:51 PM   #4
mfoley
Senior Member
 
Registered: Oct 2008
Location: Columbus, Ohio USA
Distribution: Slackware
Posts: 1,624

Original Poster
Rep: Reputation: 128Reputation: 128
OK, I've set Firefox in Default Applications > Web Browser. The settings was blank before. Now I'll wait for that message to pop up and try it. I should get it in the next day or two.

frankbell: The link is not popping up within Firefox. I got it when I launched VirtualBox and it gave me a notice that there was a new version available along with a link.
 
Old 10-26-2016, 03:52 AM   #5
kjhambrick
Senior Member
 
Registered: Jul 2005
Location: Round Rock, TX
Distribution: Slackware64 14.2 + Multilib
Posts: 1,483

Rep: Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917
mfoley --

This is something I spent a little time on some time back and now I always do it as follows ...

I set /usr/bin/firefox --new-tab as frankbell and cwizardone described ( and as you've done ) and it works for me.

To test the setting, I saved a nice, clean HTML file in /tmp/ ( I save a copy of www.slackware.com as /tmp/www.slackware.com-home.html ).

When I click on this file in the KDE Find Files/Folders App, the sample file opens in a new Tab in Firefox.

If Firefox is not running, KDE opens the file in a new instance of Firefox.

I did find that Firefox was annoyed if Firefox is NOT running and I double-click the file because firefox takes longer to open than my double-click tempo and apparently KDE tries to run a 2nd copy of firefox and it eventually throws an error ( the file will be opened in the first instance of Firefox though ).

If Firefox is already open and I double-click the HTML File, I get one copy of the HTML File in a new Tab in Firefox.

HTH.

-- kjh

p.s. If you prefer, you can also run /usr/bin/firefox --new-window if you want the file open in a new Firefox Window.
 
Old 10-26-2016, 07:59 AM   #6
mfoley
Senior Member
 
Registered: Oct 2008
Location: Columbus, Ohio USA
Distribution: Slackware
Posts: 1,624

Original Poster
Rep: Reputation: 128Reputation: 128
Reporting back ... setting Firefox as the default browser in System Settings > Default Applications did work. Annoyingly, Firefox opened behind the VirtualBox Manager window, but that's a different issue -- problem solved. Thanks all.
 
Old 05-23-2017, 11:08 PM   #7
augustin valjean
LQ Newbie
 
Registered: May 2017
Posts: 1

Rep: Reputation: Disabled
I confirm the proper place to change the default browser. The settings is a bit awkward, though, if you want to keep the option to open links "in an application based on the contents of the URL". See description in bug report listed below.
Quote:

In KDE systemsettings > Personalization > Applications > Default applications > Web browser:

Type in the browser name in the field "in the following browser", e.g. konqueror.
If you want the option "in an application based on the contents of the URL", and still be able to select another default browser, you have to use the second field as described above, save, then select back "in an application based on the contents of the URL" and save again.
 
Old 05-26-2017, 09:36 AM   #8
zakame
Member
 
Registered: Apr 2012
Distribution: Debian, Ubuntu, Slackware
Posts: 256

Rep: Reputation: 161Reputation: 161
In addition, on the CLI you can use xdg-settings to set your default:

Code:
# check current default
$ xdg-settings get default-web-browser
seamonkey.desktop

# set a new default
$ xdg-settings set default-web-browser mozilla-firefox.desktop
$ xdg-settings get default-web-browser
mozilla-firefox.desktop
 
1 members found this post helpful.
  


Reply

Tags
default, firefox, kde


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I make Firefox my default browser instead of Konqueror? suse2166 Linux - Newbie 2 12-06-2005 07:19 PM
KDE 3.2.3 firefox default browser NightKids Linux - Newbie 11 06-06-2005 10:10 PM
How to make Firefox default web browser on Mandrake? dianat100 Linux - Newbie 4 03-19-2005 12:31 PM
Can't make Firefox my default browser fryem720 Mandriva 2 08-27-2004 07:12 AM
How to make Mozilla Firefox my default file browser? jato Linux - Software 2 03-30-2004 11:33 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration