LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-20-2013, 05:59 AM   #1
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 147Reputation: 147
How to make esd (Enlightened Sound Daemon) work?


Hello,

I have read/write permission to /dev/dsp. aplay and mplayer -ao {alsa,oss} work well.
However, esdplay something fails silently, and mplayer -ao esd gives
Code:
[AO ESD] esd_open_sound failed: Connection timed out
When I start the esd command, it keeps running in the foreground and gives no message. It I start esd with "esd -d /dev/dsp" then it shows "- using device /dev/dsp" and then exits immediately. So it seems the "-d" option does not help.

Any hints? Thanks!

guanx
 
Old 09-20-2013, 07:29 AM   #2
commandlinegamer
Member
 
Registered: Dec 2007
Posts: 102

Rep: Reputation: 18
Isn't esd deprecated?
 
Old 09-20-2013, 07:47 AM   #3
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Original Poster
Rep: Reputation: 147Reputation: 147
Quote:
Originally Posted by commandlinegamer View Post
Isn't esd deprecated?
I've heard of that but it's still included in slackware-current. Is it expected to not work?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Removing the Enlightenment Sound Daemon (aka "esd" aka "esound") jgombos Debian 4 03-30-2010 02:33 PM
esd or other netwrok sound mattd7591 Linux - General 8 07-10-2007 09:44 AM
Enlightened Sound Daemon Problems Baryonic Being Linux - Hardware 0 09-10-2004 11:49 AM
Need to run system-config-sound after every boot too make sound work in FC2 jrbiochem Linux - Hardware 11 08-04-2004 07:08 AM
ALSA ESD --> no sound, but OSS sound works intense Slackware 1 03-23-2004 02:34 PM


All times are GMT -5. The time now is 01:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration