LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 10-04-2018, 04:22 PM   #16
mfoley
Senior Member
 
Registered: Oct 2008
Location: Columbus, Ohio USA
Distribution: Slackware
Posts: 1,473

Original Poster
Rep: Reputation: 122Reputation: 122

That's interesting. I've installed to the 2nd hard drive w/o problem, and booted from there, but I've not done so with the 2nd drive formatted as UEFI.

An Idea ... go ahead and install to the 1st drive, then swap to be the 2nd drive. Reboot from the installation cd, then:
Code:
mount /dev/sb1 /mnt
mount --bind /proc /mnt/proc
mount --bind /sys /mnt/sys
mount --bind /dev /mnt/dev
chroot /mnt
edit your /etc/lilo.conf (if that's what it's still called with elilo), and your /etc/fstab and change the device names to /dev/sdb[1]. Then run [e]lilo. umount all of the above, reboot. Make sure your BIOS specifies the 2nd drive as the 1st boot device, and see if that works.
 
Old 10-06-2018, 01:08 AM   #17
FlinchX
Member
 
Registered: Nov 2017
Distribution: Slackware Linux
Posts: 245

Rep: Reputation: Disabled
Quote:
Originally Posted by mfoley View Post
An Idea ... go ahead and install to the 1st drive, then swap to be the 2nd drive.
If you mean swapping as in swapping physically, that's not always possible without breaking the warranty.
 
  


Reply

Tags
boot issues, lilo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] cannot boot from grub USB thumb drive: /dev/sdb not detected... X-LFS-2010 Linux - Newbie 21 05-30-2018 08:20 PM
cannot boot from grub USB thumb drive: /dev/sdb not detected X-LFS-2010 Linux From Scratch 1 05-29-2018 12:22 PM
/dev/sdb hard drive issues. shital_064 Linux - Hardware 6 06-19-2012 05:21 AM
Can I make symlink to /dev/sdb, and if so, how? linus72 Linux - Newbie 15 06-21-2009 08:20 AM
moving bootable drive from /dev/hde to /dev/hda chromedog Red Hat 1 02-08-2006 05:31 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 12:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration