-   Slackware (
-   -   how to install slackware from a usb drive (

katokato 01-19-2012 12:00 AM

how to install slackware from a usb drive
so i tried to copy the contents of the slackware iso onto the usb, then
i went and renamed the isolinux.cfg to syslinux.cfg
then i downloaded the syslinux zip from
then i navigated to the syslinux folder that i downloaded, and into win32 (...\syslinux\win32) and ran "syslinux.exe K:" in the commandprompt.
when i try to boot my usb to install, it tells me that there is no media to use.

is there another way to do this or am i doing it wrong?

i need to get slackware on my laptop and my burner crapped out.

slackass 01-19-2012 12:53 AM

I recenty did it with 2 usb sticks on a Dell 630 with a broken dvd drive.

1st stick) image
2nd stick) the tree
(I copied the tree from my local mirror.)

Boot from the stick with the image. (bios must be set to boot from usb)
Mount the 2nd stick and use the install from “mounted hard drive” or “partition” option. (can't remember which it was.)

Hope this helps. And I also hope I'm remembering this right. :redface:

katokato 01-19-2012 09:14 AM

for usbootimg do i just unpack the iso and copy the contents onto the flashdrive?
and what format do i partition the usb with? fat32, ext?

linus72 01-19-2012 09:36 AM

there are several ways to do this, some have scripts, etc
but this is how I do it, and I dont have windows so do it from your Ubuntu install or any livecd that has syslinux and a fat32 usb

first get a app called isomaster from ubuntu repos or whatever distro you have
open a terminal and become root (su + password)
type in isomaster, when it opens find the slackware cd/dvd and open it with isomaster
extract the initrd.img, kernel (/kernels/hugesmp.s/bzImage) and isolinux.cfg from the iso to usb

(if you dont have isomaster just mount the iso somewhere and copy kernel/initrd/isolinux.cfg to somewhere)
mkdir /tmp/iso
mount -o loop /tmp/slackware.iso /tmp/iso
cp -r /tmp/iso/isolinux/isolinux.cfg /media/disk
cp -r /tmp/iso/isolinux/initrd.img /media/disk
cp -r /tmp/iso/kernels/hugesmp.s/bzImage /media/disk

rename isolinux.cfg to syslinux.cfg
edit syslinux.cfg and make it like this

label slack
kernel /bzImage
append initrd=/initrd.img load_ramdisk=1 prompt_ramdisk=0 rw printk.time=0 SLACK_KERNEL=hugesmp.s

notice that the kernel and initrd are at top level of usb, not in any folders...

now copy the slackware cd/dvd to the iso
cp -r /path/to/slackware-iso /path/to/usb
or say usb is sdb1 and is mounted on /media/disk and slackware iso is in /tmp
cp -r /tmp/slackware.iso /media/disk

so on your usb should be bzImage, initrd.img, syslinux.cfg, and the slackware.iso

install syslinux to usb with
syslinux /dev/sdb1

boot off usb, login, and type in these commands

fdisk -l (to identify usb and hdd partitions)
additionally run cfdisk, etc first if you need to create partitions

mkdir /source
mkdir /iso
mount /dev/sdb1 /source
mount /source/slackware.iso /iso

then enter setup by typing "setup"
choose language, partition, etc
when it gets to part about installing packages, choose "install from pre-mounted directory"
enter "/iso/slackware" without quotes

it should mount the iso read-only and ask what packages you wish to install, etc
thats it

NyteOwl 01-19-2012 09:59 AM

An excellent how-to for Slackware isntalls from USB

katokato 01-19-2012 09:10 PM

so i did what you told me except i used windows, since i dont have linux

so i did what you said:

mount iso file on a virtual drive

copy contents initrd.img, bzImage and isolinux.cfg to usb drive (with fat32)

rename syslinux.cfg

delete all contents of syslinux.cfg and put in

label slack
kernel /bzImage
append initrd=/initrd.img load_ramdisk=1 prompt_ramdisk=0 rw printk.time=0 SLACK_KERNEL=hugesmp.s

save syslinux.cfg

put slackware iso on usb drive

run syslinux.exe K: (my usb drive) to put ldlinux.sys on my usb drive

and then when i put my usb into my laptop and try to boot it it says theres no bottable media?


so i realized i had to rename the usb drive to slack
but then when i boot with my laptop it says pxe broadcom, media test failure, then it says no bootable devices.
so what must i be doing wrong?
do i have to use usbboot.img?
do i have to extract the slackware iso and put the actual folders on the usb drive?

katokato 01-19-2012 09:58 PM

i also tried to follow step 2. of this article using usbboot.img and writing it with win32 image writer:

it says boot failed when i try to boot with usb.

could it be that my usb drive is bad?

ive noticed that when i did that there was no bzimage in the usb drive, im gonna add that file in right now and see what happens; edit i cant do that because it says there no room it says there is only 23mb on my usb drive when it really is 3.8 gigs, but when i reformat it it goes back to 3.8 gigs total.

brianL 01-20-2012 02:40 AM

Another solution in this post:

linus72 01-20-2012 07:05 AM

1 Attachment(s)
a couple pointers, dont delete everything in the syslinux.cfg
just change
label hugesmp.s
kernel /kernels/hugesmp.s/bzImage
append initrd=initrd.img


label hugesmp.s
kernel /bzImage
append initrd=/initrd.img load_ramdisk=1 prompt_ramdisk=0 rw printk.time=0 SLACK_KERNEL=hugesmp.s

2nd, you should probably use a linux livecd both for installing syslinux to usb and for using Gparted or similar to check usb, make sure bootable flag is on, etc
you dont have to rename usb either.

if you see in attached pic boot flag must be on, see right corner, syslinux must be installed and syslinux.cfg needs to be as original except for kernel/initrd entries as above

make sure your usb is formatted fat32 and is clean

katokato 01-21-2012 01:52 AM

so i decided to get some dvds at the store and install my slackware

it was working fine but it just crashed during installation -- fixed, since it was sitting on my bed it was overheating (dam laptops!) so i raised it by putting a few cups underneath it.)

once i get slackware going im going to follow the knowledge youve given me to make a usb installation in case i need it again (dont have to worry about scratches)

thanks for your help



fb0x 01-21-2012 09:03 AM

Put usbboot.img on usb

dd if=/path/to/usbboot.img of=/dev/sdxx bs=1MB
Boot usb and install from http/ftp server.

All times are GMT -5. The time now is 03:25 PM.