LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-16-2017, 01:47 PM   #1
mfoley
Senior Member
 
Registered: Oct 2008
Posts: 1,019

Rep: Reputation: 98
How to I configure/auto-launch wpa_gui in KDE?


After much struggle (http://www.linuxquestions.org/questi...er-4175607583/) I have settled upon using wpa_gui as my KDE interface to my wireless settings.

I ran wpa_gui from the KDE Laucher search box and it gives me all the info. The manpage says that, "wpa_gui supports (almost) all of the interactive status and configuration features of the command line client, wpa_cli." Best of all, it interacts with the running wpa_supplicant, so no questions or worries about which network manager needs to start (or not start) at boot time.

So far so good. Launching as `wpa_gui` gives me an informational dialog, but a static strength meter. But when I try running in the search bar as `wpa_gui -m 10 -t`, I don't get expected results. The -m is "Set the update interval in seconds for the signal strength meter. This value must be a positive integer, otherwise meter is not enabled (default behavior)." With this setting I get no strength meter at all. Likewise -t "Start program in the system tray only (if the window manager supports it). By default the main status window is shown", does put it in the system tray but, like the -m option, it is invisible (though you can click on the invisible spot and show the dialog). Furthermore, no Adapter or network are set.

So, this only appears to work if run without options, but no active strength meter.

Has anyone used this and gotten it to take the parameters? Maybe I need to launch it a different way, perhaps from System Settings > Autostart? Please advise, almost there!

What I want is for wpa_gui to be launched automatically when I log on and for the signal strength meter to be active.
 
Old 06-16-2017, 11:36 PM   #2
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 7,754
Blog Entries: 10

Rep: Reputation: Disabled
Quote:
What I want is for wpa_gui to be launched automatically when I log on and for the signal strength meter to be active.
I think for that to happen your are going to have to have your passphrase included in a string in the wpa_supplicant configuration file for your card to be connected.

In order to get your network card connected, you will have to add one or more wireless configuration parameters, like a WEP key, the ESSID, and such:
http://alien.slackbook.org/dokuwiki/...ckware:network

Also see 'WPA' encryption in the link above.

I use Network Manager which automatically signs my passpharse in and when it shows me my network I connect that way.

Another alternative Network MGR is wicd. If you want to try it.

-:::-If you want to use wicd, you will have to remove any network interface configuration information from /etc/rc.drc.inet1.conf in order to prevent a struggle for power between wicd and Slackware's rc.inet1 script.-:::-

http://www.linuxquestions.org/questi...actice-692268/

Quote:
If your wireless isn't initiating at startup and you think all your information is correct in rc.inet1.conf, then you probably forgot to uncomment the wpa_supplicant line in your rc.inet1.conf file.
https://unix.stackexchange.com/quest...s-on-slackware

Hope that helps i gave it my best.
 
Old 06-17-2017, 09:17 AM   #3
mfoley
Senior Member
 
Registered: Oct 2008
Posts: 1,019

Original Poster
Rep: Reputation: 98
Quote:
Originally Posted by Ztcoracat View Post
I think for that to happen your are going to have to have your passphrase included in a string in the wpa_supplicant configuration file for your card to be connected.
Thanks for you post. If I wasn't clear in my OP, I have the passphrase configured and the wireless card is connecting perfectly well at boot time. The question I have is about configuring wpa_gui in KDE to run when the user logs in, and to enable the signal strength meter -- if supported by this KDE.
Quote:
I use Network Manager which automatically signs my passpharse in and when it shows me my network I connect that way.

Another alternative Network MGR is wicd. If you want to try it.
-:::-If you want to use wicd, you will have to remove any network interface configuration information from /etc/rc.drc.inet1.conf in order to prevent a struggle for power between wicd and Slackware's rc.inet1 script.-:::-

http://www.linuxquestions.org/questi...actice-692268/

https://unix.stackexchange.com/quest...s-on-slackware
I'm not using NetworkManager: This is a wireless only computer on which I've had NetworkManager running for several months, but every remote ssh connection was disconnected on an average of between 4 and 6 minutes (although there were stretches of connectivity for hours). I replaced 2 (for a total of 3) network cards to no effect. Finally, I got rid of NetworkManager and configured using inet1*/wpa_supplicant. An ssh session has been running now continuously connected for more than a week with NO disconnections. So, there is something wrong with NetworkManager!

The thread I referenced in my OP asked about wicd, but no one had any response on how to configure it. There are no man pages for either wicd or wicd-KDE, so that is an apparently little used dead-end. Actually, your response on wicd is the most detail I've received on that in weeks of posting. Thanks. I will check that out, but will likely still stick with wpa_gui.

wpa_gui seems to work just fine. There is a man page and everything. wpa_gui is a GUI only, it is not a network manager and uses the network config as established by net1*/wpa_supplicant which, as I said, is running steady as a rock.

So - the question is: how do I configure wpa_gui to run in the panel tray, with signal strength meter enabled, when the user logs into KDE?

Last edited by mfoley; 06-17-2017 at 09:20 AM.
 
1 members found this post helpful.
Old 06-17-2017, 08:32 PM   #4
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 7,754
Blog Entries: 10

Rep: Reputation: Disabled
Quote:
Actually, your response on wicd is the most detail I've received on that in weeks of posting. Thanks.
You're Welcome.

Quote:
So - the question is: how do I configure wpa_gui to run in the panel tray, with signal strength meter enabled, when the user logs into KDE?
Maybe try clicking on the panel and go into 'panel preferences' and look at the options.
I'd think that you would be able to "enable and or add" the signal strength icon/widget to the panel. If that doesn't work do a search for how to configure wpa to run in the panel:KDE.

I'm not the best with KDE. I normally run XFCE and that DE allows the strength icon in the panel so that's why I'm thinking you should be able to add it in KDE. Look in the setting for KDE.

--------------------------------------------------------------------------------------
This looks promising: "WiFi wireless signal strength in panel"

https://store.kde.org/content/show.php?content=122974

Try doing a search in the KDE Forum.
https://forum.kde.org/search.php?key...&submit=Search
https://forum.kde.org/search.php?key...&submit=Search

Hope that helps. I'm not sure what else you could try. Sorry.
 
1 members found this post helpful.
Old 06-21-2017, 03:21 AM   #5
mfoley
Senior Member
 
Registered: Oct 2008
Posts: 1,019

Original Poster
Rep: Reputation: 98
I checked Ztcoracat's suggested link: https://store.kde.org/content/show.php?content=122974, which looks like exactly what I want, but I'm having trouble. In all probability this is because I am not at all familiar with installing new widgets. First, I downloaded the dataengine, as required:

wget https://dl.opendesktop.org/api/files...1.0.1.plasmoid

then ran the install as shown:

plasmapkg -t dataengine -g -i wifi-engine-version.plasmoid

except I added the -g option because I wanted to install for all users. I got:
Code:
# plasmapkg -t dataengine -g -i 122973-wifi-engine-1.0.1.plasmoid
plasmapkg(2501)/libplasma Plasma::Package::installPackage: Could not register package as service (this is not necessarily fatal): "plasma-dataengine-pywifi-engine"
Successfully installed /user/util/src/122973-wifi-engine-1.0.1.plasmoid
I did this as root. I checked a user's .kde directory and it did show a new (in fact only) plasmoid in

/home/tmaher/.kde/share/apps/plasma/plasmoids/pywifi-engine/

On the user's desktop, I click on the Cashew > Add Widget > Get new widgets > Install Widget From Local File > Plasmoid: Native plasma widget > Next > ... and now I'm stuck. I can show hidden files and navigate down to .kde/share/apps/plasma/plasmoids/pywifi-engine/, but all that I find there is a 'contents' subdirectory with 'code' and 'locale' directories beneath it.

Obviously I'm doing something wrong. How do I install this widget?
 
Old 06-21-2017, 05:30 PM   #6
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 7,754
Blog Entries: 10

Rep: Reputation: Disabled
It shows that it installed.

Quote:
Successfully installed /user/util/src/122973-wifi-engine-1.0.1.plasmoid
With some things you have to restart your pc in order for the new install to take effect.

Quote:
Obviously I'm doing something wrong. How do I install this widget?
Not sure if your doing something wrong or not.
Depending on what distro are your running you would use your command-line utility to install the widget. I looked at the files that came with the plasmoid zip file and they are greek to me.

I asked a Moderator to join your thread to help you.
 
Old 06-24-2017, 08:48 AM   #7
mfoley
Senior Member
 
Registered: Oct 2008
Posts: 1,019

Original Poster
Rep: Reputation: 98
Thanks Ztcoracat.

Can anyone advise on how to install KDE widgets?
 
1 members found this post helpful.
Old 06-24-2017, 07:30 PM   #8
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 7,754
Blog Entries: 10

Rep: Reputation: Disabled
Quote:
Originally Posted by mfoley View Post
Thanks Ztcoracat.

Can anyone advise on how to install KDE widgets?
You're Welcome.
 
Old 06-25-2017, 12:04 AM   #9
Gordie
Member
 
Registered: Aug 2007
Distribution: Slackware, Puppy
Posts: 277

Rep: Reputation: 78
Quote:
Originally Posted by mfoley View Post
The thread I referenced in my OP asked about wicd, but no one had any response on how to configure it. There are no man pages for either wicd or wicd-KDE, so that is an apparently little used dead-end. Actually, your response on wicd is the most detail I've received on that in weeks of posting. Thanks. I will check that out, but will likely still stick with wpa_gui
I always use ARK to extract the tarball and look around inside for docs. Wicd has some. I have it set up and use it as we speak. What do you wish to know about wicd. Maybe I can help you?

Last edited by Gordie; 06-25-2017 at 08:19 AM.
 
Old 06-25-2017, 09:43 PM   #10
mralk3
Member
 
Registered: May 2015
Posts: 877

Rep: Reputation: 289Reputation: 289Reputation: 289
Wicd is much easier to use than NetworkManager, IMHO. I find wicd easier when customization is required. For example, I like to use the "macchanger" program to use a new spoofed MAC address each time I connect to a WiFi or Ethernet network. I know that NetworkManager allows this too, but Wicd is simpler to do so.

Install wicd using:
Code:
slackpkg install wicd
Or by visiting: http://ftp.osuosl.org/.2/slackware/s....2/extra/wicd/

The README.SLACKWARE in that directory explains the rest about setup.

From a console you can run the "wicd-curses" command. Or you can enable "wicd-client" in XFCE or another Window Manager. If you have a full installation of Slackware, wicd-kde should already be installed and launched upon logging into a fresh session of KDE. A reboot might be the simplest way to get things going.

A brief write up discussing wicd on Slackware:

https://docs.slackware.com/slackbook:wifi#wicd
 
1 members found this post helpful.
Old 06-27-2017, 10:30 AM   #11
mfoley
Senior Member
 
Registered: Oct 2008
Posts: 1,019

Original Poster
Rep: Reputation: 98
Gordie and mralk3 - thanks for that info on wicd. As mentioned, wicd-KDE was installed, wicd was not. I did `slackpkg install wicd` which also installed the man page. The README.SLACKWARE file at http://ftp.osuosl.org/.2/slackware/s....2/extra/wicd/ gave me what I needed to know about inet1*. The good news is that wicd installed easily and I was able to use the wicd-KDE interface for setup.

The bad news is the wireless connection is horribly slow. It loses connection in the sense that I get no response for long periods of time and when I ping the router/DHCP server/name Server at 192.168.0.1 I will get "no route to host" for some period of time, then the connection is re-established. I never get a disconnection indicator on the wicd widget. I can ssh from another Linux host on the LAN (again, very slow response), but I cannot connect from Windows putty at all. I get a "timeout" when trying.

When I revert back to inet1*/wpa_supplication the speed is back to normal, no lost connections and I can connect from Windows putty w/o problem.

This behavior is similar to the problem I experienced with NetworkManager. With NM I lost remote ssh connection every 4-5 minutes. It seems to me NetworkManager and wicd have connectivity issues. btw - my NetworkManager issues related at the beginning of this thread and these wicd issues are on two completely different computer.

Seems like I'm back to inet1*/wpa_supplicant!
 
Old 06-28-2017, 02:33 AM   #12
Loomx
Member
 
Registered: Sep 2012
Distribution: Slackware
Posts: 49

Rep: Reputation: Disabled
I too have been a happy user of wpa_gui for quite a while now. I found that networkmanager/wicd cause more problems than they solve for me.

Since I first saw your post I've tried to get the -m optiin to work too, but with no luck.
The best I can offer is that in my systems (both 14.2 and 14.2_64) it appears to be an icon issue - the standard icon is displayed as a fallback if it can't find the icons that indicate the different signal strength levels.
A standard 14.2 install does have icons with the right names; maybe they're in the wrong locations?

Here's the patch when the '-m' option was added:
http://lists.shmoo.com/pipermail/hos...ch/032274.html
 
Old 06-28-2017, 11:12 AM   #13
mfoley
Senior Member
 
Registered: Oct 2008
Posts: 1,019

Original Poster
Rep: Reputation: 98
Quote:
Originally Posted by Loomx View Post
I too have been a happy user of wpa_gui for quite a while now. I found that networkmanager/wicd cause more problems than they solve for me.
Amen! inet1/wpa_supplicant is rock-sold, stays connected and has good throughput. NetworkManager and wicd obviously use some other mechanism for creating and maintaining connections that is flawed.
Quote:
Since I first saw your post I've tried to get the -m optiin to work too, but with no luck.
The best I can offer is that in my systems (both 14.2 and 14.2_64) it appears to be an icon issue - the standard icon is displayed as a fallback if it can't find the icons that indicate the different signal strength levels.
A standard 14.2 install does have icons with the right names; maybe they're in the wrong locations?

Here's the patch when the '-m' option was added:
http://lists.shmoo.com/pipermail/hos...ch/032274.html
Interesting. I will also do some research on this. Can you tell me the name[s] of the wpa_gui icon[s]?
 
Old 06-28-2017, 04:14 PM   #14
Loomx
Member
 
Registered: Sep 2012
Distribution: Slackware
Posts: 49

Rep: Reputation: Disabled
Quote:
NetworkManager and wicd obviously use some other mechanism for creating and maintaining connections that is flawed.
They both use wpa_supplicant to do the actual work, they just both add another layer on top which sometimes seems to get in the way. At least it's easy enough to do without them :-)

If my C-reading is right, the fallback icon (which it obviously does find) is either /icons/wpa_gui.svg or /icons/wpa_gui.png
The strength meter icons that it can't find are named as follows:
network-wireless-offline
network-wireless-acquiring
network-wireless-connected
network-wireless-signal-none
network-wireless-signal-weak
network-wireless-signal-ok
network-wireless-signal-good
network-wireless-signal-excellent

In the code, it look like it's looking for them in the current QT Theme:
Code:
    icon = QIcon::fromTheme("network-wireless-signal-good",
        fallback_icon);
although in the comment at the top of the patch s/he says this:
Quote:
Status icon names are based on various Gnome icon packs (e.g. Faba). When
icon can not be found, default one is shown (wpa_gui logo).
Maybe try to find/install Faba icon pack?

[edit] Those icon names are found in /usr/share/icons/{HighContrast,Adwaita} on my default 14.2 install (without /kde package series) but it still doesn't find them even when I set my icon theme to one of those :-(

Last edited by Loomx; 06-28-2017 at 05:11 PM.
 
1 members found this post helpful.
Old 06-28-2017, 10:28 PM   #15
mfoley
Senior Member
 
Registered: Oct 2008
Posts: 1,019

Original Poster
Rep: Reputation: 98
Loomx: great research and info. That'll save me some time. But, your last comment is a bit discouraging. However I do have KDE installed, so maybe I'll have better luck.

Last edited by mfoley; 06-28-2017 at 10:29 PM.
 
  


Reply

Tags
kde, wpa_cli


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] KDE launch display No Signal (after wine Steam Deus Ex launch crash) KGHN Slackware 5 01-21-2015 10:38 PM
Fedora 12 - Help! gtkpod does not auto-launch when ipod 5.5 gen is attached Ehtetur Fedora 0 12-07-2009 08:47 PM
Using Mozilla to auto-launch the KPPP dialer Cara25 Linux - Newbie 5 06-27-2006 04:46 PM
auto launch programs at login desmondtm Linux - Newbie 1 12-01-2005 04:51 PM
Bash to Auto Launch a Program???? embsupafly Linux - Software 1 07-27-2004 12:25 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration