LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-12-2018, 10:38 AM   #1
Lysander666
Member
 
Registered: Apr 2017
Location: London
Distribution: Slackware 14.2 + Xfce
Posts: 906
Blog Entries: 2

Rep: Reputation: 788Reputation: 788Reputation: 788Reputation: 788Reputation: 788Reputation: 788Reputation: 788
How to get Slackware fullscreen in VBox?


I am running one of my Slackware installs in Vbox. I have downloaded the guest additions iso and it's mounted. I have also installed:

virtualbox-guest-dkms

since Vbox is running from Debian.

However I still cannot get the VM to go fullscreen after using host + F. The window goes fullscreen but the res stays in the centre as 1024x768. Should I be doing something within the Slackware install in the VM?

Last edited by Lysander666; 05-12-2018 at 10:40 AM.
 
Old 05-12-2018, 11:30 AM   #2
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 / Slackware 14.2 current / Manjaro / Parrot
Posts: 7,352

Rep: Reputation: 1481Reputation: 1481Reputation: 1481Reputation: 1481Reputation: 1481Reputation: 1481Reputation: 1481Reputation: 1481Reputation: 1481Reputation: 1481
it may have something to do with the settings, open terminal and
VirtualBox
Code:
VBoxManage setextradata global GUI/MaxGuestResolution any

VBoxManage setextradata "VM-Name" CustomVideoMode1 1920x1200x32
VMware Workstation 4
guest additions is installed on the client not the host.
After you installed the guest additions did you reboot your system?

If the host key is RIGHT CONTROL. press RightControl + F or visa versa.

.

Last edited by BW-userx; 05-12-2018 at 11:33 AM.
 
1 members found this post helpful.
Old 05-12-2018, 11:42 AM   #3
Lysander666
Member
 
Registered: Apr 2017
Location: London
Distribution: Slackware 14.2 + Xfce
Posts: 906

Original Poster
Blog Entries: 2

Rep: Reputation: 788Reputation: 788Reputation: 788Reputation: 788Reputation: 788Reputation: 788Reputation: 788
Thanks BW, according to this VBoxManage is a host program:

https://forums.virtualbox.org/viewto...=49350#p224552

I tried it on the client and it said 'command not found', though the host seemed to accept it [after renaming VM to Slack]. Still no change on the display though, maybe it will work after a reboot.

Last edited by Lysander666; 05-12-2018 at 11:43 AM.
 
Old 05-12-2018, 11:58 AM   #4
upnort
Member
 
Registered: Oct 2014
Distribution: Slackware, Proxmox, Debian, CentOS, Ubuntu MATE
Posts: 772

Rep: Reputation: Disabled
Perhaps check the desktop environment settings. The desktop environment might be configured to the lower resolution. As a quick test try a different desktop environment or window manager.
 
Old 05-12-2018, 01:44 PM   #5
a4z
Senior Member
 
Registered: Feb 2009
Posts: 1,727

Rep: Reputation: 740Reputation: 740Reputation: 740Reputation: 740Reputation: 740Reputation: 740Reputation: 740
you need to install the vobx guest edition

its in the vbox menu, devices, last entry

it will mount a (virtual) cd rom,

you cd into this and say VBoxLinuxAdditions.run

restart the vm
 
1 members found this post helpful.
Old 05-14-2018, 02:24 PM   #6
Lysander666
Member
 
Registered: Apr 2017
Location: London
Distribution: Slackware 14.2 + Xfce
Posts: 906

Original Poster
Blog Entries: 2

Rep: Reputation: 788Reputation: 788Reputation: 788Reputation: 788Reputation: 788Reputation: 788Reputation: 788
Quote:
Originally Posted by a4z View Post
you need to install the vobx guest edition

its in the vbox menu, devices, last entry

it will mount a (virtual) cd rom,

you cd into this and say VBoxLinuxAdditions.run

restart the vm
Thanks, finally sorted it out.

I went into the guest additions CD, it was in the left-hand pane in Thunar since I had mounted it. I then copied VBoxLinuxAdditions.run to /tmp re this video at around the 10 min mark:

https://www.youtube.com/watch?v=6eNkWH8PI7g

I then as root just entered

Code:
/tmp/VBoxLinuxAdditions.run
into the terminal and it installed. I rebooted the Slack VM and I'm now fullscreen when selecting Auto-resize display from the View menu.

Last edited by Lysander666; 05-15-2018 at 04:15 AM.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] vbox 4.0.2 - guest sabayon5.4 on win7 - mnt local gentoo from vbox sabayon? shinystuffrox Linux - Virtualization and Cloud 1 03-04-2011 02:10 AM
VBox NIC not working in slackware 13 guest aphraz Linux - Virtualization and Cloud 3 02-27-2011 05:38 AM
VBox in Slackware 13.1 gregkedro Linux - Virtualization and Cloud 5 08-05-2010 09:26 AM
Slackware 12.2 Hangs in VBox VM AstroTux Slackware 3 01-02-2010 12:35 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 12:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration