-   Slackware (
-   -   how to get an wireless iw3945 on Slackware 14 working? (

pardalian 01-19-2013 10:19 AM

how to get an wireless iw3945 on Slackware 14 working?
I have installed Slackware14 x86 on a Dell latitude D820 and I do not know how to get the wireless adapter to work.

I am sure that my wireless adapter is a 3945ABG I used lspci to identify it

I manged to find some iwlwifi-3945-ucode files from and from but I haven't been able to install none of them from the guides or tutorials about installation (at least not correctly)

Note I have freshly reinstalled the Slack so that all that I did will not affect your advice, I am waiting for guidance :D

I have read what I could find on the internet and here on Linuxquestions but nothing worked for me so far.

If anyone could help please note that I am a 48 hours beginner so pretty please step by step if you can :newbie:.

tuxbg 01-19-2013 10:52 AM

tuxbg 01-19-2013 11:05 AM

modprobe iwlegacy

pardalian 01-19-2013 11:37 AM

ok I have downloaded the files but I might need some help to install them
the modprobe iwlegacy results in: FATAL: module iwlegacy not found

tuxbg 01-19-2013 11:43 AM

installpkg <package name>
And here is a module

Just download all files in that directory and become root.Then run sh ipw3945.SlackBuild,after that install package.Then modprobe ipw3945

pardalian 01-19-2013 12:06 PM

ok did all that but the sh command gives me an error :


Building ...

WARNING: Your kernel contains ieee80211 symbol definitions and you
are not using the kernel's default ieee80211 subsystem. (Perhaps you
used the out-of-tree ieee80211 subsystem's 'make install' or have
provided a path to the ieee80211 subsystem via IEEE80211_INC.)

If you wish to use the out-of-tree ieee80211 subsystem then it is
recommended to use that projects' "make patch_kernel" facility
and rebuild your kernel to update the Module symbol version information.

Failure to do this may result in build warnings and unexpected
behavior when running modules which rely on the ieee80211 subsystem.

Aborting the build. You can force the build to continue by adding:


to your make command line.

make: *** [check_inc] Error 1
install: cannot stat 'ipw3945.ko': No such file or directory
ipw3945.SlackBuild FAILED at line 188!

tuxbg 01-19-2013 12:36 PM

I dont know about that error but here is a package

pardalian 01-19-2013 01:27 PM

Thx but sill not working I understand that I have to configure a file named firmware.agent but the location specified does not exist (/etc/hotplug/firmware.agent)

tuxbg 01-19-2013 01:55 PM

Where you read this ?
Just install firmware and the package that include intel module,reboot your machine,and then modprobe modules

red_fire 01-20-2013 09:03 PM

that's really weird.. mine has been working out of the box since Slackware 13.0. you shouldn't need to install anything else. I use kernel-huge, try booting that one first and then check if the module is loaded.

first remove the driver you installed to prevent conflicts. then, edit /etc/lilo.conf and point the booting to your kernel-huge in /boot . If you did a full installation, it should be there. I don't use lilo myself but it should look similar to this


# Linux bootable partition config begins
image = /boot/vmlinuz-huge-kernel-version
  root = /dev/sda6
  label = Slackware
# Linux bootable partition config ends

don't forget to run

to update the configuration.

after booting, check if the module is loaded.


(the name of the module is iwl3945 under iwl_legacy)

otherwise, load the module.


#modprobe iwl3945
if you use GUI, try using wicd (can be found in slackware official repository under /extra) or NetworkManager (should be installed) to test the wireless. start NetworkManager first


#chmod +x /etc/rc.d/rc.networkmanager
#/etc/rc.d/rc.networkmanager start

then it should be loaded automatically in KDE and XFCE when either one starts.

pardalian 01-21-2013 11:03 AM

I'm not home for another two days to try but I'll let you know if it works ... thank you

pardalian 01-22-2013 04:32 AM

Thank you very much ... it seems that the problem was my install disk (I realised that when my lilo started acting up and other processes failed) ... after re-burning the slack image on a new dvd even the install process went faster and the wifi was installed "out of the box" it was only a matter of starting the networkmanager : /etc/rc.d/rc.networkmanager start and problem solved.

thank you for the help

All times are GMT -5. The time now is 11:17 PM.