LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-08-2011, 11:47 AM   #1
yangzhichina
LQ Newbie
 
Registered: Nov 2010
Location: China P.R.
Distribution: Slackware 13.37
Posts: 13

Rep: Reputation: 0
Unhappy how to enable scim to input chinese?


Hello Guys,

I need your help. I finished my installation of Slackware 13.37, but I found I cannot input chinese using pinyin in KDE. Of course, I started "scim input method", I mean I can see the icon of keyboard in the tray bar, but I cannot swith input method into chinese with "Control + Space".

What can I do for this issue? Thank you.

Jeffrey.
 
Old 06-08-2011, 07:58 PM   #2
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 4,168

Rep: Reputation: 1395Reputation: 1395Reputation: 1395Reputation: 1395Reputation: 1395Reputation: 1395Reputation: 1395Reputation: 1395Reputation: 1395Reputation: 1395
It's well documented in CHANGES_AND_HINTS

Quote:
Input methods for complex characters (CJK, which is shorthand for Chinese,
Japanese, Korean) and other non-latin character sets have been added. These
input methods use the SCIM (Smart Common Input Method) platform.
The environment variables for SCIM support are set in /etc/profile.d/scim.sh
The requirements for getting SCIM input methods to work in your X session
are as follows:
(1) Use a UTF-8 locale. Look in /etc/profile.d/lang.sh for setting your
language to (for instance) en_US.UTF-8. As a word of warning: maybe you
should leave root with a non-UTF-8 locale because you don't want root's
commands to be misinterpreted. You can add the following line to your
~/.profile file to enable UTF-8 just for yourself:
export LANG=en_US.UTF-8
(2) Make the scim profile scripts executable. These will setup your
environment correctly for the use of scim with X applications. Run:
chmod +x /etc/profile.d/scim.*
(3) Start the scim daemon as soon as your X session starts. The scim daemon
must be active before any of your X applications. In KDE, you can add a
shell script to the ~/.kde/Autostart folder that runs the command
"scim -d". In XFCE you can add "scim -d" to the Autostarted Applications.
If you boot your computer in runlevel 4 (the graphical XDM/KDM login)
you can simply add the line "scim -d" to your ~/.xprofile file.
This gives you a Desktop Environment independent way of starting scim.
When scim is running, you will see a small keyboard icon in your system tray.
Right-click it to enter SCIM Setup. In 'Global Setup' select your keyboard
layout, and you are ready to start entering just about any language
characters you wish! Press the magical key combo <Control><Space>
in order to activate or deactivate SCIM input. The SCIM taskbar in the
desktop's corner allows you to select a language. As you type, SCIM will show
an overview of applicable character glyphs (if you are inputting complex
characters like Japanese).
 
2 members found this post helpful.
Old 06-09-2011, 11:41 AM   #3
yangzhichina
LQ Newbie
 
Registered: Nov 2010
Location: China P.R.
Distribution: Slackware 13.37
Posts: 13

Original Poster
Rep: Reputation: 0
Unhappy

Quote:
Originally Posted by willysr View Post
It's well documented in CHANGES_AND_HINTS
Sorry, it still doesn't work. I have done that like you quoted. I can see the tray icon like keyboard, but cannot switch IM to smart-pinyin.

My process of KDE starting is made of 2 parts.the first one is to get console started, the second one is to start KDE using "startx". Is it related to this issue?

Thanks.
 
Old 06-09-2011, 12:39 PM   #4
yuuko
Member
 
Registered: May 2011
Distribution: Slackware-current
Posts: 42

Rep: Reputation: 21
Note that 'Control+space' is *not* the key combo for switching input method. It might be 'Control+Alt+Down/Up', but I really don't remember.
Slackware come with all the input methods enabled by default. I'd suggest you have a look at the 'IMEngine Global Setup' page and disable the input methods you don't need.
 
Old 06-09-2011, 05:17 PM   #5
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,069

Rep: Reputation: 160Reputation: 160
Quote:
Originally Posted by yangzhichina View Post
Hello Guys,

I need your help. I finished my installation of Slackware 13.37, but I found I cannot input chinese using pinyin in KDE. Of course, I started "scim input method", I mean I can see the icon of keyboard in the tray bar, but I cannot swith input method into chinese with "Control + Space".

What can I do for this issue? Thank you.

Jeffrey.
Did you chmod +x /etc/profile.d/scim.sh ?
 
1 members found this post helpful.
Old 06-09-2011, 05:23 PM   #6
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 8,077

Rep: Reputation: 6865Reputation: 6865Reputation: 6865Reputation: 6865Reputation: 6865Reputation: 6865Reputation: 6865Reputation: 6865Reputation: 6865Reputation: 6865Reputation: 6865
Quote:
Originally Posted by yuuko View Post
Note that 'Control+space' is *not* the key combo for switching input method. It might be 'Control+Alt+Down/Up', but I really don't remember.
Slackware come with all the input methods enabled by default. I'd suggest you have a look at the 'IMEngine Global Setup' page and disable the input methods you don't need.
Ctrl-Space is the correct combo.

Like guanx states, you need to have /etc/profile.d/scim.sh set executable and also you need to start scim early in your X startup sequence - before all your applications start.

Eric
 
1 members found this post helpful.
Old 06-09-2011, 06:45 PM   #7
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 4,168

Rep: Reputation: 1395Reputation: 1395Reputation: 1395Reputation: 1395Reputation: 1395Reputation: 1395Reputation: 1395Reputation: 1395Reputation: 1395Reputation: 1395
Quote:
Originally Posted by yuuko View Post
Note that 'Control+space' is *not* the key combo for switching input method. It might be 'Control+Alt+Down/Up', but I really don't remember.
Control+Space is for active/deactivate
Control+Alt+Down/Up is for switching between language/dialect
 
Old 06-10-2011, 10:57 AM   #8
yangzhichina
LQ Newbie
 
Registered: Nov 2010
Location: China P.R.
Distribution: Slackware 13.37
Posts: 13

Original Poster
Rep: Reputation: 0
Thank you guys. Willysr is right. My smart-pinyin works, finally. I'm guessing that only one thing I don't make is to re-start my Slackware.

Now summarize as fellow:
1. Change en_US to en_US.UTF-8 in /etc/profile.d/lang.sh
2. chmod +x /etc/profile.d/scim.sh, if it's not executable.
3. Make a script manually to start scim using "/usr/bin/scim -d &", and put it in the "~/.kde/Autostart/".
4. Restart computer.

I think everything is ok. However, there's one thing wired: It's true that I can switch IM to smart-pinyin with Control + Space, the keyboard icon in tray bar disappears though. Is this a bug for KDE?
 
Old 06-10-2011, 11:02 AM   #9
flyer103
Member
 
Registered: Mar 2010
Location: Beijing, China
Distribution: Slackware
Posts: 41

Rep: Reputation: 1
I use fcitx as Chinese input method and it works ok ^_^
 
Old 06-14-2011, 08:38 AM   #10
markluocanada
Member
 
Registered: Dec 2006
Location: Shanghai China
Distribution: Slackware 13.1_x86_32
Posts: 143

Rep: Reputation: 17
yangzhichina,don't exactly follow what you meant, the keyboard icon will be replaced by '智'at my Slackware..though I am using XFCE..

You can try
Quote:
xwmconfig
and choose XFCE, and then restart X, and add
Quote:
scim -d
in Session and Startup in XFCE, to see if the same thing happens in this FM.

Mark
 
Old 06-14-2011, 08:56 AM   #11
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 4,168

Rep: Reputation: 1395Reputation: 1395Reputation: 1395Reputation: 1395Reputation: 1395Reputation: 1395Reputation: 1395Reputation: 1395Reputation: 1395Reputation: 1395
Quote:
Originally Posted by yangzhichina View Post
Thank you guys. Willysr is right. My smart-pinyin works, finally. I'm guessing that only one thing I don't make is to re-start my Slackware.

Now summarize as fellow:
1. Change en_US to en_US.UTF-8 in /etc/profile.d/lang.sh
2. chmod +x /etc/profile.d/scim.sh, if it's not executable.
3. Make a script manually to start scim using "/usr/bin/scim -d &", and put it in the "~/.kde/Autostart/".
4. Restart computer.

I think everything is ok. However, there's one thing wired: It's true that I can switch IM to smart-pinyin with Control + Space, the keyboard icon in tray bar disappears though. Is this a bug for KDE?
It's not a bug
You can have it displayed by picking Settings > SCIM Input Method Setup on KDE
 
1 members found this post helpful.
Old 06-21-2011, 08:59 AM   #12
yangzhichina
LQ Newbie
 
Registered: Nov 2010
Location: China P.R.
Distribution: Slackware 13.37
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by willysr View Post
It's not a bug
You can have it displayed by picking Settings > SCIM Input Method Setup on KDE
Thanks for your tip.

But I think it's truly a bug. I have checked "Show tray icon" in the SCIM settings, however it remains disappearing.
I uncheck -> apply it firstly, and check -> apply it again, now the icon shows finally.


Er... If you don't mind, I have another question for you here. Why do you use Slackware? It doesn't have popular software repo, it's not convenient for users to setup software. They have to deal with dependencies by themselves. Is it worth it? I know the KISS is the point, but I don't feel it at the time. Of course, I am not expert on Slackware. So, could you tell me how you understand the Slackware? Thank you.
 
0 members found this post helpful.
Old 06-21-2011, 09:36 AM   #13
markluocanada
Member
 
Registered: Dec 2006
Location: Shanghai China
Distribution: Slackware 13.1_x86_32
Posts: 143

Rep: Reputation: 17
yangzhichina, just trying to share something I am with Slackware.

1. Slackware forces you to learn Linux, and I am still struggling a lot.
2. Slackware has Slackbuilds.org, which has tons of nice apps, and somehow let you know the dependence issues as well.
3. For Chinese apps, I have to agree with you that there are not many options available, though we can try Wine sometimes.. PPStream, and Da Zhi Hui have linux version, which I use quite often.
4. Slackware is quite fast, and stable, and very flexible.

The list goes quite long..

There are quite some sticky threads here you can try to read it to learn more about Slackware. Slackware Esstential, and Basic Slackare are two books you can try as well.. IMHO.
Mark
 
1 members found this post helpful.
Old 06-21-2011, 10:22 AM   #14
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 4,168

Rep: Reputation: 1395Reputation: 1395Reputation: 1395Reputation: 1395Reputation: 1395Reputation: 1395Reputation: 1395Reputation: 1395Reputation: 1395Reputation: 1395
Quote:
Originally Posted by yangzhichina View Post
Er... If you don't mind, I have another question for you here. Why do you use Slackware? It doesn't have popular software repo, it's not convenient for users to setup software. They have to deal with dependencies by themselves. Is it worth it? I know the KISS is the point, but I don't feel it at the time. Of course, I am not expert on Slackware. So, could you tell me how you understand the Slackware? Thank you.
By using Slackware, i learned lots of things that i may not learn it if i use another distro since they already take care all of it. All those automatic package management, dependency checking, and all those fancy features are what other distro can provide, but in Slackware, we learn about the knowledge about a Linux Operating System + All those applications works
 
1 members found this post helpful.
Old 06-22-2011, 11:23 AM   #15
yangzhichina
LQ Newbie
 
Registered: Nov 2010
Location: China P.R.
Distribution: Slackware 13.37
Posts: 13

Original Poster
Rep: Reputation: 0
Thank you guys for these great tips. Especially Willysr & Markluocanada, you give me more.

I will feel this system well. Hope I can understand the KISS of Slack. :-)
 
  


Reply

Tags
scim


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help: Chinese Input Using Scim/pinyin sso SUSE / openSUSE 1 02-18-2009 08:56 PM
Why I can't input chinese with scim yearnjia Linux - Desktop 4 01-29-2009 05:15 PM
How to enable Chinese input in opera using scim? nos1833 Linux - Software 0 03-24-2008 02:06 AM
No idea what's going on (about chinese input using SCIM) MichaelYoung Debian 1 10-19-2006 07:54 AM
Chinese input using SCIM in OpenOffice satellite360 Linux - Software 4 05-17-2005 09:21 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration