LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 03-31-2020, 09:42 AM   #1
MozillaUser3172
LQ Newbie
 
Registered: Mar 2020
Posts: 23

Rep: Reputation: Disabled
How to disable screen zoom?


This feature, which I didn't ask for, keeps getting me in trouble.
If I accidentally press Alt when momentum scrolling is happening, then every movement of a web page downward will be incorrectly registered like a down arrow key being pressed, which it is not, and zooming in will rapidly happen.

UPDATE
This defect is caused by the very bad idea from the X project which implements momentum scrolling in the DRIVER, not in the UI library layer like is done on iOS, Android, MacOS. So the driver sends a series of vertical up/down arrow keys to simulate momentum. Even after scrolling is stopped because the top/bottom has been reached, the keys keep coming because the DRIVER has no idea that the app doesn't need them anymore. This is clearly bad design. In fact it's an inversion of responsibility.

Last edited by MozillaUser3172; 03-31-2020 at 05:43 PM.
 
Old 03-31-2020, 12:21 PM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 8,063

Rep: Reputation: 6825Reputation: 6825Reputation: 6825Reputation: 6825Reputation: 6825Reputation: 6825Reputation: 6825Reputation: 6825Reputation: 6825Reputation: 6825Reputation: 6825
So stop pressing Alt when you are scrolling. Problem solved. Or stop using computers.
 
2 members found this post helpful.
Old 03-31-2020, 01:34 PM   #3
keeneadt
Member
 
Registered: Feb 2020
Distribution: Slackware
Posts: 56

Rep: Reputation: Disabled
In xfce Settings > Settings Editor > xfwm4 > zoom_desktop
 
2 members found this post helpful.
Old 03-31-2020, 05:46 PM   #4
MozillaUser3172
LQ Newbie
 
Registered: Mar 2020
Posts: 23

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Alien Bob View Post
Or stop using computers.
He who defends crap work often produces it.
 
Old 03-31-2020, 06:33 PM   #5
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 7,060

Rep: Reputation: 4734Reputation: 4734Reputation: 4734Reputation: 4734Reputation: 4734Reputation: 4734Reputation: 4734Reputation: 4734Reputation: 4734Reputation: 4734Reputation: 4734
Quote:
Originally Posted by MozillaUser3172 View Post
He who defends crap work often produces it.
You're complaining about a feature that can be disabled.

As to your determination on why this happens, again, this is outside of the scope of Slackware, which just tries to package upstream packages as they provide them. You need to take these types of bug reports to upstream and hopefully they'll decide to get a fix implemented. If they don't implement a fix, but a patch is available, make the Slackware dev team aware of it and they'll balance the fix against the desire to stay vanilla and will decide what to do.
 
3 members found this post helpful.
Old 03-31-2020, 07:34 PM   #6
montagdude
Senior Member
 
Registered: Apr 2016
Distribution: Slackware
Posts: 1,758

Rep: Reputation: 1339Reputation: 1339Reputation: 1339Reputation: 1339Reputation: 1339Reputation: 1339Reputation: 1339Reputation: 1339Reputation: 1339Reputation: 1339
Quote:
Originally Posted by bassmadrigal View Post
You're complaining about a feature that can be disabled.
To be fair, Alien Bob's post was pure provocation and not helpful at all. Obviously the OP knows the problem can be solved by not pressing Alt while scrolling, but I can see how that can be difficult with the whole scrolling "momentum" thing going on if one uses the Alt key frequently in their workflow. He asked how to disable screen zoom, not how to stop pressing Alt.

Last edited by montagdude; 03-31-2020 at 07:37 PM.
 
1 members found this post helpful.
Old 04-01-2020, 05:30 AM   #7
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 8,063

Rep: Reputation: 6825Reputation: 6825Reputation: 6825Reputation: 6825Reputation: 6825Reputation: 6825Reputation: 6825Reputation: 6825Reputation: 6825Reputation: 6825Reputation: 6825
Quote:
Originally Posted by montagdude View Post
To be fair, Alien Bob's post was pure provocation and not helpful at all.
Correct. The reason? I invite you to visit the content of other posts by this user that he created on this forum.
 
1 members found this post helpful.
Old 04-01-2020, 06:40 AM   #8
montagdude
Senior Member
 
Registered: Apr 2016
Distribution: Slackware
Posts: 1,758

Rep: Reputation: 1339Reputation: 1339Reputation: 1339Reputation: 1339Reputation: 1339Reputation: 1339Reputation: 1339Reputation: 1339Reputation: 1339Reputation: 1339
Quote:
Originally Posted by Alien Bob View Post
Correct. The reason? I invite you to visit the content of other posts by this user that he created on this forum.
I don't care to, but I'll take your word for it.
 
Old 04-01-2020, 10:25 AM   #9
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 7,060

Rep: Reputation: 4734Reputation: 4734Reputation: 4734Reputation: 4734Reputation: 4734Reputation: 4734Reputation: 4734Reputation: 4734Reputation: 4734Reputation: 4734Reputation: 4734
Quote:
Originally Posted by montagdude View Post
To be fair, Alien Bob's post was pure provocation and not helpful at all. Obviously the OP knows the problem can be solved by not pressing Alt while scrolling, but I can see how that can be difficult with the whole scrolling "momentum" thing going on if one uses the Alt key frequently in their workflow. He asked how to disable screen zoom, not how to stop pressing Alt.
I found the exact same thing keeneadt did after googling "disable alt scroll zoom". The very first link for me is How can I disable Alt-Scroll zoom in Xubuntu 14.04? on askubuntu and the first answer is to do what keeneadt posted.

The real solution isn't to stop pressing alt, and Alien Bob knew that. But it seemed MozillaUser3172 hadn't even tried searching for this and comes in to complain about a feature (since this is a feature on xfce) that can be easily disabled with minimal searching on how to disable it.
 
Old 04-01-2020, 10:43 AM   #10
MozillaUser3172
LQ Newbie
 
Registered: Mar 2020
Posts: 23

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by bassmadrigal View Post
You're complaining about a feature that can be disabled.
No, only the screen zoom part can be disabled.
 
Old 04-01-2020, 10:47 AM   #11
MozillaUser3172
LQ Newbie
 
Registered: Mar 2020
Posts: 23

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by montagdude View Post
He asked how to disable screen zoom, not how to stop pressing Alt.
There are two zooms affected: The screen zoom and the window zoom. The latter is just as problematic.

To explain again, in Firefox if I scroll with momentum and the window hits the top or bottom, the Synaptics "kinetic" momentum feature keeps sending up/down key presses, because the browser has no way to inform it that the scrolling has stopped, thus after scrolling ends one has to wait for a while before pressing CTRL.
 
Old 04-01-2020, 10:48 AM   #12
MozillaUser3172
LQ Newbie
 
Registered: Mar 2020
Posts: 23

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by montagdude View Post
I don't care to, but I'll take your word for it.
So he slanders me and you blindly believe him? Smart.
 
Old 04-01-2020, 10:53 AM   #13
MozillaUser3172
LQ Newbie
 
Registered: Mar 2020
Posts: 23

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by montagdude View Post
I can see how that can be difficult with the whole scrolling "momentum" thing going on if one uses the Alt key frequently in their workflow. He asked how to disable screen zoom, not how to stop pressing Alt.
I assumed it was all well designed. After I posted the original question, I found out that momentum scrolling was implemented as a terrible hack that any respectable programmer should be find repulsive.

Last edited by MozillaUser3172; 04-01-2020 at 10:55 AM.
 
Old 04-01-2020, 11:15 AM   #14
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 7,060

Rep: Reputation: 4734Reputation: 4734Reputation: 4734Reputation: 4734Reputation: 4734Reputation: 4734Reputation: 4734Reputation: 4734Reputation: 4734Reputation: 4734Reputation: 4734
Quote:
Originally Posted by MozillaUser3172 View Post
No, only the screen zoom part can be disabled.
Maybe you should provide more information on the post so that people can better help you. You didn't mention your DE at all, but after googling "alt scroll zoom" it seems to imply it is xfce based and led us to provide the answers that were provided.

These are xfce features and if something is not able to be configured, that will need to be addressed through xfce devs. You may also want to try posting in https://forum.xfce.org to see if they're aware of some other option to change the behavior of this function. If this is that frustrating to you, you may want to try a different DE/WM.
 
Old 04-01-2020, 02:09 PM   #15
drgibbon
Member
 
Registered: Nov 2014
Distribution: Slackware64 -current
Posts: 667

Rep: Reputation: 426Reputation: 426Reputation: 426Reputation: 426Reputation: 426
Quote:
Originally Posted by MozillaUser3172 View Post
So he slanders me and you blindly believe him? Smart.
Probably doesn't care all that much
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Everytime I try to screen share, on both Skype and zoom my screen goes black joezero Linux - Newbie 3 07-31-2016 07:21 AM
why would my columns in LibreOffice separate as zoom out and overlap as zoom in 1sweetwater! Linux - Software 18 02-10-2015 08:50 AM
Query regarding "Zoom in" and "Zoom Out" on Fedora-17 ajaygarg Linux - Desktop 2 12-03-2012 11:59 PM
Zoom Zoom barnelli-jones LinuxQuestions.org Member Intro 1 06-27-2012 08:55 PM
plasma hangs - zoom out but no zoom in CollieJim Linux - Desktop 3 04-06-2010 08:53 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 05:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration