LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   How to disable screen zoom? (https://www.linuxquestions.org/questions/slackware-14/how-to-disable-screen-zoom-4175672289/)

MozillaUser3172 03-31-2020 09:42 AM

How to disable screen zoom?
 
This feature, which I didn't ask for, keeps getting me in trouble.
If I accidentally press Alt when momentum scrolling is happening, then every movement of a web page downward will be incorrectly registered like a down arrow key being pressed, which it is not, and zooming in will rapidly happen.

UPDATE
This defect is caused by the very bad idea from the X project which implements momentum scrolling in the DRIVER, not in the UI library layer like is done on iOS, Android, MacOS. So the driver sends a series of vertical up/down arrow keys to simulate momentum. Even after scrolling is stopped because the top/bottom has been reached, the keys keep coming because the DRIVER has no idea that the app doesn't need them anymore. This is clearly bad design. In fact it's an inversion of responsibility.

Alien Bob 03-31-2020 12:21 PM

So stop pressing Alt when you are scrolling. Problem solved. Or stop using computers.

keeneadt 03-31-2020 01:34 PM

In xfce Settings > Settings Editor > xfwm4 > zoom_desktop

MozillaUser3172 03-31-2020 05:46 PM

Quote:

Originally Posted by Alien Bob (Post 6106311)
Or stop using computers.

He who defends crap work often produces it.

bassmadrigal 03-31-2020 06:33 PM

Quote:

Originally Posted by MozillaUser3172 (Post 6106430)
He who defends crap work often produces it.

You're complaining about a feature that can be disabled.

As to your determination on why this happens, again, this is outside of the scope of Slackware, which just tries to package upstream packages as they provide them. You need to take these types of bug reports to upstream and hopefully they'll decide to get a fix implemented. If they don't implement a fix, but a patch is available, make the Slackware dev team aware of it and they'll balance the fix against the desire to stay vanilla and will decide what to do.

montagdude 03-31-2020 07:34 PM

Quote:

Originally Posted by bassmadrigal (Post 6106444)
You're complaining about a feature that can be disabled.

To be fair, Alien Bob's post was pure provocation and not helpful at all. Obviously the OP knows the problem can be solved by not pressing Alt while scrolling, but I can see how that can be difficult with the whole scrolling "momentum" thing going on if one uses the Alt key frequently in their workflow. He asked how to disable screen zoom, not how to stop pressing Alt.

Alien Bob 04-01-2020 05:30 AM

Quote:

Originally Posted by montagdude (Post 6106454)
To be fair, Alien Bob's post was pure provocation and not helpful at all.

Correct. The reason? I invite you to visit the content of other posts by this user that he created on this forum.

montagdude 04-01-2020 06:40 AM

Quote:

Originally Posted by Alien Bob (Post 6106582)
Correct. The reason? I invite you to visit the content of other posts by this user that he created on this forum.

I don't care to, but I'll take your word for it.

bassmadrigal 04-01-2020 10:25 AM

Quote:

Originally Posted by montagdude (Post 6106454)
To be fair, Alien Bob's post was pure provocation and not helpful at all. Obviously the OP knows the problem can be solved by not pressing Alt while scrolling, but I can see how that can be difficult with the whole scrolling "momentum" thing going on if one uses the Alt key frequently in their workflow. He asked how to disable screen zoom, not how to stop pressing Alt.

I found the exact same thing keeneadt did after googling "disable alt scroll zoom". The very first link for me is How can I disable Alt-Scroll zoom in Xubuntu 14.04? on askubuntu and the first answer is to do what keeneadt posted.

The real solution isn't to stop pressing alt, and Alien Bob knew that. But it seemed MozillaUser3172 hadn't even tried searching for this and comes in to complain about a feature (since this is a feature on xfce) that can be easily disabled with minimal searching on how to disable it.

MozillaUser3172 04-01-2020 10:43 AM

Quote:

Originally Posted by bassmadrigal (Post 6106444)
You're complaining about a feature that can be disabled.

No, only the screen zoom part can be disabled.

MozillaUser3172 04-01-2020 10:47 AM

Quote:

Originally Posted by montagdude (Post 6106454)
He asked how to disable screen zoom, not how to stop pressing Alt.

There are two zooms affected: The screen zoom and the window zoom. The latter is just as problematic.

To explain again, in Firefox if I scroll with momentum and the window hits the top or bottom, the Synaptics "kinetic" momentum feature keeps sending up/down key presses, because the browser has no way to inform it that the scrolling has stopped, thus after scrolling ends one has to wait for a while before pressing CTRL.

MozillaUser3172 04-01-2020 10:48 AM

Quote:

Originally Posted by montagdude (Post 6106606)
I don't care to, but I'll take your word for it.

So he slanders me and you blindly believe him? Smart.

MozillaUser3172 04-01-2020 10:53 AM

Quote:

Originally Posted by montagdude (Post 6106454)
I can see how that can be difficult with the whole scrolling "momentum" thing going on if one uses the Alt key frequently in their workflow. He asked how to disable screen zoom, not how to stop pressing Alt.

I assumed it was all well designed. After I posted the original question, I found out that momentum scrolling was implemented as a terrible hack that any respectable programmer should be find repulsive.

bassmadrigal 04-01-2020 11:15 AM

Quote:

Originally Posted by MozillaUser3172 (Post 6106674)
No, only the screen zoom part can be disabled.

Maybe you should provide more information on the post so that people can better help you. You didn't mention your DE at all, but after googling "alt scroll zoom" it seems to imply it is xfce based and led us to provide the answers that were provided.

These are xfce features and if something is not able to be configured, that will need to be addressed through xfce devs. You may also want to try posting in https://forum.xfce.org to see if they're aware of some other option to change the behavior of this function. If this is that frustrating to you, you may want to try a different DE/WM.

drgibbon 04-01-2020 02:09 PM

Quote:

Originally Posted by MozillaUser3172 (Post 6106678)
So he slanders me and you blindly believe him? Smart.

Probably doesn't care all that much ;)


All times are GMT -5. The time now is 08:56 AM.