LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 12-04-2017, 09:01 AM   #1
Aeterna
Member
 
Registered: Aug 2017
Location: Terra Mater
Distribution: VM Host: Slackware-current, VM Guests: Artix, CRUX, FreeBSD, Funtoo, HardenedBSD, OpenIndiana
Posts: 86

Rep: Reputation: Disabled
how to disable kdeconnectd


Hello,
Is there any way to disable kdeconnectd?
In plasma settings I see only option to connect to Android. But I don't see a way to stop it listening on tcp/udp 1716

thank you
 
Old 12-04-2017, 01:37 PM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 6,725

Rep: Reputation: 4092Reputation: 4092Reputation: 4092Reputation: 4092Reputation: 4092Reputation: 4092Reputation: 4092Reputation: 4092Reputation: 4092Reputation: 4092Reputation: 4092
System Settings > Startup and Shutdown > Service Manager > Startup Services.
There you un-check the "KDE Connect" service so that it no longer starts automatically when you login.
 
3 members found this post helpful.
Old 12-04-2017, 05:24 PM   #3
Aeterna
Member
 
Registered: Aug 2017
Location: Terra Mater
Distribution: VM Host: Slackware-current, VM Guests: Artix, CRUX, FreeBSD, Funtoo, HardenedBSD, OpenIndiana
Posts: 86

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Alien Bob View Post
System Settings > Startup and Shutdown > Service Manager > Startup Services.
There you un-check the "KDE Connect" service so that it no longer starts automatically when you login.

Thank you very much,

Unfortunately this option is not available anymore although I was using this setting before
System Settings > Startup and Shutdown >
Service Manager -> not present/not available

https://ibb.co/hMz7cw

Last edited by Aeterna; 12-04-2017 at 05:25 PM.
 
Old 12-04-2017, 05:47 PM   #4
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 6,725

Rep: Reputation: 4092Reputation: 4092Reputation: 4092Reputation: 4092Reputation: 4092Reputation: 4092Reputation: 4092Reputation: 4092Reputation: 4092Reputation: 4092Reputation: 4092
So you are not using the KDE4 of Slackware then. Plasma5 instead? You should mention that you run a customized setup if you post in this forum.
 
Old 12-04-2017, 06:03 PM   #5
Aeterna
Member
 
Registered: Aug 2017
Location: Terra Mater
Distribution: VM Host: Slackware-current, VM Guests: Artix, CRUX, FreeBSD, Funtoo, HardenedBSD, OpenIndiana
Posts: 86

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Alien Bob View Post
So you are not using the KDE4 of Slackware then. Plasma5 instead? You should mention that you run a customized setup if you post in this forum.
this is exactly what my first post says

Quote:
Originally Posted by Aeterna View Post
Hello,
Is there any way to disable kdeconnectd?
In plasma settings I see only option to connect to Android. But I don't see a way to stop it listening on tcp/udp 1716

thank you
 
Old 12-04-2017, 06:25 PM   #6
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 6,725

Rep: Reputation: 4092Reputation: 4092Reputation: 4092Reputation: 4092Reputation: 4092Reputation: 4092Reputation: 4092Reputation: 4092Reputation: 4092Reputation: 4092Reputation: 4092
Quote:
Originally Posted by Aeterna View Post
this is exactly what my first post says
Nope, at a minimum it was ambiguous. The desktop environment in KDE4 was already called Plasma, and it was developed further into Plasma 5 (at which time the acronym KDE5 was dropped and Plasma5 became the norm).
If you use a non-standard installation please always mention in what ways you are deviating from a regular Slackware installation (I installed product X from location Y).
 
Old 12-04-2017, 06:37 PM   #7
Aeterna
Member
 
Registered: Aug 2017
Location: Terra Mater
Distribution: VM Host: Slackware-current, VM Guests: Artix, CRUX, FreeBSD, Funtoo, HardenedBSD, OpenIndiana
Posts: 86

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Alien Bob View Post
Nope, at a minimum it was ambiguous. The desktop environment in KDE4 was already called Plasma, and it was developed further into Plasma 5 (at which time the acronym KDE5 was dropped and Plasma5 became the norm).
If you use a non-standard installation please always mention in what ways you are deviating from a regular Slackware installation (I installed product X from location Y).
I like your Plasma but, this tread is just becoming useless bickering going nowhere.
This is some sort of annoying fashion at LQ?


I noticed though that Funtoo latest KDE does not have Service Manager either.

Problem "solved"

Last edited by Aeterna; 12-04-2017 at 06:38 PM.
 
Old 12-04-2017, 06:39 PM   #8
heyjann
Member
 
Registered: Dec 2015
Posts: 72

Rep: Reputation: Disabled
If you are using any custom packages that replace regular Slackware packages with the same name, the number of people who might know the answer will be much lower. Best hinted at in post title itself.

Anyway...

Does the file /etc/kde/xdg/autostart/kdeconnectd.desktop exist on your system? If so, it'd be the first file I'd try modifying (/sabotaging).

According to this page, a Hidden = true setting disables autostarting:
https://github.com/vasi/kdelibs/blob...ADME.autostart
 
Old 12-04-2017, 07:46 PM   #9
Aeterna
Member
 
Registered: Aug 2017
Location: Terra Mater
Distribution: VM Host: Slackware-current, VM Guests: Artix, CRUX, FreeBSD, Funtoo, HardenedBSD, OpenIndiana
Posts: 86

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by heyjann View Post
If you are using any custom packages that replace regular Slackware packages with the same name, the number of people who might know the answer will be much lower. Best hinted at in post title itself.

Anyway...

Does the file /etc/kde/xdg/autostart/kdeconnectd.desktop exist on your system? If so, it'd be the first file I'd try modifying (/sabotaging).

According to this page, a Hidden = true setting disables autostarting:
https://github.com/vasi/kdelibs/blob...ADME.autostart
Thank you.

None of the options listed in the link you provided solves the issue. Probably the reason why funtoo has kdeconnectd as a separate module tha user can install if needed or not.
 
Old 12-04-2017, 08:31 PM   #10
heyjann
Member
 
Registered: Dec 2015
Posts: 72

Rep: Reputation: Disabled
Then the plasma5 desktop might not have much of a dependency on it at all, maybe try a hammer and see if slackpkg remove kdeconnect breaks anything?

Alternatively, you might investigate if some config file somewhere in your /home dir might also be autostarting it. And/or really sabotage /etc/kde/xdg/autostart/kdeconnectd.desktop (it did exist, right? I'd expect that that is the file that makes it autostart), have it try to autostart "Exec=kde_not_connectd" so it'll fail.

I might do some testing myself later.
 
Old 12-04-2017, 10:00 PM   #11
Gordie
Member
 
Registered: Aug 2007
Distribution: Slackware, Puppy
Posts: 306

Rep: Reputation: 90
That little arrow next to the clock in the tray. Right button click and choose System Tray Settings. Look at Extra Items for KDE Connect

Last edited by Gordie; 12-04-2017 at 10:01 PM.
 
Old 12-05-2017, 08:50 AM   #12
Aeterna
Member
 
Registered: Aug 2017
Location: Terra Mater
Distribution: VM Host: Slackware-current, VM Guests: Artix, CRUX, FreeBSD, Funtoo, HardenedBSD, OpenIndiana
Posts: 86

Original Poster
Rep: Reputation: Disabled
thank you both for suggestions:

so editing /etc/kde/xdg/autostart/kdeconnectd.desktop did nothing

Quote:
That little arrow next to the clock in the tray. Right button click and choose System Tray Settings. Look at Extra Items for KDE Connect
No, unfortunately KDE Connect was unchecked.
Which makes sense because I believe that kdeconnectd.desktop file just refers to the KDE Connect applet that was inactivated anyway (I never used it for Android connection).

eventually I uninstalled kdeconnect and this solved problem with kdeconnectd obnoxiously listening to tcp/udp.

I do not see any adverse effects.

Last edited by Aeterna; 12-05-2017 at 08:52 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Why `systemctl disable wicd.service`can't disable wicd ? luofeiyu Linux - Newbie 5 08-24-2016 12:54 PM
Manjaro with Nvidia / Intel GPU: How to disable Bumblebee? How to disable vsync? altermetax Linux - Hardware 2 06-13-2016 05:25 AM
how to disable Text-to-speechmanager on startup, and disable fsck after 20 boots Kristian2 Slackware 2 02-25-2009 11:55 AM
dbx command for corrosponding commands disable or disable on gdb bshankha AIX 0 09-26-2006 10:38 AM
what are the services i can disable, also disable ads, banners in konqueror? greythorne SUSE / openSUSE 3 03-16-2005 09:30 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration