-   Slackware (
-   -   How to disable ipv6? (

ms-trex 03-31-2012 02:01 PM

How to disable ipv6?
all applications that need an Internet connection works very slowly, because of ipv6 I think. I disabled ipv6 in firefox and everything is ok now, but what about all others like wget, mail etc? How to permanently disable ipv6 in slackware 13.37, I tried blacklist ipv6 in /etc/modprobe.d/blacklist but it doesn't work. Help!

whizje 03-31-2012 02:32 PM

You can compile your kernel with your current .config without ipv6 support.

ms-trex 03-31-2012 02:37 PM

Is it not possible by any command or confing file?

camorri 03-31-2012 02:39 PM

I just blacklisted ipv6 in /etc/modprobe.d/blacklist.conf an I no longer have an IPv6 address in ifconfig eth0. I booted the machine, and it does not load.


cat /etc/modprobe.d/blacklist.conf | grep ipv6
blacklist ipv6

ms-trex 03-31-2012 02:40 PM

Well, I have not IPv6 address, with or without blacklist ipv6. But I disabled ipv6 in firefox, which works normlany now, I thought that ipv6 is the problem, so why wget establishing connection last very long, the same situation is when I want to send email with sylpheed.

whizje 03-31-2012 03:04 PM

You can use ipv6.disable=1 as kernel command line parameter.

wildwizard 03-31-2012 04:33 PM

Having ipv6 enabled should not alter the speed of anything on a machine with only ipv4 network connections.

Perhaps your network has some ipv6 functionality but no actual ipv6 connection to the outside world, this would cause the problems you're describing.

You can use whizje's kernel option to disable ipv6 fully on a single system and is the simplest method

NB ipv6 is designed for complete auto configuration, if a router on a network is configured for ipv6 then every computer on that network that is ipv6 enabled will have ipv6 settings given to them by that router.

talmacelm 12-13-2012 04:20 PM

disable ipv6 in slackware 14
Just a quick confirmation, passing ipv6.disable=1 as kernel command line parameter does the trick.

One can do this by editing /etc/lilo.conf and adding

after the

line at the end of the file.

Of course, the "lilo" command has to be run after editing the file, and reboot.

All times are GMT -5. The time now is 11:36 PM.