LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 12-18-2008, 03:30 PM   #16
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.2 (multilib)
Posts: 1,223

Rep: Reputation: 58

I tried to reproduce the automounting with /dev/sdc1 /mnt/flash11 auto user,exec,rw,noauto,umask=0 0 0
but it just worked as normal, asked if I wanted it mounted and then mounted to /mnt/flash11
 
Old 12-18-2008, 03:34 PM   #17
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: Slackware
Posts: 7,619

Rep: Reputation: 2948Reputation: 2948Reputation: 2948Reputation: 2948Reputation: 2948Reputation: 2948Reputation: 2948Reputation: 2948Reputation: 2948Reputation: 2948Reputation: 2948
The screenshot makes it clear: Alien Bob and arubin should be correct. The problem should disappear after you add yourself to the "plugdev" group.

Also, I believe fstab's "noauto" option just means the drives won't be mounted at bootup. I doubt it affects HAL, so arubin should be correct in that you can take those lines out. Automounting should work with USB drives even if they're not mentioned in the fstab. It does on my box, at least (12.1, Xfce, nothing in /etc/xdg/autostart).

If you're wondering why someone suggested a udev rule, it was for this:
Quote:
For each plugging of usb device, Slack choses different device name (sdb, sdb1, sdb2, sdc, sdc1, etc...).
A udev rule associates devices with devices names, so that, say, your Samsung U3 Titanium gets detected as /dev/U3 every time you plug it in. You should'nt need to worry about that if you're using KDE.

Last edited by dugan; 12-18-2008 at 03:49 PM.
 
Old 12-18-2008, 04:02 PM   #18
sertmusluman
Member
 
Registered: Jan 2006
Location: Canakkale, Turkiye
Distribution: Slackware 12.2
Posts: 53

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by dugan View Post
The screenshot makes it clear: Alien Bob and arubin should be correct. The problem should disappear after you add yourself to the "plugdev" group.

Also, I believe fstab's "noauto" option just means the drives won't be mounted at bootup. I doubt it affects HAL, so arubin should be correct in that you can take those lines out. Automounting should work with USB drives even if they're not mentioned in the fstab. It does on my box, at least (12.1, Xfce, nothing in /etc/xdg/autostart).

If you're wondering why someone suggested a udev rule, it was for this:

A udev rule associates devices with devices names, so that, say, your Samsung U3 Titanium gets detected as /dev/U3 every time you plug it in. You should'nt need to worry about that if you're using KDE.
Now it is clear for me, thank you very much everyone. I am going to search how to add an user to plugdev group.

Sorry for my poor English Dugan, i meant content list while saying index.
I have 7 flash drives (I know it is not normal ), but for my problem only one flash drive is enough.

Thanks for extra informing me Dugan, now i am going to try adding my user name to plugdev group. Is there a straightly forward way to do this?
 
Old 12-18-2008, 04:07 PM   #19
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: Slackware
Posts: 7,619

Rep: Reputation: 2948Reputation: 2948Reputation: 2948Reputation: 2948Reputation: 2948Reputation: 2948Reputation: 2948Reputation: 2948Reputation: 2948Reputation: 2948Reputation: 2948
Code:
gpasswd -a username plugdev
It takes effect the next time you log in as that user.

BTW, I deleted my criticism of your use of "open index" because I realized I was rude, but I think the term you wanted was "folder."

Last edited by dugan; 12-18-2008 at 04:11 PM.
 
Old 12-18-2008, 04:16 PM   #20
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,154
Blog Entries: 3

Rep: Reputation: 340Reputation: 340Reputation: 340Reputation: 340
if you got rid of all them hard links to sda /mnt/flash and had the original that was install with your OS. here is my fstab I have old IDE hard drives so they show up as hda instead of sda
your sda is like my hda after that it should look like this. if you want to auto mount the dev but befor it does a widow pops up asking.
/dev/hda3 swap swap defaults 0 0
/dev/hdb5 swap swap defaults 0 0
/dev/hdc2 swap swap defaults 0 0
/dev/hda1 / ext3 defaults 1 1
/dev/hda2 /mnt/hda2 ext3 defaults 1 2
/dev/hdb1 /mnt/hdb1 ext2 defaults 1 2
/dev/hdc1 /mnt/hdc1 ext3 defaults 1 2
#/dev/cdrom /mnt/cdrom auto noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0
tmpfs /dev/shm tmpfs defaults 0 0
OK
now make sure your user has plugdev in his permissions.
any time you have a hard link then it will mount the usb
you really ought to tell people your main goal instead of I need to do this. because things interact. and looking at your fstab you are trying to control a bunch of flash drives. and have them mount at a certain file location and only mount when you want.
If I need all those flash drives then I would label them with cfdisk before hand. then label them with a label. the kernel loads them first come first serve. closes to the bus.
why lable them because when you mount them they will have a name and you can see it.
when the pop up comes it say dev sda1 and it's name. then you need to remove safe or or umount them in a terminal. this will leave the slot open so you can remount it later in the sam slot. This is not gospel because I do not have that many flash drives to experiment with.
 
Old 12-18-2008, 04:17 PM   #21
sertmusluman
Member
 
Registered: Jan 2006
Location: Canakkale, Turkiye
Distribution: Slackware 12.2
Posts: 53

Original Poster
Rep: Reputation: 15
iam a good reader of english but speaking english a bit difficult for me
i added my username using your method.

Now i want to shutdown computer as user. I run Slack with default multiuser run level (id:3). For this run level KDE shut down button is not activated. Is there a way to activate it?

Last edited by sertmusluman; 12-18-2008 at 06:48 PM.
 
Old 12-18-2008, 04:22 PM   #22
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: Slackware
Posts: 7,619

Rep: Reputation: 2948Reputation: 2948Reputation: 2948Reputation: 2948Reputation: 2948Reputation: 2948Reputation: 2948Reputation: 2948Reputation: 2948Reputation: 2948Reputation: 2948
This is from CHANGES_AND_HINTS.TXT, which is on the installation DVD and all mirrors:
Quote:
User accounts with permission to mount removable devices must be in at least the plugdev group, and the power group is also recommended to allow shutdown and reboot via HAL methods.
 
Old 12-18-2008, 04:27 PM   #23
sertmusluman
Member
 
Registered: Jan 2006
Location: Canakkale, Turkiye
Distribution: Slackware 12.2
Posts: 53

Original Poster
Rep: Reputation: 15
Thanks. Slack 12.2 DVD is on my table, i am looking it now.
 
Old 12-18-2008, 04:34 PM   #24
sertmusluman
Member
 
Registered: Jan 2006
Location: Canakkale, Turkiye
Distribution: Slackware 12.2
Posts: 53

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Drakeo View Post
if you got rid of all them hard links to sda /mnt/flash and had the original that was install with your OS. here is my fstab I have old IDE hard drives so they show up as hda instead of sda
your sda is like my hda after that it should look like this. if you want to auto mount the dev but befor it does a widow pops up asking.
/dev/hda3 swap swap defaults 0 0
/dev/hdb5 swap swap defaults 0 0
/dev/hdc2 swap swap defaults 0 0
/dev/hda1 / ext3 defaults 1 1
/dev/hda2 /mnt/hda2 ext3 defaults 1 2
/dev/hdb1 /mnt/hdb1 ext2 defaults 1 2
/dev/hdc1 /mnt/hdc1 ext3 defaults 1 2
#/dev/cdrom /mnt/cdrom auto noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0
tmpfs /dev/shm tmpfs defaults 0 0
OK
now make sure your user has plugdev in his permissions.
any time you have a hard link then it will mount the usb
you really ought to tell people your main goal instead of I need to do this. because things interact. and looking at your fstab you are trying to control a bunch of flash drives. and have them mount at a certain file location and only mount when you want.
If I need all those flash drives then I would label them with cfdisk before hand. then label them with a label. the kernel loads them first come first serve. closes to the bus.
why lable them because when you mount them they will have a name and you can see it.
when the pop up comes it say dev sda1 and it's name. then you need to remove safe or or umount them in a terminal. this will leave the slot open so you can remount it later in the sam slot. This is not gospel because I do not have that many flash drives to experiment with.
Thanks dreko, i labelled them. Modifiying fstab file and adding my user name to plugdev i can mount flash drives with default fstab without entries I can see the label names on hard link now.
 
Old 12-18-2008, 05:14 PM   #25
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 544Reputation: 544Reputation: 544Reputation: 544Reputation: 544Reputation: 544
Perhaps the solution is simple:

Insert a USB stick and let the icon appear on the KDE desktop. Then select Properties from the icon pop-up menu. Select the Mounting tab. Disable the Mount automatically check box.

If that fails, then find ~/.kde/share/config/mediamanagerrc. Edit or delete the file. If you delete the file you then at least will restore all defaults and then the next time you insert a USB stick you should be able to set the response the way you want.
 
Old 12-18-2008, 06:04 PM   #26
sertmusluman
Member
 
Registered: Jan 2006
Location: Canakkale, Turkiye
Distribution: Slackware 12.2
Posts: 53

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Woodsman View Post
Perhaps the solution is simple:

Insert a USB stick and let the icon appear on the KDE desktop. Then select Properties from the icon pop-up menu. Select the Mounting tab. Disable the Mount automatically check box.

If that fails, then find ~/.kde/share/config/mediamanagerrc. Edit or delete the file. If you delete the file you then at least will restore all defaults and then the next time you insert a USB stick you should be able to set the response the way you want.
Thanks Woodsman, i solved another problem in the main problem. Now i can mount devices as user without a long fstab file , but my first problem still continuing Content of the USB flash drive mount directory suddnely appears in a new window without asking.

Mount automatically checkbox is unchecked as default. i was already disabled.

Now i will try your second instruction.

there is no ~/.kde/share/config/mediamanagerrc file. But there exists ~/.kde/share/config/ directory.

Last edited by sertmusluman; 12-18-2008 at 06:13 PM.
 
Old 12-18-2008, 06:19 PM   #27
sertmusluman
Member
 
Registered: Jan 2006
Location: Canakkale, Turkiye
Distribution: Slackware 12.2
Posts: 53

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Alien Bob View Post
From CHANGES_AND_HINTS.TXT :
Code:
HAL is not new anymore, but here are a few notes related to it:
  1. User accounts with permission to mount removable devices must be in at
     least the plugdev group, and the power group is also recommended to 
     allow shutdown and reboot via HAL methods.
Looking at the screenshot you posted I think you did not add your account to the "plugdev" group.

As to the involuntary automounting, I will have to install 12.2 with KDE3 on a computer tonight to see (I have KDE4 here).

Eric
Involuntary automounting still continuing...

My new fstab file:

Quote:
/dev/sda2 swap swap defaults 0 0
/dev/sda1 / ext3 defaults 1 1
/dev/sda5 /opt ext3 defaults 1 2
/dev/sda6 /home ext3 defaults 1 2
/dev/sda4 /xp ntfs-3g umask=000 1 0
/dev/sda7 /depo ntfs-3g auto,noatime,users,suid,dev,exec,locale=tr_TR.UTF-8 0 0
#/dev/cdrom /mnt/cdrom auto user,exec,ro,noauto 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0
tmpfs /dev/shm tmpfs defaults 0 0
 
Old 12-18-2008, 06:37 PM   #28
sertmusluman
Member
 
Registered: Jan 2006
Location: Canakkale, Turkiye
Distribution: Slackware 12.2
Posts: 53

Original Poster
Rep: Reputation: 15
I apllied Woodsman's second instruction. I thougt that he meant medianotifierrc file and deleted it.

Quote:
cd ~/.kde/share/config/
rm medianotifierrc
Now below pop up window appears before mount process.

http://www.freeimagehosting.net/uploads/ca26eb6e94.jpg

_____________________________________________________________________

Last edited by sertmusluman; 12-18-2008 at 06:45 PM.
 
Old 12-18-2008, 08:49 PM   #29
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 544Reputation: 544Reputation: 544Reputation: 544Reputation: 544Reputation: 544
Quote:
Content of the USB flash drive mount directory suddenly appears in a new window without asking.
This might remain simple. The next time KDE pops the window, select the Do Nothing option. Then select the Always do this for this type of media check box. Then select the OK button.
 
Old 12-19-2008, 03:11 AM   #30
sertmusluman
Member
 
Registered: Jan 2006
Location: Canakkale, Turkiye
Distribution: Slackware 12.2
Posts: 53

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Woodsman View Post
This might remain simple. The next time KDE pops the window, select the Do Nothing option. Then select the Always do this for this type of media check box. Then select the OK button.
In fact i want Slack 12.2 to show me this pop up window. Before deleting "~/.kde/share/config/medianotifierrc" file, i was not able to see this window. Now i am at the point where i want to reach.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Gnome: Auto mounting external devices as first user logged in, not current user yitzle Linux - Software 4 04-01-2008 10:43 AM
(auto)mounting devices in slackware w/ (or w/o) KDE crisostomo_enrico Slackware 1 08-05-2006 12:59 AM
how can i configure FreeBSD to auto mount USB devices? asilentmurmur *BSD 2 04-24-2006 02:24 PM
Disable Auto-mounting of devices in .... WINDOWS? opioid General 4 04-20-2006 02:35 PM
Auto mounting of USB devices leecming Linux - Newbie 6 08-05-2004 02:42 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 05:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration