-   Slackware (
-   -   how to define preferred applications on mate-desktop? (

gtludwig 04-19-2013 07:07 AM

how to define preferred applications on mate-desktop?
My mate-desktop install would be working great if not for a little detail that bugs me a bit. Whenever I try to open a link I received on a email or via skype, it starts Firefox. I've installed chromium and would like to define it as my default web browsing application.
I know I should be able to define it on System > Preferences > Preferred Applications, but the Internet pane options are grayed out.

eggshell 04-19-2013 09:58 AM

Sound to me like you could use a good application launcher. You should be able to find one be searching for "launcher" or install alacarte or desktop-edit-entry

willysr 04-19-2013 10:27 AM

Hm.. i don't have this problem
i could check the Internet pane options, but i don't have chromium, only Chrome
it seems it only affects people using Chromium

joncr 04-19-2013 04:49 PM

Grayed out here, too.

dugan 04-19-2013 05:30 PM

No problem here. Did you guys remember to remove the non-Mate entries from your "Startup Applications?"

joncr 04-19-2013 06:07 PM

The browser entry is active after I cleaned out all the Gnome entries in Startup Apps. (Have never been sure which, if any, of them MATE needs.) The Mail Reader entry remains grayed out.

Are the entries in ~/.config/autostart synonymous with the entries displayed in Startup Applications? I ask because, after deselecting and removing the Gnome apps from Startups, they still have entries in autostart.

gtludwig 04-22-2013 08:16 AM

Hi all,
Still no luck here. I've cleaned Startup Applications from all obvious gnome related entries, killed X and logged off and back in (I normally use runlevel 3), and still both select boxes for internet on Preferred Applications are grayed out.
I believe this might have something to do with my user's home folder being the same from when I was using KDE (AlienBob's build), then XFCE4 and now (after reinstalling Slackware64-current on a partition I assigned to / and used the same partition as my user's home folder).

willysr 04-22-2013 11:49 AM

I would test with a newly created user to find out
usually a polluted home directory can cause 'side effect' with MATE

joncr 04-22-2013 02:04 PM

No change here with a new user. "Browser" offers Chrome, but won't display other options (should show Firefox). "Mail Reader" is grayed out and inactive. If I click a mailto: link in Chrome, Firefox and the Thunderbird both open.

I'm on clean Slackware 14 with MATE 1.6, both installed less than a week ago. I've been through $HOME pretty thoroughly and don't see anything that might be confusing matters. No stray KDE or XFCE or GTK files, just the usual detritus that accumulates.

When a change is made via "Preferred Applications", what file is updated?

But, Willy, that's all I can find to fret about. Many thanks to you all for pulling MATE together for Slackware. It's pretty nice.

chess 04-22-2013 03:35 PM

I believe one file that impacts this is $HOME/.local/share/applications/mimeapps.list which is configured by xdg-open. Check out: I know that I've run into the issue once or twice before too, and a workaround was to manually edit that file and put in my list of preferred applications. Similar discussion in the Mint forums:

joncr 04-22-2013 05:49 PM

Thanks, Chess. I played with mimeapps.list earlier, adding mime type entries, etc., without seeing any change. Ditto when I temporarily removed it. (An empty file was created at the next login.) Also tried the ideas at the Arch wiki to no avail.

Googling around, it's evident that other folks have had this problem for some time. It's not a big deal for me, since I don't often click on mailto links. Chrome is functioning as the default browser, even if it says it can't figure out if it is or is not.

k3lt01 04-22-2013 06:02 PM

Do you mean this?

joncr 04-22-2013 06:07 PM


Originally Posted by k3lt01 (Post 4936793)
Do you mean this?


chess 04-22-2013 06:40 PM

If you add entries like the following then other applications should show up in the Preferred Applications menu:

[Added Associations]

joncr 04-22-2013 06:50 PM

That looks like the solution.

The difference: No semi-colons at the end of lines in my mimeapps.list after the install. After I add the semi-colons, Preferred Applications works as expected.


All times are GMT -5. The time now is 10:57 AM.