LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-09-2006, 11:38 AM   #1
irfanhab
Member
 
Registered: Jan 2004
Location: Pakistan
Distribution: OpenSuse 10.2, Slackware 11, Solaris 10
Posts: 415

Rep: Reputation: 34
how to change the refresh rate


Hi,

I just installed slackware 10.2, and by accident discovered "fluxbox". (I've been a kde user since ages).

I really love fluxbox's simple and minimal interface, however being simple does not mean feature less, I can access my fav kde applications from it. and I've replaced KDE with fluxbox as my window manager.

Now the problem is this:
how do I change the refresh rate in fluxbox, xorgconf doesnt even ask for the refresh rate, I want it to be 85hz, I think its currently 60-70hz.

Another issue:
I have set my xinitrc to point to xinitrc.kde however whenever I start my x server it loads fluxbox.
 
Old 05-09-2006, 11:47 AM   #2
b0uncer
LQ Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
I believe you can add to the xorg.conf, under the Monitor section, following:

HorizSync horizsync-range
VertRefresh vertrefresh-range

where you put the values specific to your own monitor at the red-marked places in the above example. Read the man-pages of xorg.conf for more information about in which ways you can do this, and about all the other options too:

Code:
man xorg.conf
One more thing. You probably can't "replace KDE with fluxbox as your window manager", since that would mean KDE is a window manager too; KDE is a desktop environment, which consists of a window manager, applications and other stuff you don't get in a plain window manager. Actually the only thing a window manager does is manage windows (robustly said); everything else, nice or eyecandy, is just something else. This actually has got very little to do with your post but hey, that just caught my eye

Have a nice day,

Juho

Last edited by b0uncer; 05-09-2006 at 11:48 AM.
 
Old 05-09-2006, 02:12 PM   #3
rje_NC
Member
 
Registered: Nov 2002
Location: Greensboro, NC
Posts: 182

Rep: Reputation: 30
xorg.conf is located in /etc/X11. Be sure to be the root user when you edit the file (i use pico). The file is very well commented.

While you are editing the file, it might be a good time to add support for the scroll mouse if you have one. The mouse section should have the following to enable the scrool mouse:

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/mouse"
Option "Buttons" "5"
Option "ZAxisMapping" "4 5"


Bob
 
Old 05-09-2006, 09:52 PM   #4
nutronix
Member
 
Registered: Jan 2003
Location: montreal
Distribution: Slackware and XUbuntu an Debian
Posts: 129
Blog Entries: 1

Rep: Reputation: 19
i usually save a copy of xorg.conf file in my /home dir first....in case i screw up ;-)
 
Old 05-10-2006, 01:42 PM   #5
MannyNix
Member
 
Registered: Dec 2005
Location: ~
Distribution: Slackware -current, OpenBSD
Posts: 453

Rep: Reputation: 44
Quote:
Originally Posted by nutronix
i usually save a copy of xorg.conf file in my /home dir first....in case i screw up ;-)
Hehe, i did that too, but now it just cp xorg.conf xorg.confWORKS (just next to the original, better located) i do the same with /etc/lilo.conf

Quote:
I have set my xinitrc to point to xinitrc.kde however whenever I start my x server it loads fluxbox
I think it will keep on doing it, i had to rename .xinitrc to NOxinitrc to start kdm or other window managers, from man fluxbox:
Code:
RUNNING FLUXBOX
       This  program  is  usually  started  by the user's startup script, most
       times called ~/.xinitrc.  To run fluxbox, modify the script by adding

            exec fluxbox
Maybe trying with pkgtool?
 
Old 05-10-2006, 04:19 PM   #6
dennisk
Member
 
Registered: May 2004
Location: Southwestern USA
Distribution: CentOS
Posts: 279

Rep: Reputation: 30
Try running xorgsetup. I've found that does a good job of setting up x. Let us know of it helps.

Dennisk
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
change refresh rate bucovaina78 Linux - Hardware 6 11-13-2004 05:32 PM
Change refresh rate mad_ady Feather 4 10-18-2004 04:09 PM
change refresh rate alaios Linux - Hardware 12 03-25-2004 12:09 PM
how to change refresh rate Andrew McKinlay Linux - Newbie 4 12-04-2003 10:12 AM
Refresh Rate --> How to change nickthegreek82 Linux - Hardware 1 05-28-2003 10:35 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 06:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration