-   Slackware (
-   -   How to change the locale by setting the system default locale (

letdoit 06-01-2004 07:36 PM

How to change the locale by setting the system default locale
the LANG is "en_US.UTF-8" which is set to default. As I typed $gedit at root, the error appear " Gtk-WARNING **: Locale not supported by C library. Using the fallback 'C' locale". I have to use comand $export LANG=C each time I work under terminal environment to avoid the error message above.

Do you have any solution?

ppuru 06-02-2004 01:15 AM

you can put it .bashrc in your home directory.

keefaz 06-02-2004 03:27 AM

For LANG env variable, you can set it by edit /etc/profile.d/ and lang.csh

bwzhou 11-13-2007 03:07 AM

You can change default locale in /etc/sysconfig/i18n

rg3 11-13-2007 01:21 PM


You can change default locale in /etc/sysconfig/i18n
This does not apply to Slackware.

forrie 08-17-2011 06:05 PM

I found this older post via a Google search. I have a RHEL 5.6 system which, for the most part, has never had any issues with locale. I'm now getting these types of errors from different code:


perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LC_ALL = "",
LC_CTYPE = "",
LC_TIME = "",
LANG = ""
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
It's driving me right up a wall.

I have checked the output of "locale -a" to make sure that /etc/sysconfig/i18n is correct (it is). Something got messed up, probably during a recently "yum update".

I'd really like to fix this, as I think it's going to screw some other processes up. After reading around, I'm still not sure about how to resolve the issue.

Any pointers would be appreciated.


rg3 08-18-2011 03:34 AM

You are in the Slackware forum. I'd suggest you ask this question in the proper forum to have better chances at solving the issue.

All times are GMT -5. The time now is 10:08 PM.