-   Slackware (
-   -   How I added a DVD-RW (

shilo 09-09-2004 09:11 PM

How I added a DVD-RW
I just added a DVD-RW to my system today. It was pretty easy. Just wanted to post a little info, in case anyone else has troubles.

First, a little info. I started out with one Hard drive and one optical drive (a generic dvd-rom). The hard drive is /dev/hda and the dvd-rom was /dev/hdc. I run the kernel, but I keep all of my old kerenls available in LILO, so I also have a 2.6.7 kernel and a 2.4.26 kernel. I run Slackware 10, upgraded to -current via SWareT (using only packages from the official mirrors), and I run Dropline. I also use udev and hotplug. Some of this really doesn't matter, but I wanted to make sure everyone knows what I started with.

Before I started, I checked out /dev. I saw /dev/hdc, /dev/dvd, and /dev/cdrom. Both /dev/dvd and /dev/cdrom were symlinks pointing to /dev/hdc.

On with the installation. I unplugged everything from the computer and opened her up. I also unpacked the dvd-rw. In case anyone is wondering, I got a LITE-ON 8x DVD+/-R/+/-RW. It also says it's DVD+R Double Layer. I would give the model, but I haven't found it anywhere on the box.

After reading the manual, I decided what to do. I unplugged the IDE cable, the analog audio cable, and the power cable from the old dvd-rom. I removed it from it's bay. I changed the jumper settings and made it slave. I changed the jumper settings on the new dvd-rw to master. I put the New dvd-rw into the top bay and screwd it in. I put the old dvd-rom in the next bay and screwed it in. I connected the power to each of the drives. I connected the last connector on my IDE cable to the new dvd-rw and the connector in the middle of my IDE cable to the old dvd-rom. I connected the audio cable from new dvd-rw to the first audio input on my motherboard (I have onboard sound) and I connected the audio cable from the old dvd-rom to the second audio input on my motherboard. All done with the hardware side of things, I closed the box back up and plugged everything back in.

Now we get to the more intersting stuff. I reboot, choosing the 2.6.7 kernel. I went with that because CD burning is broken in the kernel and the 2.4.26 kernel requires scsi emulation for CD burning. I note that my new dvd-rw is recognized during boot up as /dev/hdc and that my old dvd-rom is now /dev/hdd, which is to be expected with my master/slave settings. I check out my /dev directory and now have /dev/hdc, /dev/hdd, /dev/cdrom, and dev/dvd. /dev/cdrom and dev/dvd are symlinks to /dev/hdd. No problems there.

First thing I wnat to do is create a device called /dev/dvdrw, a symlink to /dev/hdc. Here's how I do that:

mv /etc/udev/rules.d/udev.rules /etc/udev/rules.d/50-udev.rules
vi /etc/udev/rules.d/10-local.rules

Now I'm sitting in vi. I just enter the following line.

BUS="ide", KERNEL="hdc", NAME="%k", SYMLINK="dvdrw"
I save and exit. Almost there. I make myself a new mount point.

mkdir /mnt/dvdrw
I already have a mount point /mnt/cdrom, so I'm all set there. Just gotta fix up /etc/fstab, and I should be home free. I edit it, and the important lines are now:

/dev/cdrom  /mnt/cdrom  iso9660  noauto,users,ro,nosuid        0 0
/dev/dvdrw  /mnt/dvdrw  iso9660  noauto,users,ro,nosuid        0 0

OK, that should take care of everything. For good measure, let's reboot. I reboot with the 2.6.7 kernel and start checking out my handy work. I head over to /dev and see /dev/hdc, /dev/hdd, /dev/cdrom, /dev/dvd, and /dev/dvdrw. /dev/cdrom and /dev/dvd are symlinks to /dev/hdd. /dev/dvdrw is a symlink to /dev/hdc. Perfect.

I decide to test out both optical drives with an audio cd. I put one in each drive and fire up gnome-cd. Right away, it picks up on the audio cd in the dvd-rom. That's what I expected, since the default setup for gnome-cd is to use device /dev/cdrom. Problem 1. I've got no sound. I open up gnome-volume-control and start looking things over. I had left the "Aux" line muted. I unmute that, and BOOM, I've got sound from my old dvd-rom. I change the device settings in gnome-cd to /dev/dvdrw. I had to restart gnome-cd. Didn't seem to like that change. Experimenting, I found that you can also hit the eject button in gnome cd after the chage to get the program to pick up on it. Anyways, the cd in /dev/dvdrw plays fine, as I had the volume set for the "CD" line all along. Looks like everything is peachy.

Now, to try burning something. I use k3b, which is on the Slackware installation CD under /extra. Even though I am in Gnome, it works great. I set up 76 minutes of music to burn, and 3:17 later, I've got a new CD that works perfectly.

I have a few issues which I am still ironing out. Let's go over those.

The first is permissions. Ihave noticed that with the current settings, /dev/hdc and /dev/dvdrw are set root:disk instead of root:cdrom. This is a small annoyance, as the users I have in the cdrom group are all in the disk group. Still would like to know how to change that. I'm thinking that all I need to do is change the line in /etc/udev/permissions.d/udev.permissions that looks like this:


Maybe using a naming trick like I did with udev.rules will also work. I'll try that out first and edit.

****** EDIT ******

I tried both methods. Neither worked. Any suggestions? Thanks.


The second is just a small annoyance, maybe specific to Gnome. When I open up "Computer", I see "CD-ROM" and "dvdrw". I wonder how cdrom got changed to "CD-ROM" while dvdrw didn't get changed to "DVD-RW"? Any ideas?

Well, I hope this khelps someone. Good luck,

asheron 09-09-2004 09:42 PM

I have add this to my /etc/rc.d/rc.modules to get my dvd-r borner working with latest kernel(2.6.X)

/sbin/modprobe ide-cd dev=/dev/hdc


shilo 09-09-2004 09:54 PM


If you use 2.6.7, you don't. is broken. You shouldn't need to do that on future 2.6.x kernels, either. That was kinda one of the points of the post. I wanted to let people know that scsi-emulation is not needed in the 2.6.x kernel. Just in unpatched kernels. If you are moving on to 2.6, why set it up for scsi emulation now, just to have to disable it in the future? Either use 2.6.7 or patch

asheron 09-09-2004 10:09 PM

Im using kernel 2.6.7 form current/testing and if i dont load the modules, DVD-R burning does not for me.

shilo 09-09-2004 10:33 PM

That's strange. I compiled my own 2.6.7 and burning works great. What's your /etc/lilo.conf look like? Did you enable scsi emulation for your burner there? If so, you can drop it, along with the rc.modules line. It should work fine.

All times are GMT -5. The time now is 08:48 AM.