-   Slackware (
-   -   how good is slackwares auto detection?? (

bosewicht 11-24-2003 02:55 PM

how good is slackwares auto detection??
i have been debating on installing slackware for a while, but before i do, how well does slackware find things like video and sound cards?? must these be manually configured or does the install do a pretty good job at finding them??

Tinkster 11-24-2003 03:03 PM

If the soundcard is known to the kernel the
module may (or may not) be loaded. Slack
leaves MOST configuration work to the user,
just look at it as a work-out for the tired grey
matter ;)

It sets up X to work with the framebuffer
device, there's NO detection of graphics
cards whatsoever, and the number of
network modules that netconfig will try
to discover is rather limited, too.

Best regards,

Tino27 11-24-2003 03:09 PM

Compared to SuSE 8.2, Slack 9.1 managed to configure my video and audio devices okay (meaning, they worked, but not optimally). I ended up monitoring my /var/log/syslog file to look for module loading errors. Found a few and managed to resolve the issues.

What surprised me the most was my wireless 802.11b card. The biggest issue I had in setting up SuSE 8.2 was my Linksys PCMCIA WPC11 card. Lots of searching the Internet and manual configuration was needed for that under SuSE. In Slack 9.1, it just worked like a charm right out of the box.

sadiqdm 11-24-2003 04:32 PM

I agree with tino27. I found that the auto config gave me w working X, when I let it do its stuff. I did several installs to get the hang of it (9.1 from a set of download files in a separate partition) and tried to set the XF86config manually, most of the time it didn't work 8-(. Then let it do the auto thing, and it setup some generics ("nv" for the nVidia Riva TNT2 Pro64 & the correct one for the Iiyama S700JT) which worked fine but ried to make my monitor go at 1800x1500 ore somthing. After deciding on KDE, I found it has a good peripherals tool and used that to select another version of the nVidia driver and reset the display to 1024x786 and all is now well.

For some reason it insists that my Kensington Orbit is USB even though it is plugged into the PS/2 connector with an adapter. However it works fine so I've let it be.

I like KDE and have now had nearly a week with no problems. Yesterday I had to boot into Win98 to check some webpage updates with IE and it fell over after about 30 mins!

All times are GMT -5. The time now is 08:31 AM.