LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-12-2013, 11:48 PM   #1
buradd
Member
 
Registered: Mar 2012
Location: California
Distribution: Slackware64-current
Posts: 73

Rep: Reputation: Disabled
how do you downgrade x11/xserver/xorg


I'm looking to take a fresh install of slackware64-14.0 and downgrade the x11 to 7.6, can anyone help me with that?
 
Old 01-13-2013, 01:31 AM   #2
elvis4526
Member
 
Registered: Aug 2011
Posts: 111

Rep: Reputation: Disabled
Can we know why you want to do such a thing?
 
Old 01-13-2013, 10:59 AM   #3
buradd
Member
 
Registered: Mar 2012
Location: California
Distribution: Slackware64-current
Posts: 73

Original Poster
Rep: Reputation: Disabled
I believe it will fix tf2 in steam for Linux... Thank you for the meaningless reply.
 
Old 01-13-2013, 11:02 AM   #4
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,366
Blog Entries: 2

Rep: Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981
TF2 runs fine on Slackware 14, at least for me and several others. Which video hardware do you use and which drivers do you have installed?
 
Old 01-13-2013, 12:01 PM   #5
buradd
Member
 
Registered: Mar 2012
Location: California
Distribution: Slackware64-current
Posts: 73

Original Poster
Rep: Reputation: Disabled
Radeon HD 6320, and another box tried with radeon HD 6970.. Tried and prop drivers 12.8 up to 12.11beta11
 
Old 01-13-2013, 12:24 PM   #6
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,184

Rep: Reputation: Disabled
Radeon are crap, but TF2 should work with Slackware 14. I run Steam and TF2 on Slackware 14, but with a Nvidia card.

Eric
 
Old 01-13-2013, 12:36 PM   #7
buradd
Member
 
Registered: Mar 2012
Location: California
Distribution: Slackware64-current
Posts: 73

Original Poster
Rep: Reputation: Disabled
It plays for me on Ubuntu 12.04 with amd prop 12.8, but gives that glcolor error on slack
 
Old 01-13-2013, 12:41 PM   #8
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,366
Blog Entries: 2

Rep: Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981
Running TF2 on Slackware 14 64 bit with Catalyst 12.11 Beta11 (HD6870) without any problems.
I would assume that graphics drivers are not your problem. What exactly is the problem when you try to run TF2?
 
Old 01-13-2013, 12:45 PM   #9
buradd
Member
 
Registered: Mar 2012
Location: California
Distribution: Slackware64-current
Posts: 73

Original Poster
Rep: Reputation: Disabled
https://github.com/ValveSoftware/ste...nux/issues/248

It is explained here

Nvidia has the same problem with old drivers apparently
 
Old 01-13-2013, 12:51 PM   #10
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,366
Blog Entries: 2

Rep: Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981
May it be possible that you run a 64 bit version of Slackware but don't have re-installed the driver after going multilib?
 
Old 01-13-2013, 12:52 PM   #11
beder
Member
 
Registered: Apr 2011
Posts: 82

Rep: Reputation: 28
buradd, you're not getting anywhere with that silly attitude towards people trying to help you
 
Old 01-13-2013, 01:11 PM   #12
buradd
Member
 
Registered: Mar 2012
Location: California
Distribution: Slackware64-current
Posts: 73

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by beder View Post
buradd, you're not getting anywhere with that silly attitude towards people trying to help you
You're not helping anyone. Why post?
 
Old 01-13-2013, 01:13 PM   #13
buradd
Member
 
Registered: Mar 2012
Location: California
Distribution: Slackware64-current
Posts: 73

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by TobiSGD View Post
May it be possible that you run a 64 bit version of Slackware but don't have re-installed the driver after going multilib?
I always install multilib before compile prop drivers, all before even using xwin
 
Old 01-13-2013, 03:55 PM   #14
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,184

Rep: Reputation: Disabled
Quote:
Originally Posted by buradd View Post
You're not helping anyone. Why post?
You sir, have to check your attitude. It took you five posts to give us an actual report of your error message. People try to help here, and it costs you nothing except giving relevant information.

Good luck with it.

Eric
 
Old 01-13-2013, 04:27 PM   #15
buradd
Member
 
Registered: Mar 2012
Location: California
Distribution: Slackware64-current
Posts: 73

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Alien Bob View Post
You sir, have to check your attitude. It took you five posts to give us an actual report of your error message. People try to help here, and it costs you nothing except giving relevant information.

Good luck with it.

Eric
sorry you feel that way, eric.

the topic of this post was a question on how to downgrade the xserver to 7.6

the first reply was questioning why, rather than instructing how or otherwise helping.

you can see how it stayed off topic from there... nobody has given any help on the actual topic of how to downgrade x11, which should be trivial to one of you by now I'm sure, instead I get combative posts... sorry for my attitude, get thicker skin.

thank you.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kubuntu 9.04: Is there a way to downgrade XServer to 1.5.x? beli0135 Linux - Desktop 3 06-17-2009 11:08 AM
xserver lost configuration, dpkg-reconfigure xserver-xorg isn't helping bezdomny Linux - Software 5 07-13-2008 12:33 PM
xorg-x11-devel dependant on old version of xorg-x11-libs thetawaverider Linux - Software 1 11-09-2006 07:22 AM
xserver-xorg config warning: migrating xserver-xfree86 templates doctorwebbox Debian 9 07-27-2005 07:24 PM
xorg-x11-libs required by xorg-x11-devel darknails Fedora 1 01-13-2005 02:34 PM


All times are GMT -5. The time now is 09:07 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration