LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-14-2011, 05:35 AM   #1
Konphine
Member
 
Registered: Jul 2011
Location: Phoenix, New York
Distribution: Slackware 13.37
Posts: 376

Rep: Reputation: 11
How Do I Use Scim?


Hi again,

I originally made this post in Linux-General, but only one person was really answering the question and now he hasn't been responding, so I've come here since Scim is also Slackware related.

Simply put, I need to be able to use Scim to input the Korean language. If anybody knows how, that would be great.

Here's the original thread:
http://www.linuxquestions.org/questi...e-scim-891208/
 
Old 07-14-2011, 06:42 AM   #2
kite
Member
 
Registered: Aug 2003
Location: Shenzhen, China
Distribution: Slackware
Posts: 303

Rep: Reputation: 47
My experience (Chinese):

1. I edited /etc/profile.d/lang.sh. I just changed the default locale en_US to zh_CN.UTF8 (reboot is required). Not sure for Korean.
2. I chmod +x /etc/profile.d/scim.sh (reboot is required).
3. I added scim to the autostart (re-login is required).
4. I use shortcut CTRL+SPACE to activate scim.

P.S.: I have switched to fcitx input method, which is actively developed. I am not sure whether it is available for Korean though.
 
1 members found this post helpful.
Old 07-14-2011, 07:21 AM   #3
Konphine
Member
 
Registered: Jul 2011
Location: Phoenix, New York
Distribution: Slackware 13.37
Posts: 376

Original Poster
Rep: Reputation: 11
Do you know where I can find an Index list of the different languages so I can put in the Korean one?
 
Old 07-14-2011, 07:56 AM   #4
onebuck
Moderator
 
Registered: Jan 2005
Location: Summer Midwest USA, Central Illinois, Winter Central Florida
Distribution: SlackwareŽ
Posts: 13,576
Blog Entries: 34

Rep: Reputation: 2768Reputation: 2768Reputation: 2768Reputation: 2768Reputation: 2768Reputation: 2768Reputation: 2768Reputation: 2768Reputation: 2768Reputation: 2768Reputation: 2768
Hi,

Quote:
Originally Posted by Bruce Hill View Post
It has nothing to do with the Korean language. The software you use is
not always written without bugs. It also has dependencies on other software
that is also not written without bugs. These software packages need updates
for security, and they also need to have patches when other software they
depend on are changed. In the last release of Slackware SCIM would segfault
and needed some patches. That time I supplied them:
Code:
ftp://mirrors.kernel.org/slackware/slackware64-13.37/ChangeLog.txt
x/scim-1.4.9-x86_64-5.txz:  Rebuilt.
  Address stability issues with Firefox and other applications.
  Thanks to Bruce Hill for the patches.
x/scim-bridge-0.4.16-x86_64-5.txz:  Rebuilt.
  Address stability issues with Firefox and other applications.
  Thanks to Bruce Hill for the patches.
In the future I will not, and don't use SCIM anymore. Perhaps Slackware will
change to iBus in the future; unless someone wants to maintain SCIM, which
no longer has any maintainer.

Just follow the directions in the link given before. If you still have problems,
then post back what you did and what your specific error message is then.
Bruce Hill gave you solid advice concerning 'SCIM'. Your thread: How Do I Use Scim? in 'Linux-General' is now closed. I see no reason to keep it open. You might get lucky here in the Slackware forum. I think that you should have posted here originally.
 
Old 07-14-2011, 08:41 AM   #5
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Arch, Gentoo
Posts: 6,939

Rep: Reputation: 129Reputation: 129
We don't use Slackware on anything but servers now, and none of them
have X, or SCIM, installed. I will install Slackware64-13.37 on something
and try this out for you.

What do you use for the Korean locale?
 
Old 07-14-2011, 10:42 AM   #6
Konphine
Member
 
Registered: Jul 2011
Location: Phoenix, New York
Distribution: Slackware 13.37
Posts: 376

Original Poster
Rep: Reputation: 11
onebuck:
Quote:
Bruce Hill gave you solid advice concerning 'SCIM'. Your thread: How Do I Use Scim? in 'Linux-General' is now closed. I see no reason to keep it open. You might get lucky here in the Slackware forum. I think that you should have posted here originally.
True, and I reported what Mr. Hill wanted but got no response after that even with a bump which is why I came here. I asked there originally because I saw that Scim was available for a few other distros, so I was hoping for a larger range of people who might be able to help.

Bruce Hill:
Quote:
We don't use Slackware on anything but servers now, and none of them
have X, or SCIM, installed. I will install Slackware64-13.37 on something
and try this out for you.

What do you use for the Korean locale?
You don't have to do that. I'm using Slackware because I'm going through this point where I want to try out a new Linux distro. I'm going to be in College and wanted to try out something new and heard that 13.37 came out recently.

What do you mean what do I use?
 
Old 07-14-2011, 06:03 PM   #7
Konphine
Member
 
Registered: Jul 2011
Location: Phoenix, New York
Distribution: Slackware 13.37
Posts: 376

Original Poster
Rep: Reputation: 11
Bump for Help.
 
Old 07-14-2011, 06:24 PM   #8
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 4,168

Rep: Reputation: 1395Reputation: 1395Reputation: 1395Reputation: 1395Reputation: 1395Reputation: 1395Reputation: 1395Reputation: 1395Reputation: 1395Reputation: 1395
I think Korean are supported (Hanja and Hangul)
you just need to enable them on SCIM Setup > IMEngine > Global Setup
 
Old 07-14-2011, 07:04 PM   #9
Konphine
Member
 
Registered: Jul 2011
Location: Phoenix, New York
Distribution: Slackware 13.37
Posts: 376

Original Poster
Rep: Reputation: 11
I have Korean enabled on there, but I just don't know how to start typing it. It won't work even after Ctrl + Space, and if I need to do what the last thread says, then I need to find the language thing that kite and Bruce Hill are talking about.

Right now it's set to en_US, I need to find the Korean one.
 
Old 07-14-2011, 07:12 PM   #10
Mike_M
Member
 
Registered: Mar 2011
Location: California
Distribution: Slackware
Posts: 116

Rep: Reputation: 53
A list of locales can be found in /usr/share/locale. Each directory is a different locale. My guess is ko_KR is Korean.
 
1 members found this post helpful.
Old 07-14-2011, 07:33 PM   #11
Konphine
Member
 
Registered: Jul 2011
Location: Phoenix, New York
Distribution: Slackware 13.37
Posts: 376

Original Poster
Rep: Reputation: 11
According to the folder, it's just "ko"
 
Old 07-14-2011, 07:44 PM   #12
Konphine
Member
 
Registered: Jul 2011
Location: Phoenix, New York
Distribution: Slackware 13.37
Posts: 376

Original Poster
Rep: Reputation: 11
Okay, it works now! However, the only problem I'm running into is that I've set certain applications to also show up in Korean, which isn't really a problem but I would prefer them to be in English.

Right now, on this desktop I have Dolphin, Firefox, Trash Can and Terminal but Terminal is in Korean, everything else is fine.

I did as kite said to up to step 2 (since I won't always be using Korean). Is there a way to change this?
 
Old 07-14-2011, 09:21 PM   #13
Konphine
Member
 
Registered: Jul 2011
Location: Phoenix, New York
Distribution: Slackware 13.37
Posts: 376

Original Poster
Rep: Reputation: 11
Bump for last bit of help. ^^
 
0 members found this post helpful.
Old 07-14-2011, 10:03 PM   #14
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Arch, Gentoo
Posts: 6,939

Rep: Reputation: 129Reputation: 129
In /etc/profile.d/lang.sh you should have:
Code:
export LANG=en_US.UTF-8
How did you "set Terminal to show up in Korean"?
 
1 members found this post helpful.
Old 07-14-2011, 10:11 PM   #15
Konphine
Member
 
Registered: Jul 2011
Location: Phoenix, New York
Distribution: Slackware 13.37
Posts: 376

Original Poster
Rep: Reputation: 11
Hmm, well what I did was I set:

Quote:
export LANG=ko
Which is what caused it, but I reverted it, and it seems to be working correctly now. Thanks again. ^^
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How Do I Use Scim? Konphine Linux - General 9 07-14-2011 07:59 AM
scim as standard im compul Debian 3 12-24-2009 03:30 AM
SCIM font - got SCIM working, now all flash has japanese font.....help! sandaili Linux - Software 6 03-24-2009 07:27 AM
[help] scim - gnome pcandpc Debian 1 07-03-2007 07:29 PM
Firefox 1.5 and SCIM? Erik_the_Red Linux - Software 1 01-19-2006 06:42 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 02:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration