LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-12-2015, 05:51 PM   #1
alanware
Member
 
Registered: Aug 2011
Location: Midwest-USA
Distribution: Slackware
Posts: 85

Rep: Reputation: Disabled
How do I use a USB headset with Alsa?


I recently bought a usb headset. The system detects the device and I can select it from programs like vlc. Other programs like flash-player and system sounds, other programs that don't have a selection option cannot play sound to the device. Is there a way to have the sound go to both current default source and my headset?

Thanks
 
Old 05-12-2015, 07:23 PM   #2
genss
Member
 
Registered: Nov 2013
Posts: 740

Rep: Reputation: Disabled
not sure, maybe
http://www.6by9.net/output-to-multip...ces-with-alsa/
this uses dmix so it should work fine, except maybe flash

ttable is the main part, format is
ttable.input.output volume
http://alsa.opensrc.org/Asoundrc

wish i could help you more

Last edited by genss; 05-12-2015 at 07:27 PM. Reason: I-O swap
 
1 members found this post helpful.
Old 05-12-2015, 10:25 PM   #3
mralk3
Senior Member
 
Registered: May 2015
Distribution: Slackware, OpenBSD
Posts: 1,463

Rep: Reputation: Disabled
How do I use a USB headset with Alsa?

* What distribution of Linux?
* What is the name/specs of your headset?
* Post the results of the 'lsusb -v' command.
* Post the results of the 'aplay --list-devices' command.

Without this information no one has any idea what to tell you to do to help.

Last edited by mralk3; 05-12-2015 at 10:30 PM.
 
Old 05-13-2015, 02:00 AM   #4
franzen
Member
 
Registered: Nov 2012
Distribution: slackware
Posts: 313

Rep: Reputation: 184Reputation: 184
Maybe this helps:
http://schoepfer.info/howto.xhtml#toc3
 
Old 05-13-2015, 02:44 AM   #5
fsLeg
Member
 
Registered: Dec 2013
Location: Russia, Moscow
Distribution: Slackware, Debian
Posts: 88

Rep: Reputation: Disabled
Problems like this have overly complicated solutions in Slackware. People here may throw rocks at me, but I'd suggest installing PulseAudio with pavucontrol, it really helps laymen to deal with multiple sound cards, especially detachable USB ones. I know it helped me with my USB microphone, something I didn't expect when decided to play with PA.

What else I can think of is setting your headset as the default playback device using asoundrc. The problem here is that your headset probably isn't always attached to your PC, so the sound may be broken when it isn't. Some udev rule that would call a script which replaces /etc/asound.conf with the correct version would help with that.
 
Old 05-13-2015, 07:24 AM   #6
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 7,395

Rep: Reputation: 5085Reputation: 5085Reputation: 5085Reputation: 5085Reputation: 5085Reputation: 5085Reputation: 5085Reputation: 5085Reputation: 5085Reputation: 5085Reputation: 5085
Quote:
Originally Posted by mralk3 View Post
* What distribution of Linux?
Well, considering this is the Slackware forum and he has Slackware listed as his distribution, I'm thinking it's a strong possibility that OP's running Slackware

Back to the topic... I am not sure how to get both to run simultaneously, but I do know you will need to make sure both have a consistent device number assigning by alsa. You can find more about this in the link franzen posted. This will make sure that the device IDs with alsa stay the same whether or not you have the USB headset plugged in when booting.

Are you looking to actually have audio outputted to both the headset and the laptop at the same time or just change from the laptop speakers to the headset when the headset is plugged in?
 
Old 05-13-2015, 06:00 PM   #7
alanware
Member
 
Registered: Aug 2011
Location: Midwest-USA
Distribution: Slackware
Posts: 85

Original Poster
Rep: Reputation: Disabled
Hey, thanks for all the great replies to my question. To clarify, I am running Slackware64-current from a March 2015 time frame. I am going through the links genss linked. They seem to be exactly what I was looking for. I will post again once I have tried to implement the .asoundrc file with my devices in it.
 
Old 05-13-2015, 06:49 PM   #8
mralk3
Senior Member
 
Registered: May 2015
Distribution: Slackware, OpenBSD
Posts: 1,463

Rep: Reputation: Disabled
Quote:
Originally Posted by bassmadrigal View Post
Quote:
Originally Posted by mralk3 View Post
* What distribution of Linux?
Well, considering this is the Slackware forum and he has Slackware listed as his distribution, I'm thinking it's a strong possibility that OP's running Slackware
Ah my bad, I was logged in from the LQ android app and the app doesn't display the forum sub section a post is in. Actually, it doesn't display much except the post title, author and replies. Haha.
 
1 members found this post helpful.
Old 05-14-2015, 11:57 AM   #9
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 9,832

Rep: Reputation: 4421Reputation: 4421Reputation: 4421Reputation: 4421Reputation: 4421Reputation: 4421Reputation: 4421Reputation: 4421Reputation: 4421Reputation: 4421Reputation: 4421
I've never used a USB headset, but I assume it's seen as a USB sound card. In that case, don't use an asoundrc. Use the slots module parameter. The official documentation is here:

http://alsa.opensrc.org/MultipleCard...s.3D.22_method

If you need me to be more specific (which file to edit, etc), then I can check when I get home tonight.

And yes, this is probably a case where Pulseaudio is the better option.
 
Old 05-14-2015, 12:26 PM   #10
Bertman123
Member
 
Registered: Jun 2010
Distribution: Slackware 14.1 64 bit MLED with XFCE 4.12
Posts: 331

Rep: Reputation: 69
I use pulseaudio as I've found it much easier switching between my usb headset and the default sound card on my laptop.
 
Old 05-14-2015, 08:17 PM   #11
alanware
Member
 
Registered: Aug 2011
Location: Midwest-USA
Distribution: Slackware
Posts: 85

Original Poster
Rep: Reputation: Disabled
Posting some results of aplay and lsusb as requested.

Logitech h390
lsusb -v
aplay --list-devices
Code:
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC892 Digital [ALC892 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 3: Headset [Logitech USB Headset], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
 
Old 05-14-2015, 10:14 PM   #12
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 9,832

Rep: Reputation: 4421Reputation: 4421Reputation: 4421Reputation: 4421Reputation: 4421Reputation: 4421Reputation: 4421Reputation: 4421Reputation: 4421Reputation: 4421Reputation: 4421
If you want to use your headset permanently, create the following file:

/etc/modprobe.d/alsa.conf

Code:
options snd slots=snd-usb-audio,snd-hda-intel
 
Old 05-21-2015, 12:38 PM   #13
alanware
Member
 
Registered: Aug 2011
Location: Midwest-USA
Distribution: Slackware
Posts: 85

Original Poster
Rep: Reputation: Disabled
Thank you all for your responses in an effort to resolve my sound configuration. I followed genss suggestion using plugins to send audio to both sound outputs at the same time. Although, I could not get his linked config to work. I did, however, find a similar article online that I was able to modify.

slack4dummies alsa: multiple output, multiple sound cards, multiple users

Everything seems to work great. I don't have the microphone working in also right now.
 
Old 05-21-2015, 08:00 PM   #14
ReaperX7
LQ Guru
 
Registered: Jul 2011
Location: California
Distribution: Slackware64-Current
Posts: 6,450
Blog Entries: 15

Rep: Reputation: 2030Reputation: 2030Reputation: 2030Reputation: 2030Reputation: 2030Reputation: 2030Reputation: 2030Reputation: 2030Reputation: 2030Reputation: 2030Reputation: 2030
The mic should be controlled by alsamixer. See if it might need to be unmuted.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
USB headset, Alsa and Pidgin TheStarLion Debian 1 12-17-2012 11:24 PM
Bluetooth headset, Alsa - no soundcard in /proc/asound/cards (but headset works) simopal6 Linux - Hardware 1 04-29-2009 09:07 AM
USB Headset and Alsa opiea Linux - Software 1 10-06-2007 08:35 PM
USB Logitech Headset and Alsa. HOW ? Dark Carnival Linux - Hardware 0 05-19-2004 08:43 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration