-   Slackware (
-   -   How do I boot existing Slackware installation with CD1? (

ridingthestorm 09-28-2008 02:52 AM

How do I boot existing Slackware installation with CD1?

I'm quite new to Slackware. This is a fresh install, and I did not want to install LILO because I have other systems already, and GRUB seems more convenient. This time I ran into problems with my existing GRUB because it didn't detect correctly Slackware's ext3. So I wanted to install Slackware's own GRUB but I can't find a way to boot it -- a very basic question: what parameters should I pass to my CD1 at boot: prompt to boot into the existing installation? I searched several manuals, readme files, googled, and could not find. Could someone, please, help?

samac 09-28-2008 03:55 AM

Put CD1 into your computer, boot, read the on screen display and input your values. Once your computer has booted install grub.


ridingthestorm 09-28-2008 05:40 AM

This way the CD only boots into its own environment. According to the screen instructions (or additional instructions through F2), there are only 2 parameters I can pass: kernel (such as hugesmp.s) and root partition, but those didn't change anything for me. I also tried several times to install grub while in chrooted environment but then it just installed the package without installing the actual bootloader into MBR.

bgeddy 09-28-2008 06:24 AM

Well step by step would be as follows :-

Boot cd1 as per instructions for root= etc.

Mount cd containing the grub package - I think it's in extra but I have a DVD image so I can't say which CD it's on.

As root run installpkg /mount/point/of/CD/grub*.tgz to install grub - obviously replacing the silly directory with your mount point.

As root run grubconfig to configure grub and install to MBR if wished - there's a README file in the /extra/grub directory telling you about this.

Reboot and go.

I've just ran these steps on a VM to check and it works fine for me.

ridingthestorm 09-28-2008 08:35 AM

Many thanks for thinking with me and even checking. As soon as I'm back home, I'll try.

ridingthestorm 09-29-2008 02:07 AM

Thank you once more! Tried it, and it works fine.

All times are GMT -5. The time now is 09:40 AM.