LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 07-08-2013, 01:29 PM   #1
WhiteHotLoveTiger
Member
 
Registered: Jun 2012
Location: NB, Canada
Distribution: Slackware
Posts: 66

Rep: Reputation: 1
Unhappy How can I stop Fluxbox from turning off the display?


I'm running Slackware14 with fluxbox on an old PC. I'm using it to display a constantly updating website in a shop window.
Unfortunately, fluxbox keeps turning the display off. I thought I'd fixed it when I put xset s off in ~/.fluxbox/startup
When it kept blanking, I did a little more reading on the xset man page, and ran xset -dpms
I thought that this would stop the screen from going blank for certain! But, as you can probably guess, I'm still having a problem with it.

What other settings should I be looking at?
 
Old 07-08-2013, 03:05 PM   #2
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware-14.0 on a Lenovo T61 6457-4XG
Posts: 3,638

Rep: Reputation: 827Reputation: 827Reputation: 827Reputation: 827Reputation: 827Reputation: 827Reputation: 827
Probably OT as you are under X, but that could help others: there is a kernel parameter to set the console blank (screen saver) timeout in seconds, which is:
Code:
consoleblank=
The default value is 600 (10mins), a value of 0 disables the blank timer.
 
Old 07-08-2013, 03:09 PM   #3
wadsworth
Member
 
Registered: Aug 2007
Distribution: Slackware64 13.37
Posts: 213

Rep: Reputation: 63
I change a line in /etc/rc.d/rc.M to look so:
Code:
# Screen blanks after 15 minutes idle time, and powers down in one hour            
# if the kernel supports APM or ACPI power management:                             
/bin/setterm -blank 0 -powersave off -powerdown 0
Also I have the following in /etc/X11/xorg.conf.d/no_blank.conf
Code:
Section "ServerFlags"
     Option     "BlankTime" "0"
     Option     "StandbyTime" "0"
     Option     "OffTime" "0"
     Option     "SuspendTime" "0"
EndSection
 
Old 07-08-2013, 03:22 PM   #4
WhiteHotLoveTiger
Member
 
Registered: Jun 2012
Location: NB, Canada
Distribution: Slackware
Posts: 66

Original Poster
Rep: Reputation: 1
This is strange, but the screen is back on now.
I didn't witness the blanking myself, so maybe there was something else going on, I'm not sure. A friend at the shop emailed me to tell me it wasn't working. I started researching other options, and finally resigned myself to scripting an infinite loop to jiggle the mouse every 30 seconds. Once I had the script ready I headed down to the site where the machine is, only to find out that it was mysteriously back on.
This computer has neither a mouse nor keyboard attached.

I'm at a loss to explain it, but hopefully I won't need to use the mouse jiggle script...
 
Old 07-08-2013, 07:15 PM   #5
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, Mint
Posts: 6,880

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
I don't think Fluxbox is capable of turning off your display. It's not a desktop environment, just a window manager. All it does is manage application windows.

There is likely a power management setting somewhere that is doing this. If you have a full-fledged desktop environment, such as Gnome or KDE, installed, log into that and check your power management settings. They may still be in effect even if you are using Fluxbox for your UI.

Also, check your screensaver settings; they may include some power management stuff. I know that xscreensavers has some elementary display power management settings under the "Advanced" tab.

Last edited by frankbell; 07-08-2013 at 07:16 PM. Reason: Proofreading.
 
Old 07-09-2013, 02:50 PM   #6
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,183

Rep: Reputation: 284Reputation: 284Reputation: 284
I also use fluxbox and I use xset -dpms with no problems.

Do make sure that xscreensaver isn't running as that will also turn off the screen.
 
  


Reply

Tags
fluxbox, kiosk


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Frozen/unusable secondary display after turning it back on. kslen Linux - Hardware 6 09-15-2011 02:26 AM
Why is my Gnome display turning off, even with acpi, pwr mgmgt gone? wsanders Linux - Desktop 2 04-30-2010 01:46 PM
Computer turning on, no bios, no display, no beeps.. woms14 Linux - Hardware 2 01-17-2009 06:11 PM
fluxbox - distorted display jrtayloriv Linux - Newbie 0 02-11-2005 09:30 PM
fluxbox / aterm display issue dasein Linux - Software 6 02-07-2005 10:58 PM


All times are GMT -5. The time now is 02:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration