-   Slackware (
-   -   How can I install a slackware-current kernel to slackware 11? (

bijit1709 06-05-2007 01:07 PM

How can I install a slackware-current kernel to slackware 11?
I am trying to install a precompiles kernel from slackware-current(generic.s, gensmp.s, huge.s, hugesmp.s) but I don't know how or if its possible. Please someone help me with this ..

Thanks in advance.

Alien Bob 06-05-2007 01:38 PM

It's not possible.


bijit1709 06-05-2007 01:58 PM

Thanks for letting me know Eric. Do you know where I can get a very good how-to for kernel compilation? Or how can I can properly install Kernel-generic-smp-

rworkman 06-05-2007 02:12 PM

Get the config file here for the kernel:
(go up a directory for the other kernels if you'd prefer one of the others)
Copy that config file to ".config" in your extracted kernel source directory and build/install the kernel and modules normally.
Note that the same guidelines about making an initrd will apply if you use one of the generic configs.

sparc86 06-05-2007 02:46 PM


Originally Posted by bijit1709
Thanks for letting me know Eric. Do you know where I can get a very good how-to for kernel compilation? Or how can I can properly install Kernel-generic-smp-

Check out this guide.

Always select your boot settings stuff (scsi, ide, sata, etc...) as built-in. Therefore you do not need to use the initrd.

By the way, if you have time, I strongly suggest you to use the generic .config as a base and then just take off all the stuff you don't need.
This will make your kernel smaller. Smaller kernels are better/faster kernels.

davimint 06-05-2007 10:24 PM

Eric & Robby

I found this post after I wrote this one.

I respect you both and wish you would expand on your answer "Eric" as to why it is not possible in either this post or mine. The reason for my question is the "Changes & Hints text" that is found on the installation instructions for current. Me being a novice at linux-Slackware I've learned to pay close attention to details and it say to "INSTALL a 2.6.18 or LATER KERNEL" so the very good kernel does not meet that standard. The Kernel-huge-smp- actually worked for me although it may have been a fluke or parody of some sorts. I may not have the experience or knowledge to understand the answer you may provide but would like to try. Again, you both are great and I appreciate you taking the time to help us all with your answers.

Thanks David

rworkman 06-05-2007 11:11 PM

Eric can probably expand on this more than me, but...

Technically, it is *possible* to use the kernel packages from -current on 11.0, which you already know based on your "attention to detail" :-) If it were not possible to boot a -current kernel on an 11.0 system, those upgrade instructions wouldn't be very good, now would they? :-)

It is *strongly* *STRONGLY* discouraged (which is the reason for Eric's answer) to use any packages from -current on an 11.0 system. There are some which can/will work just fine (binary repackagings such as firefox, thunderbird, and java come to mind), but generally speaking, someone who already knows which ones will work doesn't have to ask about installing -current packages on -stable releases. :-) Back to the kernel though -- the biggest issue I can think of at the moment as to *why* the -current kernel should not be used on an 11.0 system is gcc. The -current kernel was compiled with gcc-4.1.2, but 11.0 has gcc-3.4.6. As soon as you decide to build an out-of-kernel module (fuse, nvidia or ati drivers, etcetera), you'll find out that it won't work, as the kenrel module has to be built with the same version of gcc that built the kernel itself. At this point, many users would decide that the proper course of action is to upgrade gcc, and the situation escalates from there.

To make a long story short, it gets very tiresome trying to help users who've gone down this road, so the easiest answer to give is "no, it's not possible."

Note that this is *my* answer - I don't claim to speak for Eric, nor do I make any guarantees that he will agree with me on every point. :-)

davimint 06-05-2007 11:49 PM

Thank you for taking the time to help me understand and I appreciate the points you made. Now,I better understand the course of action that should be taken and the options that are available.

bijit1709 06-08-2007 04:43 PM

May be someone can help with this...

The error for the 2.6.# is that the vga doesn't work. In order to see the booting process i have to give vga=normal. But I still have problems When give command:

# startx
I have tried xorgconfig but I still have errors I have tried also xorgsetup. Does anyone know why this happens? Its gives some error and says it doesn't support my screen depth. Any screen depth I put. And when I do:

# shutdown -r 0
it says rebooting . and it doesn't do anything after and it doesn't reboot. Do you think its the same problem with the vga?

Nylex 06-10-2007 02:12 AM

Edit: post the errors from X. Also, you shouldn't really start X as root, use your regular user account.

Drone4four 06-11-2007 01:39 AM

this post is similar to my thread here:

rworkman 06-13-2007 03:24 PM

A bit more information about kernel package incompatibility with -current on 11.0 (it's a post on alt.os.linux.slackware usenet group):

All times are GMT -5. The time now is 12:05 AM.