LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 08-13-2017, 12:21 PM   #1
dimm0k
Member
 
Registered: May 2008
Location: Brooklyn ZOO
Distribution: Slackware64 14.2
Posts: 492

Rep: Reputation: 49
Hotkeys for SCIM not activating/switching


Currently using Slackware64 14.2 and recently found out about SCIM to allow me to input Japanese more easily and that works great except I can't switch back to English or vice versa easily. If I'm understanding everything properly in SCIM, I should be able to switch between inputs with the "CTRL-ALT-down/up" hotkeys, but doing that does nothing. "CTRL-space" should also activate SCIM, but that doesn't seem to do anything either. I have both scim.sh and scim.csh +x in /etc/profile.d and SCIM does get loaded on start in X, as I definitely see it in my XFCE tray and am able to switch inputs using the mouse. any suggestions on easing my life with hotkeys?
 
Old 08-13-2017, 07:42 PM   #2
TommyC7
Member
 
Registered: Mar 2012
Distribution: Slackware, CentOS, OpenBSD, FreeBSD
Posts: 462

Rep: Reputation: Disabled
dimm0k,

May we see the options you've set in your "Global Setup" part under the "FrontEnd" section?

I'd also like to see the contents of your /etc/scim.sh as well if possible.
 
Old 08-14-2017, 07:07 AM   #3
dimm0k
Member
 
Registered: May 2008
Location: Brooklyn ZOO
Distribution: Slackware64 14.2
Posts: 492

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by TommyC7 View Post
dimm0k,

May we see the options you've set in your "Global Setup" part under the "FrontEnd" section?

I'd also like to see the contents of your /etc/scim.sh as well if possible.
attached is a screenshot of the requested section, which is pretty much the defaults. I did try to add my own hotkey, but when it didn't work I removed it. below is my /etc/profile.d/scim.sh, which is also defaults

Code:
#!/bin/sh

# SCIM (Smart Common Input Method platform).  This is used to support the
# entering of text in non-US-English languages.

# For SCIM to work, you need to use a UTF-8 locale.  Make sure it ends on
# ".UTF-8", not "utf-8"!  As an example, you would need to use en_US.UTF-8
# for a US locale (export LANG=en_US.UTF-8), not en_US.
#
# The locale (LANG variable) is set in /etc/profile.d/lang.sh.

if [ -x /usr/bin/scim ]; then
  # Enable legacy X applications to use scim:
  export XMODIFIERS="@im=SCIM"
  # Let GTK applications like Firefox/Thunderbird use scim as
  # default immodule:
  export GTK_IM_MODULE="scim"
  # Enable Qt/KDE applications to use scim:
  export QT_IM_MODULE="scim"
  # Make scim start automatically if the "magic key" Ctrl-Space is pressed:
  export XIM_PROGRAM="/usr/bin/scim -d"
fi

# This ensures scim starts when you logon.
# This will only work if you login through runlevel 4 (graphical login)!!!
# Better is to have it start through Ctrl-Space like configured higher up ^^.
#if [ ! `ls /tmp/scim-socket*` ]; then
#  /usr/bin/scim -d
#fi
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2017-08-14_08-02-08.png
Views:	5
Size:	70.8 KB
ID:	25703  
 
Old 08-15-2017, 09:32 AM   #4
gegechris99
Member
 
Registered: Oct 2005
Location: France
Distribution: Slackware 14.2 64bit
Posts: 900
Blog Entries: 4

Rep: Reputation: 132Reputation: 132
Quote:
Originally Posted by dimm0k View Post
I have both scim.sh and scim.csh +x in /etc/profile.d and SCIM does get loaded on start in X, as I definitely see it in my XFCE tray and am able to switch inputs using the mouse. any suggestions on easing my life with hotkeys?
To have SCIM works correctly, you need to follow steps as described in CHANGES_AND_HINTS.TXT
Quote:
Input methods for complex characters (CJK, which is shorthand for Chinese,
Japanese, Korean) and other non-latin character sets have been added. These
input methods use the SCIM (Smart Common Input Method) platform.
The environment variables for SCIM support are set in /etc/profile.d/scim.sh
The requirements for getting SCIM input methods to work in your X session
are as follows:
(1) Use a UTF-8 locale. Look in /etc/profile.d/lang.sh for setting your
language to (for instance) en_US.UTF-8. As a word of warning: maybe you
should leave root with a non-UTF-8 locale because you don't want root's
commands to be misinterpreted. You can add the following line to your
~/.profile file to enable UTF-8 just for yourself:
export LANG=en_US.UTF-8
(2) Make the scim profile scripts executable. These will setup your
environment correctly for the use of scim with X applications. Run:
chmod +x /etc/profile.d/scim.*
(3) Start the scim daemon as soon as your X session starts. The scim daemon
must be active before any of your X applications. In KDE, you can add a
shell script to the ~/.kde/Autostart folder that runs the command
"scim -d". In XFCE you can add "scim -d" to the Autostarted Applications.
If you boot your computer in runlevel 4 (the graphical XDM/KDM login)
you can simply add the line "scim -d" to your ~/.xprofile file.
This gives you a Desktop Environment independent way of starting scim.
When scim is running, you will see a small keyboard icon in your system tray.
Right-click it to enter SCIM Setup. In 'Global Setup' select your keyboard
layout, and you are ready to start entering just about any language
characters you wish! Press the magical key combo <Control><Space>
in order to activate or deactivate SCIM input. The SCIM taskbar in the
desktop's corner allows you to select a language. As you type, SCIM will show
an overview of applicable character glyphs (if you are inputting complex
characters like Japanese).
Please check the following:

- step (1): which UTF-8 locale are you using?
- step (3): even though you see the icon in the XFCE system tray, there is no guarantee that SCIM is started at the right moment. I would advise that you explicitly launch SCIM when X starts. I personally like the ~/.xprofile option.
Code:
$echo "/usr/bin/scim -d" >> ~/.xprofile
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 14.2 SCIM input issue: cannot imput alpha letters(half-width) using scim, no fast searching for XFCE FileManager kcynice Slackware 0 07-21-2016 03:45 AM
scim foreign language can't type space when switching type mode 7/24/2015 babbab Slackware 16 07-05-2016 04:23 AM
[SOLVED] Hotkeys in gnumeric. Creating gnumeric/system hotkeys Alex McGregor Linux - Newbie 1 08-30-2014 12:20 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 05:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration