-   Slackware (
-   -   hostname confusion (

wufo 09-10-2013 11:00 AM

hostname confusion
I am confused over how linux stored and uses its hostname. I run the command
~ $ hostname

But, when I use cups on a remote system to access a printer, it fails with
a can't establish connection with At one tine the system might have been named loki, but was changed.

Why does cups still report loki as the hostname instead of misty to the remote system?


YellowApple 09-10-2013 11:12 AM

What's the content of /etc/hosts?

wufo 09-10-2013 11:17 AM

Discovered the problem in the server's /etc/hosts and discovered your suggestion to look there when I came back to post the problem solved. Still, thanks for the reply.


YellowApple 09-10-2013 12:27 PM

No problem, and good to see you got it figured out. I had just stumbled through some issues with Apache and an OpenVZ-ified Slackware server's /etc/hosts, which is why it came to mind (damn OpenVZ-based VPS providers...).

All times are GMT -5. The time now is 07:12 PM.