-   Slackware (
-   -   horizontal mouse wheel scrolling config in Slack 11 [evdev driver instead of mouse] (

arcanex 12-11-2007 01:35 PM

horizontal mouse wheel scrolling config in Slack 11 [evdev driver instead of mouse]
I'm trying to get the horizontal scrolling feature of the Apple Might Mouse
working in Slackware 11. Everything else works as far as I care (using
the "mouse" driver) except for the horizontal scrolling.

The issue seems to be that the "mouse" Xorg driver doesn't really support
the horizontal scrolling, so I'm trying to use the "evdev" driver instead.
But I'm having trouble just recognizing the mouse using the "evdev" driver.

Here's the relevant section of xorg.conf that I'm trying to add
(just trying to get the mouse working at all, not even worrying about
the extra mouse wheel or buttons):


Section "InputDevice"
        Identifier  "Mouse1"
        Driver      "evdev"
        Option      "Name" "Primax Electronics Apple Optical USB Mouse"

Has anyone had success in this area? I've searched the forums and most of
them pertain only to the "mouse" driver.

I can confirm that 'evdev' is compiled into the kernel and that is the
identifying string for the mouse. What I am not sure of is whether the
evdev Xorg driver that comes with Slackware 11 is working...

H_TeXMeX_H 12-11-2007 02:12 PM

So, you got the name from 'cat /proc/bus/usb/devices', right ? If not, then look through there and find it.

Have you tried this guide for evdev:

arcanex 12-11-2007 02:24 PM

I actually got the device name from '/proc/bus/input/devices', but I also
tried the strings there at '/proc/bus/usb/devices'.

Any way I enter the device name string in xorg.conf, I get the same
"Device not found" error, as if it's disregarding the "Name" option entirely
and is still looking for a "Device" option.

And yes, I've seen that Gentoo wiki page. That's where I'm basing my
procedures off of, actually.

H_TeXMeX_H 12-11-2007 02:34 PM

Ok then, it seems the only way is to put in the "Device" option. Have you tried doing that, the info is available there in 'cat /proc/bus/usb/devices'. Something like:

Option      "Device" "/dev/input/event0"

arcanex 12-11-2007 02:59 PM

That did it! It was '/dev/input/event2' all along.

I tried '/dev/mouse', '/dev/input/mice', '/dev/input/mouse0' before, but those
didn't work. Looking back now, it's obvious those weren't using evdev.

So here's the relevant section of my xorg.conf now, for further reference:


Section "InputDevice"
    Identifier "Mouse1"
    Driver "evdev"
    Option "Device" "/dev/input/event2"
    Option "ZAxisMapping" "4 5 6 7"

Thanks for the help.

EDIT: Just to mention it for those who happen to have this problem as well:
the "squeeze" button, which used to map to button 8 with the "mouse" driver,
now doesn't get recognized by "evdev" at all.

H_TeXMeX_H 12-11-2007 04:10 PM

Also, one more thing you should know: udev or something else may decide to change the event2 to event0 or event1, etc. which will cause xorg not to start (this is what happened for me). Now, I'm not exactly sure how to fix this. I'm not even sure udev causes it. I'm wondering if anyone knows a solution to this.

The only solution I came up with is to make a script that detect which event is used for the mouse and modifies xorg.conf before xorg starts up to account for this. It's probably not the best way, but I haven't found another way. Maybe editing udev rules will help ?

simcox1 12-12-2007 02:27 AM

Do you still need a .Xmodmap to map the buttons?

H_TeXMeX_H 12-12-2007 03:37 AM


Originally Posted by simcox1 (Post 2988009)
Do you still need a .Xmodmap to map the buttons?

If they don't all work or some are reversed, you may. If they work, you don't.

simcox1 12-12-2007 07:18 AM

evdev works with the correct "Device" setting in xorg.conf, but I still need to use a .Xmodmap. At the moment horizontal scrolling doesn't work. So in fact it's no different.

All times are GMT -5. The time now is 04:44 AM.