-   Slackware (
-   -   homebank crashing on current / kde 4.4 (

zvzi 02-23-2010 08:25 AM

homebank crashing on current / kde 4.4

is anyone using homebank? i'm having it crash with a segmentation fault error everytime i open an .xhb file since either updating to current or kde 4.4. i can't recall exactly when the crash started to happen but i am sure it is after either one of the updates. any ideas on why this happening? thanks in advance.

Hangaber 02-24-2010 01:19 PM

HomeBank v4.2.1
KDE: v4.3.4

I haven't been using HomeBank long, but so far no export/import or save/load problems.

Have you tried creating a new/blank xhb, with a few sample accounts and entries, and see if you can save and load that one ok?

Jack128 02-26-2010 04:46 PM

I try to use homebank 4.2.1 with libofx-0.9.1 on KDE 4.3.4, too.
Same behavior with this build, like zvzi reported.

Save/Load won't work, Export/Import either.
Is there something we do wrong or is there a workaround.

Best Regards,


zvzi 02-26-2010 07:08 PM

creating new xhb files and saving/opening works fine. i suspected it had to do with my xhb file being corrupt but then i downloaded the example xhb file from the website and opening it segfaulted again. i have tried installing homebank on the the other machine in my house running ubuntu and saving/opening them works completely fine. hmm maybe i'll try installing the same version as installed on the ubuntu machine and see how it goes..

kde 4.4
slackware-current (multilib)

Jack128 02-27-2010 04:20 AM

Witch version you are running on the ubuntu-box?
I can't open the example_file.xhb, either.

Edit/Ps: I reported the bug.

Best Regards,


All times are GMT -5. The time now is 08:17 PM.