-   Slackware (
-   -   home users directories is gone (

BlinkingSpirit 09-29-2012 07:35 PM

home users directories is gone
I have the following situation. had a partition of 275Gb and tried to install a new OS. what I did was back up. With cfdisk, split this partition into two, one with 240GB and the other with the rest. I could not install another OS, I returned to join the two partitions. and restored the backup. And I used the chown command to directories of users. thereafter installed LibreOffice. when rebooted the pc saw home directory clean. when I use the command df it shows only 240GB instead 275. the properties of / home shows 275Gb. where's my data? Is there any to recover my data?

ps. this text is written with help of google translator, i hope it is understandable.


pingu 09-30-2012 01:19 PM

Just barely understandable I'm afraid.
(Well, English isn't my native language either so maybe that's why...)
We need to make sure we understand each other correctly, so let's be extremely detailed.

Let's see:
You had
/home 275 GB (which partition?)
You split
/home 240 GB
/<for new distro> 35 GB
You "undid"
You put the 2 previously splitted partitions together, giving you again
/home 275 GB

After that I'm kinda lost.
* Was the original /home filled with data? How much?
* You restored the backup, why do you say you've lost your data?
* Why chown? You had a backup, it should have kept the uid's?
* Rebooted pc and saw /home clean - what do you mean by that? Was your 240/275GB partition mounted, did it contain the user directories it should?
* How did you check the "properties"?

Start with giving the following:
1) What distro/distros are you using
2) How are your disks partitioned (in terminal as root or using sudo, post output of "fdisk -l")
3) Post output of "df -hT"
4) Post output of "cat /etc/fstab"

All I can think of for now.
Now I just hope Google translator can translate my post good enough for you to understand me... ;-)

BlinkingSpirit 09-30-2012 08:48 PM

this is steps i made.
1 - /home is one partition with 275Gb
2 - make backup (only 16Gb), and moved a backup to external drive
3 - split with cfdisk into 2 partitions, one with 240 and other with 35
4 - tried install windows xp, didn't have success with it
5 - reboot
6 - undid it, by merging it
7 - mkfs.reiserfs
8 - moved the backup /home and chown the folders to users, and installed libreoffice
9 - reboot
10 - when i log on, i'm notified with message telling me that doesn't find home path
11- check /home, and see nothing, the directory is clean
12- df -h, the output is 240Gb free
13- in Thunar, /home properties i see 275Gb free

here was the problem:
in step 5 in the reboot, /etc/fstab didn't find the /home partitions because a deleted, so he "mounted" /home in root partitions.
in step 6 and 7, i restored the partition, but didn't mount it (cause of the problem)
in step 8 when i restored the backup, the data was in /home directory in root partitions.
in step 9 after another reboot, the /etc/fstab verify that the partitions exist and mounted in /home, that is why didn't find my data.
i saved my data after this, but i still don't understand the step 12 and 13.

All times are GMT -5. The time now is 07:26 PM.