LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Slackware (http://www.linuxquestions.org/questions/forumdisplay.php?f=14)
-   -   Home and End keys in RXVT (http://www.linuxquestions.org/questions/showthread.php?t=267011)

kevmccor 12-16-2004 08:24 AM

Home and End keys in RXVT
 
When using RXVT the "Home" and "End" keys result in a "~" instead of moving the cursor. They work properly in xterm, xemacs, and other programs. I have a pc105 en_us Mitsumi (very standard) keyboard, using Slackware 10.0. Any help would be appreciated.

Thanks,
Kevin

AntEater 12-16-2004 02:32 PM

re: Home and End keys in RXVT
 
While it may not solve your problem, as a work around the emacs keybindings "C-e" for end of line and "C-a" for beginning of line should work. What is $TERM set to in your shell environment? I've never seen this problem with rxvt in Slackware but you might want to check your /etc/termcap settings to see if something has been changed.

ror 12-16-2004 03:06 PM

I had this problem when moving from bash to zsh, I managed to fix it but have forgotten right now :\

kevmccor 12-16-2004 04:51 PM

I tried "C-e" for end of line and "C-a" for beginning and it works. The $TERM variable gives "xterm." I looked at /etc/termcap, but I have no idea what is going on there.

I checked file:///usr/doc/rxvt-2.7.10/doc/rxvtRef.html#KeyCodes and it says that:

Home ESC [ 7 ~ ESC [ 7 $ ESC [ 7 ^ ESC [ 7 @
End ESC [ 8 ~ ESC [ 8 $ ESC [ 8 ^ ESC [ 8 @

whatever that means. I can get the characters "~ $ ^ @" by pressing Shift, Ctl, Alt and the Home and Delete keys, as apparently indicated in the KeyCodes table.

Here is my ~/.Xdefaults for RXVT:

! rxvt
rxvt.geometry: 100x24
rxvt.background: black
rxvt.foreground: white
rxvt.savelines: 128
!rxvt.font: smoothansi fkp glisp
rxvt.font: smoothansi
rxvt.scrollBar: True

And here is my start-up command in my xfce menu:

rxvt -bg black -fg AntiqueWhite -sl 128


All times are GMT -5. The time now is 06:57 AM.