LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 08-21-2019, 08:50 AM   #1
lioh
Member
 
Registered: Aug 2019
Location: Switzerland
Distribution: Slackware
Posts: 41

Rep: Reputation: Disabled
High pulseaudio load on -current with ktown


Hi all,

I am on -current with ktown and experience very high pulseaudio CPU load from time to time:

Click image for larger version

Name:	pa.png
Views:	43
Size:	46.3 KB
ID:	31174

I was wondering if it might have something to do with Plasmas system notification sounds but I have disabled them completely and the problem still exists.

Does anyone of you also experience this issue or knows how to debug this further?

Greetings
Lioh
 
Old 08-21-2019, 11:24 AM   #2
drgibbon
Member
 
Registered: Nov 2014
Distribution: Slackware64 14.2
Posts: 497

Rep: Reputation: 324Reputation: 324Reputation: 324Reputation: 324
I've seen that fairly recently on my laptop running -current without KDE (awesomewm instead). No idea why though, I had to kill pulseaudio and I only noticed in the first place because my fan was going crazy.
 
Old 08-21-2019, 11:28 AM   #3
lioh
Member
 
Registered: Aug 2019
Location: Switzerland
Distribution: Slackware
Posts: 41

Original Poster
Rep: Reputation: Disabled
I have not seen this with Xfce yet.
 
Old 08-21-2019, 11:43 AM   #4
tramtrist
Member
 
Registered: Jul 2018
Location: Cincinnati USA
Distribution: Slackware
Posts: 104

Rep: Reputation: 55
I run i3wm and can produce it at will.
Steps:
Startx to i3wm
Run something requiring sound
Exiting i3wm
Startx to i3wm

On the 2nd start of X pulseaudio is almost always running at 100% CPU
At which case I kill the process (audio still works) and move on

I thought it was just me...
 
Old 08-21-2019, 11:52 AM   #5
Jan K.
Member
 
Registered: Apr 2019
Location: Esbjerg
Distribution: slackware...
Posts: 54

Rep: Reputation: 24
Another big difference I've noticed between the MS Windows and Linux world is, that bug reports are highly welcomed in the Linux world, whereas Microsoft goes straight into a denial phase...

So why not report this apparently clear bug to developers?

...

Oh... wait...
 
2 members found this post helpful.
Old 08-21-2019, 11:56 AM   #6
tramtrist
Member
 
Registered: Jul 2018
Location: Cincinnati USA
Distribution: Slackware
Posts: 104

Rep: Reputation: 55
I run i3 which isn't supported officially by Slackware but I understand and agree I probably should have brought it up.
 
Old 08-28-2019, 08:40 AM   #7
lioh
Member
 
Registered: Aug 2019
Location: Switzerland
Distribution: Slackware
Posts: 41

Original Poster
Rep: Reputation: Disabled
I have noticed that the runlevel script was not activated. After chmod +x /etc/rc.d/rc.pulseaudio && /etc/rc.d/rc.pulseaudio start the situation has improved. I have not seen the high load till then anymore.
 
Old 09-05-2019, 04:42 AM   #8
rogan
Member
 
Registered: Aug 2004
Distribution: Slackware
Posts: 135

Rep: Reputation: 40
The recommended way is to not use the rc scripts for pulse.
Something is wrong with pulse though, I sometimes use xfce and
everytime I shut it down (I use startx) I hear the computer fans
ramping up. The culprit is always a pulse process left using 100%cpu
up to maybe 30 seconds after.
There may be a fix but I don't care anymore.
 
Old 09-05-2019, 04:48 AM   #9
lioh
Member
 
Registered: Aug 2019
Location: Switzerland
Distribution: Slackware
Posts: 41

Original Poster
Rep: Reputation: Disabled
For me using the rc script solved the issue. Do you have any references not to use it?
 
Old 09-05-2019, 04:55 AM   #10
rogan
Member
 
Registered: Aug 2004
Distribution: Slackware
Posts: 135

Rep: Reputation: 40
less /etc/rc.d/rc.pulseaudio :
#!/bin/sh
#
# Start/stop/restart PulseAudio in system mode.
# In this mode, a single system instance of PulseAudio will be shared by
# multiple local users.
#
# Please note: this is not generally the best way to use PulseAudio!
# Normally pulseaudio will start automatically as-needed with an instance
# per audio user. Unless you really need to use system mode you should leave
# this script non-executable.
#
# For more information, see:
# http://www.freedesktop.org/wiki/Soft...ser/SystemWide
 
1 members found this post helpful.
Old 09-07-2019, 08:53 PM   #11
tramtrist
Member
 
Registered: Jul 2018
Location: Cincinnati USA
Distribution: Slackware
Posts: 104

Rep: Reputation: 55
Setting "/etc/pulse/client.conf" to "autospawn = no" fixed this for me.
I'm using rc.pulseaudio in rc.d as well
 
1 members found this post helpful.
Old 09-12-2019, 01:06 AM   #12
lioh
Member
 
Registered: Aug 2019
Location: Switzerland
Distribution: Slackware
Posts: 41

Original Poster
Rep: Reputation: Disabled
Thanks for sharing this. I am not really sure if autospawn = no is necessary because from my experience if the system-wide service is running the user session just connect to it instead of spawning a new session.
 
Old 09-12-2019, 05:15 PM   #13
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib" & Xfce.
Posts: 4,866
Blog Entries: 1

Rep: Reputation: 2268Reputation: 2268Reputation: 2268Reputation: 2268Reputation: 2268Reputation: 2268Reputation: 2268Reputation: 2268Reputation: 2268Reputation: 2268Reputation: 2268
Experienced this while running Xfce-4.14 yesterday. I killed pulseaudio and went back to Xfce-4.12. That solved that problem... so to speak.
 
Old 09-15-2019, 12:14 PM   #14
lioh
Member
 
Registered: Aug 2019
Location: Switzerland
Distribution: Slackware
Posts: 41

Original Poster
Rep: Reputation: Disabled
pulseaudio has been upgraded in -current. Let's see if it improves the situation somehow. Even though I have never seen this issue again after enabling the system service, I am now going to try again with the service disabled.
 
Old 09-15-2019, 12:28 PM   #15
tramtrist
Member
 
Registered: Jul 2018
Location: Cincinnati USA
Distribution: Slackware
Posts: 104

Rep: Reputation: 55
Confirmed on my side.
Disabled rc.pulseaudio via chmod -x
Starting it on i3wm with 'pulseaudio -D' in the i3 config
Logged out after starting a youtube video
No 100%CPU at the moment
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Today's -current icu4c upgrade broke ktown's sddm dugan Slackware 37 07-28-2019 01:39 PM
Preferred combination of stable/current and ktown? dugan Slackware 18 12-28-2016 03:20 AM
[SOLVED] Current and ktown 5 causing Gimp problems coralfang Slackware 21 09-16-2016 05:43 AM
[SOLVED] libreoffice not working on latest ktown on sw64-current; how to roll back to 4.10.5? michaelslack Slackware 3 12-05-2014 05:06 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 12:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration