LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-21-2020, 10:32 PM   #1
TheNutCase
Member
 
Registered: May 2016
Location: Columbia, South Carolina14
Distribution: Slackware 14.2
Posts: 334

Rep: Reputation: Disabled
Help turning of power saver mode for my printer.


I am using Slackware 14.2 (64-bit) as my operating system, and I have an HP Deskjet 1512 All-in-one printer, and my question it this: Is there a way for me to disable the printer's power saver mode, and if so, how do I go about it?
 
Old 06-22-2020, 12:14 AM   #2
karlmag
Member
 
Registered: Apr 2014
Distribution: Slackware
Posts: 46

Rep: Reputation: Disabled
Quote:
Originally Posted by TheNutCase View Post
I am using Slackware 14.2 (64-bit) as my operating system, and I have an HP Deskjet 1512 All-in-one printer, and my question it this: Is there a way for me to disable the printer's power saver mode, and if so, how do I go about it?

Hi,

My first question was "why?", my second thought was "maybe the manual says?"

I presume you meant programatically from a Linux machine (specifically slackware).

A quick search lead me to this;
https://h30434.www3.hp.com/t5/Printe...e/td-p/1746661

If that is the case, it looks like HP messed up somehow on some series of printers.

Given the somewhat sparsely detailed question this will be my best guess at an answer.
Also - I don't have your particular type of printer, nor any similar ones, with all the possible caveats that might have.

... or maybe what you are asking is something quite different :-)

Thanks
--
KarlMag
 
Old 06-22-2020, 11:11 AM   #3
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 7,151

Rep: Reputation: 4820Reputation: 4820Reputation: 4820Reputation: 4820Reputation: 4820Reputation: 4820Reputation: 4820Reputation: 4820Reputation: 4820Reputation: 4820Reputation: 4820
On my work HP LaserJet Pro, the power saving functions are done with the internal firmware, not the driver with the computer. The only way I found to not have my printer power off overnight was to either leave my computer at work turned on or hook up a phone line to the fax port on the machine. I am required by work to have my work computer at home, so leaving it in the office wasn't an option. Luckily, we don't really use landline phones, so I simply hooked my phone line into the printer and it stays on 24/7 (it will go into low powered standby mode when the fax is plugged in, otherwise it would completely power off after a max of 8 hours).

Coincidentally, HP released a firmware update that would have the LaserJet power off after a certain period of time, even when the fax line was plugged in (which meant I couldn't receive faxes). I'm hoping the power off when plugged into a fax line was abug and not intentional, because it is very hard to receive faxes after hours when the machine turns itself off after a predetermined amount of time. I very quickly reverted that firmware update.
 
Old 06-22-2020, 02:38 PM   #4
TheNutCase
Member
 
Registered: May 2016
Location: Columbia, South Carolina14
Distribution: Slackware 14.2
Posts: 334

Original Poster
Rep: Reputation: Disabled
The reason that I was asking the question I did was because when my printer isn't in power saver/sleep mode then hplip is able to display the estimated ink levels, plus it allows me to do things such align print cartridges, and/or scan documents or photos. As it is right now, the only "solution" that works is if I unplug the printer then plug it back in again.
 
Old 06-23-2020, 02:26 AM   #5
Labinnah
Member
 
Registered: May 2014
Location: Łódź, Poland
Distribution: Slackware-current
Posts: 182

Rep: Reputation: 107Reputation: 107
I don't know how to disable power save mode in printer. But maybe resetting usb will be enoungh as workaround.
Run as a root:
Code:
usbreset YOUR_PRINTER_ID

Last edited by Labinnah; 06-23-2020 at 02:28 AM. Reason: Details
 
Old 06-23-2020, 10:26 AM   #6
TheNutCase
Member
 
Registered: May 2016
Location: Columbia, South Carolina14
Distribution: Slackware 14.2
Posts: 334

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Labinnah View Post
I don't know how to disable power save mode in printer. But maybe resetting usb will be enoungh as workaround.
Run as a root:
Code:
usbreset YOUR_PRINTER_ID
I tried that and got:
Code:
bash-4.3# usbreset YOUR_PRINTER_ID
bash: usbreset: command not found
 
Old 06-23-2020, 11:01 AM   #7
michaelk
Moderator
 
Registered: Aug 2002
Posts: 20,123

Rep: Reputation: 3387Reputation: 3387Reputation: 3387Reputation: 3387Reputation: 3387Reputation: 3387Reputation: 3387Reputation: 3387Reputation: 3387Reputation: 3387Reputation: 3387
A quick search shows there are lots of people that have a similar problem. Once the printer goes into power save mode it does not automatically wake up.

According to the HP FAQ there are two modes i.e. sleep and power saving modes. Power saving modes turns the printer completely off which defaults to two hours. The FAQ does say it can be disabled either by the control panel or software. A quick look at the manual just shows status lights and not a panel so you are left with software or maybe via its embedded web server if so equipped (see 2nd link).

https://support.hp.com/us-en/document/c04183583

http://www.hp.com/hpinfo/newsroom/pr...tion_Brief.pdf
 
Old 06-23-2020, 02:48 PM   #8
Labinnah
Member
 
Registered: May 2014
Location: Łódź, Poland
Distribution: Slackware-current
Posts: 182

Rep: Reputation: 107Reputation: 107
Quote:
Originally Posted by TheNutCase View Post
I tried that and got:
Code:
bash-4.3# usbreset YOUR_PRINTER_ID
bash: usbreset: command not found
In current it is in usbutils package. If it is not present in 14.2 you can try to compile it from current slackbuild in 14.2.
 
Old 06-24-2020, 11:06 PM   #9
TheNutCase
Member
 
Registered: May 2016
Location: Columbia, South Carolina14
Distribution: Slackware 14.2
Posts: 334

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by michaelk View Post
A quick search shows there are lots of people that have a similar problem. Once the printer goes into power save mode it does not automatically wake up.

According to the HP FAQ there are two modes i.e. sleep and power saving modes. Power saving modes turns the printer completely off which defaults to two hours. The FAQ does say it can be disabled either by the control panel or software. A quick look at the manual just shows status lights and not a panel so you are left with software or maybe via its embedded web server if so equipped (see 2nd link).

https://support.hp.com/us-en/document/c04183583

http://www.hp.com/hpinfo/newsroom/pr...tion_Brief.pdf
How do I go about finding what my printer's IP address is?
 
Old 06-25-2020, 04:11 AM   #10
michaelk
Moderator
 
Registered: Aug 2002
Posts: 20,123

Rep: Reputation: 3387Reputation: 3387Reputation: 3387Reputation: 3387Reputation: 3387Reputation: 3387Reputation: 3387Reputation: 3387Reputation: 3387Reputation: 3387Reputation: 3387
Most routers have a configuration page showing attached devices and their IP addresses.

If you don't know how to login to your router a nmap ping scan will show devices on your network but you then may need to figure out which is your printer by trial and error.
 
Old 06-25-2020, 04:52 PM   #11
TheNutCase
Member
 
Registered: May 2016
Location: Columbia, South Carolina14
Distribution: Slackware 14.2
Posts: 334

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by michaelk View Post
Most routers have a configuration page showing attached devices and their IP addresses.

If you don't know how to login to your router a nmap ping scan will show devices on your network but you then may need to figure out which is your printer by trial and error.
My printer is connected directly to my desktop pc.
 
Old 06-26-2020, 10:59 PM   #12
TheNutCase
Member
 
Registered: May 2016
Location: Columbia, South Carolina14
Distribution: Slackware 14.2
Posts: 334

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Labinnah View Post
In current it is in usbutils package. If it is not present in 14.2 you can try to compile it from current slackbuild in 14.2.
I just updated 14.2 today, tried that command again - same result.
 
Old 06-26-2020, 11:46 PM   #13
TheNutCase
Member
 
Registered: May 2016
Location: Columbia, South Carolina14
Distribution: Slackware 14.2
Posts: 334

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Labinnah View Post
In current it is in usbutils package. If it is not present in 14.2 you can try to compile it from current slackbuild in 14.2.
I just updated 14.2 today, tried that command again - same result.
 
Old 06-26-2020, 11:57 PM   #14
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 7,151

Rep: Reputation: 4820Reputation: 4820Reputation: 4820Reputation: 4820Reputation: 4820Reputation: 4820Reputation: 4820Reputation: 4820Reputation: 4820Reputation: 4820Reputation: 4820
Quote:
Originally Posted by TheNutCase View Post
I just updated 14.2 today, tried that command again - same result.
It isn't a part of 14.2 and doesn't seem to be on SBo. You can try and grab the SlackBuild and source from -current and build a copy, but I have no idea if this will help your problem. I imagine this is a problem with the firmware of the printer, and I don't think changing anything on your computer will change it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] system freezes after power saver mode kicks in on desktop pandanuma Linux Mint 6 06-01-2017 03:57 PM
Samsung 2043BWX Monitor: Power Saver Mode notadoc Linux - Hardware 0 09-27-2016 09:52 PM
power saver mode sulekha Ubuntu 3 07-04-2010 07:38 AM
Etch and turning off screen saver knobby67 Debian 2 02-22-2007 08:04 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration