-   Slackware (
-   -   Help: Slackware 9 Install Boot Disks (

DigitalIce 07-23-2003 03:21 AM

Help: Slackware 9 Install Boot Disks
Ive tried many times to make a boot disk using slackwares provided rawrite and fail because it always comes up "permission denied" when i try to do this:
(in dos)
a=floppy drive

<y:\G:\isolinux\sbootmgr\> rawrite y:\kernels\bare.i A:

This reports a permisison denied error. Maybe im on the wrong path completly as I've never used linux at all (except for RH9 and Mandrake 9.1 that I just installed...which I figured out in 2 min how to install)

I tried just booting to the CD rom but that didnt work, which is why ive been on this quest to make a boot disk.

I read through some other help files and one of them stated that there should be a "bootsks" directory of some sort which i didnt find in my ISO that was burned to CD.

So now im lost and frustrated, and was really hoping I wouldnt be stuck with windows the rest of my life. Please help, thnx

BittaBrotha 07-23-2003 03:28 AM

The boot disk images are stored in the bootdsks.144 directory for 3.5" diskettes and the bootdsks.12 directory for 5.25" diskettes.

If you are creating the image from a Linux system, the following command should work just fine:

dd if=[image file name] of=/dev/fd0

You may need to change /dev/fd0 depending on your configuration.

Here is the syntax for RAWRITE:

C:\>RAWRITE [image file name] [destination drive letter]:

Hope that helps!

DigitalIce 07-23-2003 03:35 AM


Originally posted by BittaBrotha
[B]The boot disk images are stored in the bootdsks.144 directory for 3.5" diskettes and the bootdsks.12 directory for 5.25" diskettes.]
Yep, thats the directory I cant find.

I deleted the other installs of linux for now so I cant use them....and that rawrite command you stated is what I have been doing (see above) and reports the permission denied problem.

....still stuck

BittaBrotha 07-23-2003 03:39 AM

If you doing the Rawrite command from Win/Dos, then you shouldn't be getting a Permission Denied error, maybe some other error but not that one.

And of course if you're in Linux then you are doing it as Root user?

DigitalIce 07-23-2003 03:51 AM

tried it on the comp i wanted to install it onto in DOS and in XP under command prompt and gave me the same error. Even moved the bare.i file to my local HD and it still gave me the error. bash.I comes up on my system as a folder (not sure if its suppost to or not) and has 3 files inside. I can rawrite any single one of those files on their own just fine.....maybe it has something to do with bash.i being a folder???

Is there a ISO image somewhere on the web that i can just d/l to fix this?

BittaBrotha 07-23-2003 04:09 AM

You want to install Slackware 9.0 using floppy disk?

Here's what you should do.

1.) Go in the BOOTDISKs folder and get bare.i, if that's the one you want.

For example, to use RAWRITE.EXE to create the
bare.i bootdisk you'd put a formatted disk in your floppy drive and issue the following command:


2.) Then go in the ROOTDISKS folder and get two files, Install.1 and Install.2.

For example, to make the first rootdisk image (install.1),
you'd put a formatted 1.44MB floppy in your floppy drive, and then run this command:


and repeat for INSTALL.2 disk

Hopefully this should get you going.

If you want the boot/root disk again, try here!

DigitalIce 07-23-2003 02:10 PM

Thnx a lot BittaBrotha, solved my problem with that link. Seems as though my ISO never had those bootdisk or rootdisk folders. Now I can make it correctly.


BittaBrotha 07-23-2003 07:53 PM

My pleasure...

georg9 07-26-2003 06:07 PM

Re: Help: Slackware 9 Install Boot Disks
> <y:\G:\isolinux\sbootmgr\> rawrite y:\kernels\bare.i A:

> This reports a permisison denied error.

I have the strong suspection, that you are in a dos box of some win* o.s., rather than in real dos.

Try to find a boot floppy of msdos, or one of Caldera dos, and boot from it. Then this command will work.


Seifer Almasy® 10-27-2003 06:43 PM

I have a Slackware 9 and BARE.I is a FOLDER, dont IMAGE

Trying rawrite Y:\kernels\bare.i\bzImage a: (works for me)

cya :study:

PS: I newbie in linux

All times are GMT -5. The time now is 11:45 AM.