LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-19-2016, 12:33 AM   #1
sinar.kk
Member
 
Registered: Nov 2015
Location: Cochin , Kerala , India
Distribution: Slackware
Posts: 79

Rep: Reputation: Disabled
Unhappy Help Required On mulitib Setup while installing teamviewer for slackware 14.1 64bit


Hi all i have setup the multilib exactly as said in the http://docs.slackware.com/slackware:multilib --> the quick 'n dirty instructions.

And all went fine as per the documentation given over there , even The GNU libc libraries and The gcc compiler suite also got installed .

Then the next i took the slackbuild for teamviewer 11.0 from slackbuild.org repository

and when i try to run ./teamviewer.Slackbuild as root it shows the message

"Package for x86_64 architecture is not available."

What am i missing ??? can you all please help me
 
Old 01-19-2016, 12:42 AM   #2
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,704

Rep: Reputation: Disabled
launch the SlackBuild passing it the ARCH variable, like
Code:
ARCH=i486 ./teamviewer.SlackBuild
 
2 members found this post helpful.
Old 01-19-2016, 12:47 AM   #3
sinar.kk
Member
 
Registered: Nov 2015
Location: Cochin , Kerala , India
Distribution: Slackware
Posts: 79

Original Poster
Rep: Reputation: Disabled
@ponce i ran with the command as you said above but it ran until in the end it throwed the following errors

Quote:
chmod: cannot operate on dangling symlink './opt/teamviewer/config'
chmod: cannot operate on dangling symlink './opt/teamviewer/logfiles'
chmod: cannot operate on dangling symlink './usr/bin/teamviewer'
ln: failed to create symbolic link '/tmp/SBo/package-teamviewer/opt/teamviewer/config': File exists
 
Old 01-19-2016, 12:53 AM   #4
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,704

Rep: Reputation: Disabled
delete this line (107) from the SlackBuild
Code:
ln -s /etc/teamviewer $PKG/opt/teamviewer/config
and run it again.
 
2 members found this post helpful.
Old 01-19-2016, 01:01 AM   #5
sinar.kk
Member
 
Registered: Nov 2015
Location: Cochin , Kerala , India
Distribution: Slackware
Posts: 79

Original Poster
Rep: Reputation: Disabled
@ponce....Thank you so much ...it worked like a charm !!!!
 
  


Reply

Tags
multilib, slackware64, teamviewer


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing slackware 14 64bit from a mac on external hdd JaDaReload'd Slackware - Installation 1 09-02-2013 05:12 PM
Installing slackware 14 64bit from a mac on external hdd JaDaReload'd Slackware - Installation 1 08-08-2013 04:54 PM
[SOLVED] How I installed a dual-boot setup - FC 17 64bit and Windows 7 64bit rylan76 Fedora - Installation 2 12-12-2012 12:21 AM
Urgent help required - installing a USB port Printer to an HP Thin Client M@thi Linux - Hardware 1 07-31-2008 10:28 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration