LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-21-2010, 12:21 PM   #1
dbeck
LQ Newbie
 
Registered: May 2006
Location: MN State Univ., Mankato
Distribution: Slackware 12.2, CentOS 5.4
Posts: 22

Rep: Reputation: 15
help needed with acls and samba server


Hi - I over our Christmas break I moved a samba file server from Slackware 10.2 to 12.2 at a university where samba is used in a classroom lab setting. In the 10.2 machine I used to compile samba myself but for the new server I went with the slackware package v3.2.15. Both were the same versions but this one had acl usage enabled which I wasn't aware of. After the conversion everything looked good but later I found I had to reconnect the computers and when then when classes started the PROE app wouldn't start with accounts that existed prior to break - error message pointed to something in the registry. (I had used all the same samba related files except for the samba software.)

At this point, the problem seems to be related to acls. I don't (think I) need acls. It seems acls adds a layer of complexity that is not easy to decipher or manipulate with the old tools. Is there a way to turn it off for the whole system or is it just in this samba instance that acls could be causing the problem. I tried to disable acls in samba but I don't remember if that didn't fix the problem or caused a different one. I am also a little hesitant to do much experimenting with samba settings at this point in the semester.

Thanks,

Denis Becker
 
Old 01-25-2010, 02:45 PM   #2
cg40oz
LQ Newbie
 
Registered: Dec 2009
Location: /dev/random
Posts: 15

Rep: Reputation: 0
To remove acls all you need to do is open /etc/fstab and remove the acl option. Then do a mount -a.
 
Old 01-27-2010, 03:39 PM   #3
dbeck
LQ Newbie
 
Registered: May 2006
Location: MN State Univ., Mankato
Distribution: Slackware 12.2, CentOS 5.4
Posts: 22

Original Poster
Rep: Reputation: 15
Thanks,

I had to look at the mount man page to find where acls were turned on. I don't have the courage to try changing it right now but plan to test it out soon.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Why F5 is needed to refresh after uploading file to samba server UltraSoul Linux - Software 2 06-27-2009 10:22 PM
Samba: Right combo of file ACLs, & settings? slacky Linux - Server 0 01-24-2008 08:27 AM
Using Samba with ACLs drenze Linux - Server 1 10-19-2007 08:32 AM
Windows ACLs and FC5/Samba/rsync Unclesmiff Linux - Enterprise 1 02-23-2007 04:12 AM
Server/Samba Help Needed esage MEPIS 1 03-02-2006 04:31 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration