LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-11-2013, 12:30 AM   #1
srjdhkr96
LQ Newbie
 
Registered: Dec 2012
Posts: 3

Rep: Reputation: Disabled
Help me ...........no network interface


in the graphical interface of my slackware 14.0 i always get the notification no network interface on gui. it gets dynamic ip address while booting but i can't get option to see my ip address , subnet mask and default gateway from graphical interface. from command line its fine
 
Old 01-11-2013, 12:51 AM   #2
STDOUBT
Member
 
Registered: May 2010
Location: Stumptown
Distribution: Slackware 14.0/32bit + a T60p (2007-YS3) = YES
Posts: 260

Rep: Reputation: 60
You didn't specify whether this is a wired interface, but I'll assume so.
If this is a fresh install, you may need to "turn on" NetworkManager.
To do so,
Code:
chmod +x /etc/rc.d/rc.networkmanager
then run
Code:
/etc/rc.d/rc.networkmanager start
You'll need to do that as root. And just the one time.
 
Old 01-11-2013, 10:25 AM   #3
TommyC7
Member
 
Registered: Mar 2012
Distribution: Slackware, CentOS, OpenBSD, FreeBSD
Posts: 433

Rep: Reputation: Disabled
If you do use NetworkManager (which is the GUI network program I assume you're referring to), don't forget to disable /etc/rc.d/rc.inet1 starting on boot (that's the program that's been obtaining the DHCP lease for you as you state) since I hear that conflicts with NetworkManager.

Code:
chmod -x /etc/rc.d/rc.inet1
 
Old 01-12-2013, 08:39 AM   #4
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,175

Rep: Reputation: Disabled
Quote:
Originally Posted by TommyC7 View Post
If you do use NetworkManager (which is the GUI network program I assume you're referring to), don't forget to disable /etc/rc.d/rc.inet1 starting on boot (that's the program that's been obtaining the DHCP lease for you as you state) since I hear that conflicts with NetworkManager.

Code:
chmod -x /etc/rc.d/rc.inet1
That advice is not correct. You can (and should) leave that file executable. Just make sure that you do not have interface definitions in /etc/rc.d/rc.inet1.conf for the network interfaces that NetworManager should manage.
 
Old 01-12-2013, 04:53 PM   #5
TommyC7
Member
 
Registered: Mar 2012
Distribution: Slackware, CentOS, OpenBSD, FreeBSD
Posts: 433

Rep: Reputation: Disabled
Ah, thank you for the correction Alien Bob.
 
Old 07-01-2013, 11:23 PM   #6
raleeha
Member
 
Registered: Jan 2011
Location: Berlin
Distribution: Manjaro
Posts: 43

Rep: Reputation: 1
no network interface

Hi,

i have a same issue when trying to connect via NetworkManager. I did made the /etv/rc.d/rc.networkmanager script accessable and tried to start /etc/rc.d/rc.networkmanager start. When DHCPCD starts it tells me there where found a network interface.

http://pastebin.de/35163

Any suggestions would be appreciated. Many thanks.

raleeha
 
Old 07-02-2013, 12:07 AM   #7
STDOUBT
Member
 
Registered: May 2010
Location: Stumptown
Distribution: Slackware 14.0/32bit + a T60p (2007-YS3) = YES
Posts: 260

Rep: Reputation: 60
raleeha,

I'm not sure what you mean by "accessible". You should to make that script "executable".
Show us the output of the following command:
Code:
ls -lahs /etc/rc.d/rc.networkmanager
The output should look like this:
Code:
4.0K -rwxr-xr-x 1 root root 1.7K Aug 14  2012 /etc/rc.d/rc.networkmanager*
If you don't have the "x" in "-rwxr-xr-x", run this:
Code:
chmod +x /etc/rc.d/rc.networkmanager
...and you'll be good to go.

Otherwise, I recommend making your own thread...this one is marked as [SOLVED] ;-)
 
Old 07-02-2013, 08:57 AM   #8
raleeha
Member
 
Registered: Jan 2011
Location: Berlin
Distribution: Manjaro
Posts: 43

Rep: Reputation: 1
Hi, sorry when I wrote into a thread marked as [solved]. I will make my own thread better. But thanks again for reply STDOUT.

raleeha
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to prevent auto up an interface at /etc/network/interface file ? Joydeep Bakshi Linux - Networking 8 07-28-2011 02:43 AM
Fedora 13 Network Interface fails to connect after starting network manager crazy eddy Linux - Networking 2 06-15-2010 09:47 AM
How NET_TX_SOFTIRQ select network interface when multiple interface exits Mr.J Linux - Kernel 0 06-02-2009 11:17 AM
In FC6 network interface doesn't come up if 'service network restart' command is run rajat Linux - Networking 2 05-02-2007 11:53 PM
network interface (BCM4401-B0) hangs on hight network load indig0kid Linux - Hardware 0 03-09-2007 09:49 AM


All times are GMT -5. The time now is 08:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration