LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 10-02-2003, 02:17 AM   #1
carboncopy
Senior Member
 
Registered: Jan 2003
Location: Malaysia
Distribution: Fedora Core, Slackware, Mac OS X, Debian, OpenSUSE
Posts: 1,210
Blog Entries: 4

Rep: Reputation: 45
hde:DMA disabled at boot up. HELP!!!!


Hi!

I am getting really desperate on this. What could be a problem for a harddisk with UDMA6 to have it's dma switch off? Below is a fraction of my dmesg from 2.6.0t3 kernel.

When I did hdparm -t /dev/hde7
I get this results.

/dev/hde7:
Timing buffered disk reads: 64 MB in 37.02 seconds = 1.73 MB/se

My hde is an 80G 8MbCache Maxtor with ATA133. I connected it to my Silicon Image 680 PCI card as master on channel 1. I have another drive 30Gb with ATA133 as slave on the same channel. But it works fine.

How can I forced the drive to work in UDMA6? Is there something wrong with my harddisk? It works fine in Windoze XP and 2000.


<snip>
kjournald starting. Commit interval 5 seconds
EXT3-fs warning (device hdf2): ext3_clear_journal_err: Filesystem error recorded from previous mount: IO failure
EXT3-fs warning (device hdf2): ext3_clear_journal_err: Marking fs in need of filesystem check.
EXT3-fs: mounted filesystem with ordered data mode.
VFS: Mounted root (ext3 filesystem) readonly.
Freeing unused kernel memory: 176k freed
<snip>
hdf: dma_intr: status=0x51 { DriveReady SeekComplete Error }
hdf: dma_intr: error=0x84 { DriveStatusError BadCRC }
hdf: dma_intr: status=0x51 { DriveReady SeekComplete Error }
hdf: dma_intr: error=0x84 { DriveStatusError BadCRC }
hdf: dma_intr: status=0x51 { DriveReady SeekComplete Error }
hdf: dma_intr: error=0x84 { DriveStatusError BadCRC }
hdf: dma_intr: status=0x51 { DriveReady SeekComplete Error }
hdf: dma_intr: error=0x84 { DriveStatusError BadCRC }
hde: DMA disabled
ide2: reset: success
<snip>
 
Old 10-04-2003, 09:31 PM   #2
r_jensen11
Senior Member
 
Registered: Apr 2003
Location: Minnesota, USA
Distribution: Slack 10.0 w/2.4.26
Posts: 1,032

Rep: Reputation: 45
Can you boot into Linux properly? If not, then use root disks, then mount the directories needed to modify files (basically at the time when you started using fdisk for setting up your computer, you can mount and use PICO or whatever to edit files.) Then umount, and reboot.
 
Old 10-05-2003, 05:24 AM   #3
Cerbere
Member
 
Registered: Dec 2002
Location: California
Distribution: Slackware & LFS
Posts: 799

Rep: Reputation: 33
What are the outputs of:

hdparm -i /dev/hde

and

hdparm -i /dev/hdf

It is unlikely that only one of two drives on the same channel would have DMA enabled. Does your kernel support the Silicon Image 680? I know that my SIS motherboard only became fully supported with the 2.4.21 kernel, and I had to enable it when I compiled.

Enjoy!
--- Cerbere
 
Old 07-16-2004, 07:03 AM   #4
tcpip95
LQ Newbie
 
Registered: Nov 2003
Posts: 11

Rep: Reputation: 0
have you tried manually configuring it via hdparm to see if it will work at all?

hdparm -d1 -X70

If that works, you could then simply place this instruction in rc.local and have it execute on startup.


-d1 enables dma
-X70 sets UDMA 6
 
Old 07-16-2004, 08:14 AM   #5
carboncopy
Senior Member
 
Registered: Jan 2003
Location: Malaysia
Distribution: Fedora Core, Slackware, Mac OS X, Debian, OpenSUSE
Posts: 1,210
Blog Entries: 4

Original Poster
Rep: Reputation: 45
Sorry guys, I have found out the problem. At least I think I did.

It is the Silicon Image card itself. Now that I move both my 80Gbyte drive to the onboard IDE. no problem. Of course, after re partitioning and formatting everything.

Yeah, I found it weird too to have only one drive having dma problem, and it is everytime the other drive which is not root.

And also and extra note, I am getting the same speed reading from hdparm -tT /dev/ with the onboard IDE (ATA/100) and the pci-ide (ATA/133). Just weird. Anyway, the Silicon Image card is a low quality one I guess. Looking forward to get Maxtor card.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
hdd: DMA disabled grautu Debian 1 11-01-2005 10:02 AM
Harddisk Dma Disabled devansh Linux - Hardware 4 06-17-2005 12:17 AM
2.6.11.8 disabled dma xushi Slackware 5 04-30-2005 10:11 PM
dma disabled in Mandrake 9.1 marto Linux - Hardware 6 01-20-2004 05:21 AM
hde: timeout waiting for DMA rukasu Linux - General 4 09-29-2003 10:11 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration